1. Official MINIX forum

004 FIRMWARE - updated

Discussion in 'NEO X8-H PLUS 004 firmware via MINIX FOTA' started by danlat1415, Apr 4, 2015.

  1. Rui Oliveira

    Rui Oliveira Active Member

  2. vel tins

    vel tins Member

    I refuse to flash a full firmware via USB tool. This resets everything which is only acceptable, if you have bricked your device...
    I usually flash the "update.zip" from TWRP after editing the "updater-script" inside the update.zip.
    Since I`ve replaced/modified some System apps, the normal way via FOTA doesn't work any more.
    PS: flashing from TWRP also keeps root intact.
    So again, please upload the "update.zip"
  3. Manor

    Manor New Member

    Hi Ken,
    Don't want to be too pushy, you are doing a great job!
    But please take a look at the relevant discussion: http://www.minixforum.com/threads/firmware-request-samba-server.3882/
    about 3000 views and many customers that looks for the same feature.

    Again, many thanks for your support...

    Manor
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We know.
    As I have said many many times,
    our priority is to fixing problems,
    then adding extra features.
    sangaz, PhillyGTA and hugenay like this.
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You should take full responsibilities of your own decision.
    What you have done is equal to giving up our official support.
    Sydney likes this.
  6. vel tins

    vel tins Member

    I know, that nobody can or will support a modded box, but hey, that thing is almost "unbrickable", so I don't care too much.
    Additionally, any Android device without root? Impossible.
    (y)
    Last edited: Apr 8, 2015
  7. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    I just bought the Minix Neo X8-H Plus with 22-NOV-2014 firmware pre-installed.
    I did a USB burn to firmware version 002, then an FOTA upgrade to firmware version 003.
    Now I'm waiting for the firmware version 004 FOTA to be released/finalized.
    All good no problems there.
    I have successfully downloaded firmware 004 (Full system image w/Windows USB burning tool)

    Can I just do a full Windows/USB burn tool install of firmware 004 NOW, without waiting for the FOTA update to be available???
    I've just got the box so I have no previous apps/configurations to save, thus the question could I just install the downloaded 004 fw via Windows/USB burn tool?
    My understanding is, work is in progress with the FOTA process, but the full 004 fw install is OK and could be installed without waiting for an FOTA update....correct?

    Thank you for any information.
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    All my Android phones and tablets are not rooted, including my boxes of course.
    I fully understand the PROs and CONs and I decided to leave them non-root.
  9. vel tins

    vel tins Member

    ^^
    Well, each according to his taste.
    However, I've noticed that the firmware is available again via FOTA.
    Will flash it later...
  10. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    Upgraded to fw version 004 via FOTA and all went well. Approx 540MB download.

    Thank you Minix (y)

    Gbit Ethernet now gives me 820Mbits/s. Interestingly I was getting approx 790Mbits/s on fw ver 003 and only 370Mbits/s on fw ver 001
    I have WiFi Channel 13!!!!.. I smiled on either side of my face when I noticed it wasn't there in the original builds. :)
    Any thoughts on 68Mbits on connection speed 433Mbits 802.11ac when we also see 68Mbits on connection speed 150Mbits 5Ghz 802.11n.
    68Mbits WiFi real bandwidth is very usable, but would consider approx 150Mbits real bandwidth on 802.11ac a realistic goal.
  11. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Ethernet result is similar to our tests.
    WiFi could go faster than that @ 5GHz depends on the capability of the router.
  12. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    Ken,

    Cool. I'm game to explore any options to increase my 'real' WiFi bandwidth. ( I have no root access on the Minix box :) )

    Looking at my results:

    My tests are done using a QNAP TS-253 Pro NAS as an iPerf server on a 1Gbit LAN.

    An ASUS RT-AC66U router running TomatoUSB firmware with 1300Mbits connect speed using 802.11ac on 3 channels (80MHz) OR 450Mbits connection speed using 802.11n on 2 channels (40Mhz),
    will more than provide all the resources required for a Minix NEO X8-H Plus with a maximum 433Mbit connection speed using 802.11ac.
    The ASUS RT-AC66U is attached to a 1Gbit LAN as an Access Point (AP) router.

    A Linksys E4200v1 router running TomatoUSB firmware with a 5GHz interface with a max connection speed of 450Mbits on 2 channels (40MHz) again should provide all the resources a Minix NEO X8-H Plus would require when connecting via 802.11n 5GHz. (Obviously not 802.11ac as the Linksys E4200v1 doesn't support 802.11ac)

    I have old notebooks with Intel 7620 Wifi cards using the ASUS RT-AC66U at greater distances than 1metre and 'real' bandwidth of well over 200Mbits on 802.11ac (USB 2.0 bus for PCIe interface ..long story).
    On the Linksys E4200v1 a Sony Xperia C1905 phone using 802.11n 5GHz with a connection speed of 150Mbits has seen bandwidth peaks of 98Mbits and outliers of 105Mbits 'real' bandwidth.

    The Minix NEO X8-H Plus is using a single stream adapter and thus 433Mbits 'connection speed' limit over 802.11ac or 150Mbits over 802.11n 5GHz.

    As we all know a 802.11ac connection speed can never be obtained in real bandwidth as WiFi is half-duplex with overheads and as a rule of thumb will only obtain approx half the connection speed in real bandwidth.

    So if I connection to a Linksys E4200v1 using 802.11n 5GHz and the Minix X8-H Plus gives a connection speed of 150Mbits and the bandwidth is 68Mbits, then I accept that and just consider it a bit slow.

    If I connect to the ASUS RT-AC66U using 802.11ac and it indicates a 433Mbits connection speed, but only gives me the same 68Mbits bandwidth, I start to think there is something that could be improved.

    I've previously 'tuned' my WiFi interfaces with short and green-field(GF-BRCM) preamble, frame burst and a couple of other settings. Generally though 802.11a/b/g devices shouldn't impact 5GHz in the same way they can on 2.4GHz. So when using the Minix 5GHz 802.11n or 802.11ac I shouldn't see problems due to old 802.11a devices which only use 54Mbits 5GHz...because they're soooo old they don't exist these days and are only used in specifications to indicate support for 5GHz 802.11n. Beside, I'm the only one in the area using 5GHz WiFi. :)

    Also as my network uses channel 13 2.4GHz WiFi , I've only just got access to it with Minix fw 004 upgrade and haven't tested 2.4GHz WiFi yet.

    So that's my show and tell, now we just need to understand(even if it's just me) why the Minix X8-H Plus only gives 68Mbits real bandwidth over 802.11ac.
    And is there anything more I can do to improve the Minix WiFi throughput.

    The ASUS RT-AC66U indicates strong WiFi support and VERY well received in reviews and technical forums when it comes to WiFi throughput and I've not noted anything that would contradict that.

    I also have a Minix NEO X7 and I may swap the antenna over to see if there is any difference.
    Just for the record the Minix NEO X7 gives a connection speed of 65Mbits with bandwidth of 43Mbits download and 31Mbits upload using 5GHz 802.11n on the Linksys E4200v1 as seen using iPerf.
    I consider that quite acceptable considering the low 65Mbits connection speed of this devices WiFi adapter. Fast-Ethernet(100Mbits) on the Minix X7 is seen as ~90Mbits/s bandwidth.

    ___UPDATE___

    Tested Minix NEO X8-H Plus 802.11n 2.4GHz (20MHz) with a connection speed of 72Mbits and get 55Mbits bandwidth.

    My Tests are really weird.
    55Mbits on 20MHz 2.4GHz (802.11n) with connection speed of 72Mbits
    68Mbits on 80MHz 5GHz (802.11ac) with connect speed of 433Mbits.

    Thought maybe the Minix box was having trouble with channel bonding and set the ASUS router 5GHz interface to 20MHz and then 40MHz

    67Mbits on 20MHz 5GHz (802.11ac) with connect speed of 86Mbits.

    66Mbits on 40MHz 5GHz (802.11ac) with connect speed of 200Mbits.

    I can't break away from ~68Mbits on 5GHz in any channel bonded range using the Minix X8-H Plus... that is way weird.

    Can anyone confirm a 5GHz bandwidth greater than 68Mbits????.. in any configuration.

    Tried a Sony Xperia C2005 phone and get 105Mbits on 5GHz 80MHz 802.11n with connection speed 150Mbits. So router is still giving good throughput at 150Mbits connect speed.
    A notebook with a 7260 Intel WiFi card gives 193Mbits on 5GHz 80MHz 802.11ac with connection speed of 866Mbits. And that's good(me thinks) considering the WiFi card is on a 480Mbit shared USB 2.0 bus (Old Alienware M11xR1 notebook) so its absolute theoretical max could be no more than ~450Mbits.
    Last edited: Apr 9, 2015
  13. Healer

    Healer Member

    I have also a rt-ac66u and with half the wi-fi strength (it's in another room than the router) I see in android settings that is connected at 268mbit ( I think, not at home now) but never tested the real bandwidth.
    I have Berlin firmware installed on the router.
    I don't have any steaming speed problems, even on 30gb mkv.
    Anyway I have a problem that other members mentioned...
    When I'm streaming a file to minix and another device starts streaming something, my minix simply looses wifi connection.
    No other devices loose connection on this testings also using wifi.
  14. WeK05

    WeK05 Audio Visual Master Specialist

    There has been previous discussion about throughput being limited. It was a maximum throughput of 87Mbps - http://minixforum.com/threads/can-anybody-get-more-then-87mb-on-5ghz.3925/

    When you test throughput, how long are you running the test? For the Z64 Windows tests, I did it for 3 min.
  15. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    My experience with WiFi on the Minix X8-H Plus is pretty good if I overlook the max 68Mbits/sec (which I'm banging on about).
    I watched "Saving Private Ryan" streamed from my NAS as a (DVD) 720p mkv and it played through from beginning to end without any issues.
    I was using my 802.11ac WiFi notebook via the same WiFi AP while the movie was playing and again no dramas [pun noted]

    When I test via iPerf I'm just using the standard 10sec, but if I extend that to 180sec I still get ~68Mbits/sec.

    [ 5] local 172.nnn.nnn.nnn port 5001 connected with 172.nnn.nnn.nnn port 34396
    [ ID] Interval Transfer Bandwidth
    [ 5] 0.0-120.1 sec 967 MBytes 67.6 Mbits/sec

    [ 4] local 172.nnn.nnn.nnn port 5001 connected with 172.nnn.nnn.nnn port 34397
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.0-180.1 sec 1.42 GBytes 67.7 Mbits/sec


    I've tested on the following 5GHz routers/AP.
    • ASUS RT-AC66U router (Minix connection speed 433Mbits 802.11ac)
    • ASUS EA-N66 access point (Minix connection speed 150Mbits 802.11n)
    • Linksys E4200v1 router (Minix connection speed 150Mbits 802.11n)
    All the above give 64-68Mbits on 5Ghz (802.11n and 802.11ac)
    The good thing is that WiFi for me seems very stable with no drops/jitters noted (only had the box 2 days).
    The bad thing is, I just happened to note the max real bandwidth I can obtain is 68Mbits/sec, but Minix and some other people can get 80-100Mbits/sec. Grrrr. :D

    I have set preamble to long/short and green field on/off, frame burst on/off
    The few WiFi tuning changes I've made make no difference to the almost constant 68Mbits/sec.

    The bright side is I have a constant/stable 68Mbits bandwidth and given the Minix box is 32bit I can't use files over 4GBytes anyway.
    I can also faux the few apps that require WiFi, such that WiFi is not a requirement.

    Oh and as I've noted Gbit Ethernet is benchmark'd as 780-820Mbits/sec, so no complaints there. :D
  16. chrmar

    chrmar New Member

    After 004 update my Logitech Harmony Touch started acting weird on the Minix. every time I use the arrow keys (left, right, up, down) it makes two steps on the minix instead of one. This problem did not exist on FW 003. I have tried changing the settings on the harmony but nothing works. Do anyone else have the same issue?
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    My cheap hiwifi Gen.3 router (< US$60) can do >80Mbps with my 100Mbps line... testing to the Internet using Ookla. @ AC...
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    This is consistent with our results.
    The limit is by the clock of the SDIO channel, not the wifi chipset itself.
    And we've tested to stream a whole 46GB ISO movie file to play the whole movie without buffering in between.
  19. bmasencup

    bmasencup New Member

    Hey Ken, great work getting the audio problems fixed with the adaptive refresh rate. But, I have a new problem. Another poster mentioned it as well. Now my Logitech Harmony remote makes multiple keypresses when I use the arrow keys. No problems at all with fw003.
  20. WeK05

    WeK05 Audio Visual Master Specialist

    So, this is like taking a Ferrari or Bugatti to drive on a road with stringent speed limit of 55mph.