1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Beta Release 006 beta firmware

Discussion in 'Beta Firmwares' started by MINIX - Ken, Feb 26, 2016.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO U1 users,

    We are releasing this 006 beta firmware for testing purpose, hoping to make the official Fw006 release even better.

    This beta firmware has fixed the below problems and adding some new features, include:

    1.) Added the "Force RGB output" option for older TVs/displays (e.g. old Philips, SONY TVs)
    [Settings -> Display -> Force RGB output]
    Please note that you might need to restart your TV to take effect.

    2.) Fixed EDID detection error during system wakeup.
    (Fixed symptoms like green screen during wakeup on some displays)

    3.) Removed wake-lock from HDMI-CEC protocol.
    (Fixed the unable to go sleep issue with some non-CEC supported devices)

    4.) HDMI output status spoofing. (Tested with apps like Showtime Anytime)

    5.) Fixed viewing Ethernet data usage crashing problem.

    6.) Fixed watching YouTube live stream video/audio stuttering issue.

    7.) Added EXT4 file system support.

    Download link:
    http://www.minixforum.com/downloads/download.php?file=U1_FW006_BETA.rar
    (470MB)
    MD5 checksum: B966739D200C51B902118DC30BCC53C1

    Firmware flashing guide:
    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    Please feel free to test and provide us your valuable feedback.
    For problems not listed above, we are still working on them.

    NOTE: Beta firmware won't be able to update via OTA when official 006 firmware is released,
    we shall release also the USB .zip package as a compensation.


    Thank you very much for your participation and support!

    Thanks and regards,
    Team MINIX.
    simogold, David_Cole, vndunno and 6 others like this.
  2. DutchDiversion

    DutchDiversion Active Member

    Great list of fixes and new features, thnx!
  3. skynet

    skynet Active Member

    Ouch, many thanks Ken !
    Great features (y)
  4. midelpo

    midelpo New Member

    Hi @MINIX - Ken, you can add "wifi frequency band" in wireless options? Like this:

    [​IMG]
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We have to find out.


    Sent from my iPhone via Tapatalk
    DutchDiversion likes this.
  6. skynet

    skynet Active Member

    Hi Ken

    Sorry for asking again, but will think to provide a Samba server in FW006 final or another future release ?
    Thanks
  7. newbie99

    newbie99 Moderator Moderator

    sorry, but ken answered this question more then one time... e.g.
  8. deon10

    deon10 New Member

    Hello
    Does this erase APKs from the Minix? Meaning my Kodi, and all the addons, etc
    Thanks
  9. TonyL

    TonyL Member

    Might the youtube stuttering fix affect general video performance with other video players?

    Today I was using a news app and every time I played a youtube video embedded in it I would lose remote functionality. I lose cursor, back, arrow and home buttons. I have to use the ir remote to back out and the a2 remote doesn't work properly until I reboot the machine. Any chance this firmware may fix that?

    Otherwise I might wait for OTA.
  10. DutchDiversion

    DutchDiversion Active Member

    Yes, the flash will erase all user data and installed apps.
  11. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I tried and not seeing the same problem.
    It could be a bug of that specific app.
    The fix is targeting YouTube in-app live stream only, not other videos.

    Sent from my iPhone via Tapatalk
  12. skynet

    skynet Active Member

    Hi Tony, I checked it and it's working fine. Check your PM ;)
  13. deon10

    deon10 New Member

    Thank you! And sorry if this is obvious, i'm new to this. How about OTA with official releases? Is it the same or can I keep my data?
    DutchDiversion likes this.
  14. DutchDiversion

    DutchDiversion Active Member

    Never a dumb question. OTA with official will keep your data and not erase like full flash will.
  15. newbie99

    newbie99 Moderator Moderator

    but remember OTA will not work at beta...
    DutchDiversion likes this.
  16. Bloo

    Bloo New Member

    Dear Ken,

    If you have time, please fix the bluetooth range because it's 1 meter, no more, and it's not comfy at all for me to work on my open office stuff while trying to stay in range :cry: x 999,99
    (this happens with a Logitech K480. it's also sttutering, after a short press on a key, sometimes i get 5,6 letters instead of one :confused:)
  17. adam555

    adam555 New Member

    +1
    I have sound blaster JAM bluetooth 4.1 headphones and range is very poor.
    Bitrate of files or bitrate of wifi is coincides with breaking sound.
  18. TonyL

    TonyL Member

    Well it was the guardian news app, you might have a root around in there and play the videos they embed on their app. Admittedly, it could be on just the one news story for some reason. Sorry, I really don't have time to go around doing testing. I'll just report what my experience is and leave it to you guys to sort out.

    If you don't get the same results and it means you won't look into it, all I can say is you should be debugging your UI more because the problem is very real. I'm not doing anything exotic or unusual.

    The news story I was looking at had to do with a war movie and I wanted to see the trailer they had embedded on the page. I'll try to look again and be more specific but I'm busy at the moment, sorry.
  19. TonyL

    TonyL Member

    I'm with you guys, bt range is not great with my bt speaker either. I have an anker A7908 bt 4.0 and can get much better range with other devices.
  20. TonyL

    TonyL Member

    Okay, so it didn't take long. Go to the guardian movie section and look for any review. Most have youtube trailers embedded in them. I played one, the remote didn't fail right away, but it eventually did.

    Same as before had to reboot. I hope that helps! Please let me know if you need more info about what I have installed or whatever, I'll do my best.

    And as I said, this is with firmware 005.

    Cheers.