1. Welcome to the official forum for MINIX devices!

X8-H [0x30403003]UBOOT/Partition system/Download buffer/Data tranfer

Discussion in 'NEO X8-H, X8 Plus & X8' started by david durand, Oct 10, 2017.

  1. david durand

    david durand New Member

    Hi all,

    I was stuck on android logo (suddenly, no special operation or app install).
    After read some thread I decided to use the burning tools to flash a fresh fw (009).

    The box is recognize (when doing recover button+ power on) but the flash always fails at 22% with the following error:
    [HUB1-4][Err]--[0x30403003]UBOOT/Partition system/Download buffer/Data tranfer error

    here the log
    -------------------------------------------------------------------
    [11:07:27 946][HUB1-4][Inf]-------------ERASE FLASH-----------
    [11:07:27 946][HUB1-4][Inf]--disk_initial 1
    [11:07:27 946][HUB1-4][Inf]--Send command success
    [11:07:37 603][HUB1-4][Inf]--Read command status success
    [11:07:37 603][HUB1-4][Inf]-------------Download meson.dtb-----------
    [11:07:37 603][HUB1-4][Inf]--0-7-0-16
    [11:07:37 603][HUB1-4][Inf]-- download mem dtb normal 45056
    [11:07:37 603][HUB1-4][Inf]--Send download command success
    [11:07:37 618][HUB1-4][Inf]--Read command status success
    [11:07:37 665][HUB1-4][Inf]--Transfer complete
    [11:07:37 665][HUB1-4][Inf]--Send download get_status command succeed
    [11:07:37 665][HUB1-4][Inf]--get_status success
    [11:07:38 180][HUB1-4][Inf]-------------Download boot.PARTITION-----------
    [11:07:38 180][HUB1-4][Inf]--0-7-0-16
    [11:07:38 180][HUB1-4][Inf]--download store boot normal 8344218
    [11:07:38 180][HUB1-4][Inf]--Send download command success
    [11:07:38 195][HUB1-4][Inf]--Read command status success
    [11:07:40 036][HUB1-4][Inf]--Transfer complete
    [11:07:40 036][HUB1-4][Inf]--Send download get_status command succeed
    [11:07:40 052][HUB1-4][Inf]--get_status success
    [11:07:40 052][HUB1-4][Inf]--verify sha1sum 86f79b1dfe02ce997b154db216fe783e8a329b1e
    [11:07:40 052][HUB1-4][Inf]--Send verify cmd succeed
    [11:07:40 769][HUB1-4][Inf]--Get verify status success
    [11:07:41 284][HUB1-4][Inf]-------------Download logo.PARTITION-----------
    [11:07:41 284][HUB1-4][Inf]--0-7-0-16
    [11:07:41 284][HUB1-4][Inf]--download store logo normal 6891984
    [11:07:41 284][HUB1-4][Inf]--Send download command success
    [11:07:41 300][HUB1-4][Inf]--Read command status success
    [11:07:42 860][HUB1-4][Inf]--Transfer complete
    [11:07:42 860][HUB1-4][Inf]--Send download get_status command succeed
    [11:07:42 860][HUB1-4][Inf]--get_status success
    [11:07:42 860][HUB1-4][Inf]--verify sha1sum 59d38b6519a5066fbef37f119a2a52a9d3cd1a06
    [11:07:42 860][HUB1-4][Inf]--Send verify cmd succeed
    [11:07:43 468][HUB1-4][Inf]--Get verify status success
    [11:07:43 983][HUB1-4][Inf]-------------Download recovery.PARTITION-----------
    [11:07:43 983][HUB1-4][Inf]--0-7-0-16
    [11:07:43 983][HUB1-4][Inf]--download store recovery normal 8380086
    [11:07:43 983][HUB1-4][Inf]--Send download command success
    [11:07:43 999][HUB1-4][Inf]--Read command status success
    [11:07:45 856][HUB1-4][Inf]--Transfer complete
    [11:07:45 856][HUB1-4][Inf]--Send download get_status command succeed
    [11:07:45 856][HUB1-4][Inf]--get_status success
    [11:07:45 856][HUB1-4][Inf]--verify sha1sum 0748a1be286cd4f64e2dd88ce09a32c3f4c51060
    [11:07:45 856][HUB1-4][Inf]--Send verify cmd succeed
    [11:07:46 575][HUB1-4][Inf]--Get verify status success
    [11:07:47 089][HUB1-4][Inf]-------------Download system.PARTITION-----------
    [11:07:47 089][HUB1-4][Inf]--0-7-0-16
    [11:07:47 089][HUB1-4][Inf]--download store system sparse 844231480
    [11:07:47 089][HUB1-4][Inf]--Send download command success
    [11:07:47 105][HUB1-4][Inf]--Read command status success
    [11:08:43 718][HUB1-4][Err]--usbReadFile len=512, ret=-116 error_msg=libusb0-dll:err [_usb_reap_async] timeout error

    [11:08:43 718][HUB1-4][Err]--Download file failed, sequence 2047
    [11:08:43 718][HUB1-4][Inf]--Failure : 1, FailureMax : 3
    [11:08:43 718][HUB1-4][War]--[11:08:53 720][HUB1-4][Err]--IOCTL_WRITE_MEDIA_Handler,value=1000,index=10,len=65536,ret=-116 error_msg=libusb0-dll:err [control_msg] sending control message failed, win error: The semaphore timeout period has expired.



    [11:08:53 720][HUB1-4][Err]--Download file failed, sequence 2047
    [11:08:53 720][HUB1-4][Inf]--Failure : 2, FailureMax : 3
    [11:08:53 720][HUB1-4][War]--[11:09:03 735][HUB1-4][Err]--IOCTL_WRITE_MEDIA_Handler,value=1000,index=10,len=65536,ret=-116 error_msg=libusb0-dll:err [control_msg] sending control message failed, win error: The semaphore timeout period has expired.



    [11:09:03 735][HUB1-4][Err]--Download file failed, sequence 2047
    [11:09:03 735][HUB1-4][Inf]--Failure : 3, FailureMax : 3
    [11:09:03 735][HUB1-4][Err]--[0x30403003]UBOOT/Partition system/Download buffer/Data tranfer error
    [11:09:03 735][HUB1-4][Inf]--Close device handle 0x00000640
    -------------------------------------------------------------------

    I have tried different usb cable different usb port on different computer (win 7 and 10) but same problem. I am using a x8-h

    I also tried with the SD card solution , but nothing is displayed on screen.
    Can you please help! Now i have nothing except a black screen.....

    Thanks
  2. david durand

    david durand New Member

    By the way i tried different usb burning tools too.
    the one inside the fw bundle (2.0.6.2) but also 2.0.5.15 and 2.0.8. Everytime same problem which fails at 22%
  3. david durand

    david durand New Member

    someone please !!??
  4. Higgs

    Higgs Yellow Dude Super Moderator

  5. david durand

    david durand New Member

    thanks for the link.
    I managed to create a sd card and to boot on, but 20 sec after the upgading process has started it got stuck and the droid logo got a red X in front of him. It looks like the upgrqde fqiled for some reason... what can be the problem?? do you have an idea??
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Sorry, I'm neither a software nor hardware expert. I know enough to follow instructions and to google for things I want to know. Other than that I'm lost :unsure:

    One suggestion - try a different firmware image...
    midnight likes this.
  7. david durand

    david durand New Member

    thanks for ur help, but unfotunatly it did not work... I bought a new box. something else than this ****ing minix shit brand