1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

1080p50 stuttering playback

Discussion in '[Bugtracker] NEO X8/X8-H 002 beta 9 firmware' started by sportster, Oct 14, 2014.

  1. sportster

    sportster New Member

    Unfortunately seamless playback of 1080p50 MTS and MP4 files encoded with H.264 is not possible with Beta 9. There is severe stuttering with all players (XMBC, 4K Player, MXPlayer). I verified that Hardware acceleration is enabled. Stuttering is even much worse than with Beta 7, although I expected an improvement (I skipped Beta 8 due to it's instability). Stuttering is independent from display resolution (I tested 1080p50 and 720p50).
    Contrary to this, playback of 4Kp24 is smooth and reliable (Display configured to 1080p24).
  2. Jafte

    Jafte New Member

    Same for 1080p60 MTS using XBMC and MXplayer.
  3. sportster

    sportster New Member

    In the meantime I tested playback of 1080p50 MPEG-2 as well and compared it with older firmware betas.
    Beta 9: Stuttering comparable to 1080p50 H.264
    Beta 7: Much worse. Low framerate playback and severe stuttering
    Beta 2: Seamless playback without any stuttering.
  4. Ronald

    Ronald New Member

    Same problem here,

    I bought this media hub a month ago especially for his kind of files.
    The device is now only gathering dust... I hope there will be a solution soon.

    The files are from my Panasonic Camcorder:
    Video:
    Codec: H264 - MPEG-4 AVC (part 10) (h264)
    Resolution: 1920x1080p
    Frames per second: 50
    Coded format: Planar 4:2:0 YUV

    Audio:
    Codec: A52 Audio (aka AC3) (a52 )
    Channels: 3F2R/LFE
    Sample rate: 48000 Hz
    Bitrate: 384 kb/s
  5. sportster

    sportster New Member

    Clarification how H.264 1080p50 plays on specific Firmware Betas and Stock Firmware according to my tests:

    Stock firmware, Beta 2, Beta 7: Slight or Major stuttering. These type of files never played seamlessly. Amount of stuttering seems to depend on Encoder settings. See also this thread from August: http://www.minixforum.com/threads/bad-playback-1080-50p-files-mp4-why.315/

    Beta 9: Much worse. Severe stuttering. Did the new Amlogic SDK deteriorate the situation?
  6. Rslynn46

    Rslynn46 Member

    Are the minix team going to acknowledge this as an issue?
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Working on it.
  8. Rslynn46

    Rslynn46 Member

    Thank you
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Solved today. ;)
    WilfredG, sportster and Rslynn46 like this.
  10. Rslynn46

    Rslynn46 Member

    Excellent news good work guys!
  11. sportster

    sportster New Member

    Great news, thank you! When can we expect to get a corresponding Beta update?
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We are finalising it to final 002, no more beta. :)
  13. jk-nz

    jk-nz Developer

    I'm really looking forward to a version with the 50hz fix.
    This is the only major issue I have with the current FW (i'm still running pre-beta 9v3).

    Edit: I think the problem I have is only with 1080i 25fps video. Will upload a clip.
    Last edited: Nov 10, 2014
  14. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1080i 25Hz is not a proper standard.
    Video should either be 1080p 25Hz or 1080i 50Hz.
  15. WeK05

    WeK05 Audio Visual Master Specialist

    1080i50 = 1080i/25 (EBU standard). 50 refers to field rate, 25 is the frame rate. 1080p25 primarily exists only on consumer video devices.