1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

A2 CAPS button light does not turn on

Discussion in '[Bugtracker] NEO X8/X8-H 002 beta 9 firmware' started by Jesmond Spiteri, Nov 6, 2014.

  1. The thread name is quite self explanatory............Beta 8 OK. Beta 9 CAPS works but the light remains off on the keypad....
  2. MrReis

    MrReis Guest

    Your description of this bug makes perfect sense to me. I bought a NEO A2 and a NEO X8-H directly from MINIX US and the X8-H was loaded with Beta 7 firmware and the A2 "Caps LK" key LED worked fine, then it stopped working. I contacted MINIX US about it and they stated that they checked the "Caps LK" key LED on five of the A2s they had in stock and none of them lit when caps lock was enabled. They contacted the manufacture of the A2 and the "official" statement from the manufacturer was "there are [sic] no Cap Lk [sic] LED." The reply denied that the "Caps LK" key LED even exists! I saw it light with Beta 7 firmware but now I was being told by MINIX that the "Caps LK" key has no LED.

    Anyway just before the A2 "Caps LK" key LED stopped working because of a completely unrelated problem on the X8-H I was told by MINIX Hong Kong to upgrade the X8-H firmware to Beta 9 which I did. Now I realize that is when the A2 "Caps LK" key LED stopped working. I didn't connect "the dots." I didn't connect the X8-H firmware update to Beta 9 and the A2 "Caps LK" key LED failing to work until I read your post.

    Now I am trying to get MINIX (US or Hong Kong) to give me a link to the Beta 7 firmware image but I don't think they want to because there are "bugs" in it. Let ME choose the bugs I want.
    Last edited by a moderator: Nov 9, 2014
  3. The A2 Caps LK Led works ok with Beta 8. You can download it from forum and give it a try. For me, at the moment, Beta 8 works better than Beta 9-2. Hope to have a great final firmware v2.0 as all MINIX customers deserve it. I must say though it took time for MINIX to get to this point with the X8. A big thanks to MINIX and a huge thanks to the support forum as you give MINIX the soul it misses.. :)
  4. MrReis

    MrReis Guest

    Yes, I can confirm that when beta 8 FW (20140819) or beta 7 FW (20140722) as well as beta 'x' (20140530) is installed on the NEO X8-H the NEO-A2 "Caps LK" key LED lights when the caps lock function is enabled. I guess that there is a handshake between the A2 and the X8-H.

    The amazing thing is that when MINIX US asked the A2 manufacturer about the function of the "Caps LK" key LED the manufacturer responded "there are [sic] no Cap [sic] Lk LED." The manufacturer (who ever that is) doesn't understand the hardware nor the functionality of their own product!

    [​IMG]
    Last edited by a moderator: Nov 15, 2014
  5. On my A2 I have MINIX and I assume that MINIX has to support it not who manufactures it...Glad it works ok with BETA 8. Also it does not work with NEO x6.....
  6. MrReis

    MrReis Guest

    I'm not sure that MINIX US wants to support the A2. When I told them that the A2 "Caps LK" key LED does not light when caps lock is enabled they told me the manufacturer told them there is no "Caps LK" key LED which is a bold face lie. I guess they don't think it is an "important" enough problem to work on it and just want it to go away so they told me the manufacturer told them there is no A2 "Caps LK" key LED.

    I'm not sure that MINIX Hong Kong wants to support the A2 either. When I asked MINIX Hong Kong (John Scutt) how the A2 "Caps LK" key LED is specified to function their reply was "Caps LK – this is just to enable and disable ‘Caps Lock’. The LED should not toggle on and off when you press the Caps LK button." I guess that my NEO A2 air mouse is defective because as the above photograph shows, the A2 "Caps LK" key LED does in fact "toggle on and off when you press the Caps LK button" when X8-H beta 9 FW is not installed. Is this plausible deniability?
    Last edited by a moderator: Nov 15, 2014
  7. Ulises Rodriguez PhD

    Ulises Rodriguez PhD Active Member

    Hi Jesmond Spiteri and MrReis,

    I also own the MINIX Neo A2 Remote and apart from the "Gyroscope" Function that barely worked with Beta8, but never has worked with Beta9.2, my "A2" AirMouse and also the Keyboard have always worked flawlessly on the X8-H.

    Concerning the A2 Caps-lock Led problem, I would like to tell you, that I already have tested my A2 on others Android devices and also on a PC, and Yes I can confirm that the A2-Remote Caps-LK key LED lights up when the caps lock function is enabled!

    So apparently, the Led is there and also this Caps-Lock-Led works...

    Your Minix A2 Remote may be is Not defective, just to be fully sure, you can test it on a PC or any other Android device!

    Since, the Caps-Lock-Led works with Beta8 and Not with Beta9.2, the problem could be the firmware?

    Let's hope that MINIX will solve this little A2 problems, before they release the Final Firmware, that should be out soon!..
  8. MrReis

    MrReis Guest

    My hope is that MINIX first acknowledges that this is a beta 9-2 FW bug - they haven't done that yet. MINIX needs to understand this is a beta 9-2 firmware bug before they can fix it. I think that they believe problems like this (and X8 audio always being directed to the earphone jack and HDMI port at the same time) can only be caused by incorrect firmware update installation.
  9. yc1437

    yc1437 Member

    +1 Caps lock led no longer light up on beta 9

    Sent from my SM-G900F using Tapatalk
  10. This is very strange MINIX. The A2 costs a bomb(1/2 the price of the x5mini) and it consumes a whole lot of batteries and I expect that MINIX gives priority to issues within its own product line and make sure that MINIX devices work in harmony. It is of human nature that in-experienced people tend to buy everything of the same brand to make sure compatibility is next to 100% but it seems that a MELE-F10 works better at the end of the day. It is a shame we have this situation. Also the audio output shortcut key combination which works great on the x7 does not work on x8/x6 and it seems they will never work... Thank you.