1. Welcome to the official forum for MINIX devices!

After FW005 Audio dropout on all my movies with Dolby Digital

Discussion in 'NEO U9-H' started by The Matrix, Jul 2, 2017.

  1. The Matrix

    The Matrix New Member

    Hi,

    I am connecting my Minix U9-H to Onkyo AMP, and after I update to the latest firmware 005 and reinstall Kodi 17.3 I start noticing audio dropout on all my movies with Dolby Digital and the HD Audio also !!!

    I didn't face this problem in the previous firmware, Its just start now, so any suggestion or advice PLZ?

    Regards
  2. Runge

    Runge Member

    I'm experiencing the same problem, but also had this issues sometimes with firmware 004a.
  3. The Matrix

    The Matrix New Member

    Any solution for this bug?
  4. MrBig

    MrBig Active Member

    It's not a bug but rather a buffer adjustment needed for KODI. Look here:
    http://www.minixforum.com/threads/optimum-advancedsettings-xml-cache-settings.16450/
    Also, sometimes when you are experiencing these audio and video problems as well, it very well may be the source you are streaming from, or any one of the hops necessary to get to you. I find sometimes that even my aggressive buffering doesn't help with lagging internet connections. And I am Fiber 100 up and down.
    Dr Goodvibes likes this.
  5. The Matrix

    The Matrix New Member

    if the KODI was the problem I didn't face it in the previous firmware FW004 ?
  6. MrBig

    MrBig Active Member

    When you said re-install KODI, did you uninstall it and then re-install or did you update 17.3 over your old version?
    The fact is only a couple of users are experiencing this audio dropout with any version of KODI. That leads me to believe it is a configuration error.
    Please post your KODI audio setup configuration, what model ONKYO amp and how you are hooked up to that amp? This will better help solve the problem.
  7. The Matrix

    The Matrix New Member

    May be I forget to mention that I connected my U9-H using 1GB Ethernet wired cable to my PC and my networked HDD. the drop out was very clear with all DD movies when I playing AAC movies it was playing smoothly with any drop out !
    Its very clear bug because I was using Popcorn A400 media player and never face such a problem!
  8. The Matrix

    The Matrix New Member

    First thank you for your help

    I am always do a full reset whenever I install a new firmware and then I start reinstall all my apps again.

    Regarding my AMP connection I have ONKYO 608 connected to my Samsung TV and to the U9-H using HDMI cables.

    The KODI audio setup configuratio is:
    All the Passthrough were enabled
    DSP is off
    No of Channels are 5.1
    Output configuration is Best Match ( I'd try Optimized same problem)
    everything else in the Audio are default

    Do you need any more information?

    Regards
  9. The Matrix

    The Matrix New Member

    I just want another proof that the problem is from the new FW005
    On the previous FW004 I was using KODI and Minix SBMC and both were wroking flawlessly, although KODI was the only one to output the HD Audio because SBMC were always output the HD stream as either DD or DTS only!!!

    Now when I use Minix SBMC version some movies especially the UHD movies are working totally and for some HD stream no sound at all, thats all happend after installing the new firmware FW005!
  10. MrBig

    MrBig Active Member

    In KODI change your channels to 2.1, You have passthrough on, now check the appropriate dolby and dts settings that match your Onkyo 698. Also follow this to increase your buffer size: http://www.minixforum.com/threads/optimum-advancedsettings-xml-cache-settings.16450/
  11. wrxtasy

    wrxtasy Active Member

    And here lies the problem.
    2.0 refers to the number of Audio Data Transport Channels not the number of speakers. This is a very common mistake.
    2.0 Data channels is easily enough to carry compressed lossy/lossless AC3, DTS or HD passthrough Audio data to your AVR for it to decode and sort out.

    Suggestion:
    Reset all Kodi Audio settings back to default and only select the AC3, DTS or HD Audio passthrough options you want.
    Do not touch anything else. You may need to Quit Kodi and start it again.

    If you want 5.1 AAC Audio transcoded to 5.1 AC3 you can also try selecting the DD/AC3 Transcode option.

    FW005 introduced Android Multichannel PCM Audio output and this is why you now have problems with your incorrect Kodi Audio settings.
    Last edited: Jul 4, 2017
    Higgs likes this.
  12. Runge

    Runge Member

    Tried your suggestion but the issue still exists.

    I have previously increased my buffer size but this shouldn't have anything to do with since I'm playing all my video files from a NAS on my network connected via 1gbit ethernet (both NAS and U9) (no streaming from repos or such) and the audio dropouts are only present for Dolby Digital 5.1 encoded files, not DTS, TrueHD or DTS-HD MA.

    There's no audio dropouts if I use the built-in media player on my tv with the same video files.
  13. wrxtasy

    wrxtasy Active Member

    Confirming you do NOT have the Kodi Video Player option - Sync playback to display enabled ?
  14. Runge

    Runge Member

    This is not enabled, only Adjust Display Refresh Rate to "On start / stop".
  15. wrxtasy

    wrxtasy Active Member

    Try...

    Power Down the U9, Unplug, Now Plug power back in, then hold in the power button on the U9 till the Android Recovery screen Appears.

    Then simply Clear the Cache and reboot.
  16. Runge

    Runge Member

    All right, how much will be reset by doing this?
  17. wrxtasy

    wrxtasy Active Member

    It will only clear a temporary cache. No Apps or settings are wiped.

    Factory / Reset nukes everything back to a factory FW state.
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Checked, no problem with passthrough, please clear your Kodi app's cache & data.
  19. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Every time after OTA, you must clear the cache of Kodi,
    otherwise crazy things would happen!
  20. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You configured too many things,
    you only have to enable passthrough inside Kodi, and checked those options supported by your amplifier,
    nothing else...