1. Welcome to the official forum for MINIX devices!

Amlogic on/off (choice between no video or HD (720p & 1080p) stuttering)

Discussion in 'NEO X8/X8-H 002 beta 9 firmware (20141018)' started by jankoman, Nov 24, 2014.

  1. jankoman

    jankoman New Member

    Hi,

    Can someone tell me if there is a solution to this?
    I've been reading on so many forums that many people have this problem.

    If Amlogic codec is ON under Hardware acceleration, some videos only play sound, no video (screen is black), and if Amlogic codec is OFF, all video play, except HD videos will not play smooothly.

    Any solution? Some pople suggest it will be fixed in new firmware, but is that confirmed?

    Thanks everyone!
  2. jOOle

    jOOle New Member

    As told many times already, you need to give more informations about your system. Whats your firmware version, wich programs you use ...
    I can presume that you use 002 beta 9-2 and XBMC.
    If you use SPMC black screen is already reported and I think solution will be aviable in next firmware release.
    For now u can try http://www.minixforum.com/threads/v13-3-3-beta-minix-xbmc-for-evaluation.1926/
  3. jankoman

    jankoman New Member

    Hi jOOle,

    I am using Minix x8-h with 002 beta 9-2 (Kernel version 3.10.33 from 18 Oct 2014) and
    V13.3.3 BETA MINIX XBMC . (I had same problem with 13.1 MINIX XBMC on original firmware. What is SPMC?
    This problem occurs when playing video from hard drive, or from Navix, icefilms, IPTV... even youtube.
  4. jOOle

    jOOle New Member

    I occasionally had black screen with audio on IPTV but only in preview window, when I switch to full view all is ok.
    Semper Media Center (SPMC in short) is an unofficial spinoff of the official XBMC app.
    Do you use autoswitching?
    Did you flash beta 9-2 via .zip file or via OTG? I usualy use factory reset after flashing firmware.
  5. jankoman

    jankoman New Member

    Yes, IPTV with black preview is a regular thing as well. I do not use autoswitching. At least not intentionally.
    I flashed via OTG. I did not do factory reset.
  6. jOOle

    jOOle New Member

    Check in XBMC for autoswitching
    Settings - video - Playback - adjust display refresh rate to match video
    What frequencies are supported by your tv?
  7. jankoman

    jankoman New Member

    Thanks jOOle, it worked. Now the videos play smooth. Hehe. Cool
  8. jankoman

    jankoman New Member

    Oops, I was too fast. The movies from hard drive work, but home video files are slow... I have amlogic codec off. And I remember with original firmware with amlogic on it worked ok...
    Also, xbmc shuts down very often now, and if I turn amlogic on, I only get sound no video for any 1080p movies
  9. arel

    arel New Member

    This problem is NEVER solved on ALL Amlogic (s802, S89, clones nd whatever...) :-(


    It has something to do with the amlogic codec itself, which is part of the ANDROID SDK and so on...too much details, sorry ;-)

    If you own a M8 (S802) Box or an MXIII Box or something similar I recommend to check google for "Openelec on Amlogic devices". Some russian Coder built Openelec for these boxes....but (not yet) for Neo X8 :-(

    Under Linux the "Sound, but no video problem" ws solved .....

    I also was searching for month for a solution on "Android" ...but most "workarounds" (e.g. switch to SW decoding in XBMC or Kodi) is nothing less a sad "workaround" which for example makes these boxes for "live TV (e.g. IPTV)" in HD practical UNUSUBALE :-(

    Without HW decoding these boxes are senseless e.g. as a "low power" HTPC set top box...

    Hope some time a developer will go into detail to solve the above mentioned PROBLEM for Android/XBMC/KODI....

    kind regards
    arel
  10. jOOle

    jOOle New Member

    If it works from hard drive I can only suggest that u check your network.
  11. jankoman

    jankoman New Member

    regular files work from hard drive, but more demanding files (home video raw files from camera), also from hard drive do not work smooth.
    Also, with display refresh rate to match video on, XBMC crashes all the time. This sucks.

    Original Firmware with Original XBMC worked best so far (all HD videos including Amlogic codec on worked great and smooth), but I had a huge problem with slow buffering at that time...

    Now streaming works ok, but I cant watch hi-def video...

    I guess all I can do is wait for Firmware 2 with KODI 14... and hope they will fix it.

    Now I understand people who love APPLE so much because: "it simply works"!

    Because this box is definitely not for someone who is not technically advanced and is willing to play around with setting and constantly fix problems.
  12. jOOle

    jOOle New Member

    Think there are some post on forum about problems on videos from camera where is stated that problem is video are with variable frame rate and also have problems on most other devices. I dont know if is it true or not.
    Today is starting official 002 firmware over OTA and I recomend you to try it.