1. Registration issues have now been resolved. New accounts are able to be created

Android 6.0 Marshmallow and Kodi 17.* running

Discussion in 'NEO Z64A Custom ROMs, Kernels & Discussion' started by Miguelrk, May 28, 2017.

  1. dandi10

    dandi10 New Member

    Hi! It must be rooted or something? I did the above and when I choose to run from USB it just restart and goes up normally. If yes, can you send some info how to root it please?

    Hi, when i choose to run the usb it restarts and android runs normally. Does it needs to be rooted? If yes how to do it?
    Last edited by a moderator: Jun 14, 2017
  2. Miguelrk

    Miguelrk New Member

    It doesn't need to be rooted.
    is the usb pen formated in FAT32? - if so, try use another usb pen.
    does it boot on another pc? - you can try :) or even re-use an old pc to run android :)
  3. jordantheripper

    jordantheripper New Member

    I Miguelrk
    thanks for your works.
    I tried "live method" and it works great
    Only one information. May be that with this firmware, original remote control doesen't work?
    May be I have to download some app to let it works again?
    wait for reply
    thanks
  4. Miguelrk

    Miguelrk New Member

    Hello.
    I don´t use original remote.
    I use a "qwerty" :)
  5. m12m345m

    m12m345m New Member

    Any tutorial videos for this method?
  6. garyxh

    garyxh New Member

  7. dc-73

    dc-73 New Member

    I tried android 7...sound wasnt working. Maybe on a future build? I also tried the 64 bit version of android 6...it worked fine. The only reason i havent installed it permanently is because i am unsure if it will go to sleep. I read somewhere that its impossible if running from usb. Needs to be installed on intenal drive for it to work. Can anyone confirm that sleep works?
  8. garyxh

    garyxh New Member

    Thanks, it doesn't appear anyone else has anything to add. I will avoid v7 and install v6 instead as this seems to be more stable.
  9. yuhaizad

    yuhaizad New Member

    Hi. After install it i'm left with internal storage size of only 496MB, with only 131 MB free space. Did i do wrong? How to recover the internal storage which was initially 32GB?
  10. yuhaizad

    yuhaizad New Member

    Run the setup again, but this time i modified the partition first. Managed to get 25GB of internal storage.
    Also i found out that internet connection can only use wifi. How to recover the ethernet connection? 2nd thing is the display size is a bit bigger than my tv screen. How to resize it? Couldn't find any setting inside.
  11. dc-73

    dc-73 New Member

    When i tried it out, I found that the ethernet was still working. There was no icon. I didnt connect to wifi and i was still able to at least look at websites. I will have to give it another try someday.
  12. dandi10

    dandi10 New Member

    Hi! Yes, formatted and tried another pendrive. With one of them I see a few letter in the left side (like trying to run something) and then stop and boot normally..I have Z64 Android 64 bit. Do I'm missing something? What about installing Win 10?
  13. Rui Figueira

    Rui Figueira New Member

  14. yuhaizad

    yuhaizad New Member

    Did you find any way to enable the ethernet icon?
  15. dandi10

    dandi10 New Member

  16. HardwareGuru

    HardwareGuru Developer Administrator

    Ok guys here we go:

    I have to say this is meant for people who know what they do as i will not post pictures with it.
    Also i do NOT take any responsibility if something breaks!

    Tested on the android uefi bios, if you have windows please change it to the android version first!
    ** yes you can find it on the forum :D

    needed tools:

    gparted live image; https://downloads.sourceforge.net/gparted/gparted-live-0.29.0-1-i686.iso
    android x86 iso: https://www.fosshub.com/Android-x86.html/android-x86_64-6.0-r3.iso
    * do not try android 7 as it not stable!
    win32diskimager: https://sourceforge.net/projects/win32diskimager

    Connect a monitor to the z64 ( NOT A TV!) (the gparted live usb distribution does not support 16:9 resolutions )
    Connect a keyboard and mouse.

    Burn the gparted iso on a thumb drive.
    Boot the z64 while pressing F11.
    Choose the thumbdrive from the uefi boot menu.
    Follow the instructions till you get into the gparted debian linux part. ( mainly just pressing enter,enter,enter...)
    Within gparted remove all partitions ( YES ALL!).
    create 2 new partitions:
    - Fat32 10MB ( for the grub loader lateron)
    - ext4 as the rest (29000 or something like that)
    Press apply and let gparted do its job.
    power down/pull the plug.

    ok after that is done put the android iso on the usb drive using win32imagemaker.
    Insert the pendrive and boot the z64 while holding F11.
    Choose the usbpendrive from the uefi boot manager.
    select android x86 installer
    install on the ext4 partition.
    when it askes to install the grub2 loader press yes.
    when it askes to format the boot partition select yes.
    when the install procedure is done it will ask to reboot, pull the usb stuck and reboot.

    voila.. be patiant.
    first things to do is go into
    settings > app compatability > on
    settings > apps > browser > permissions > enable all
    Do this before installing apps from the playstore.
    Netflix for example will work only if you enabled app compatablity BEFORE INSTALL.

    Known issues:
    - back button on mouse will not work
    - hdmi scaling does not work ( set your TV to auto fit )
    - no resolution settings
    - no keyboard when having usb input devices ( not looked if it can be changed by settings )
    - no power on/off controll ( pull the plug to power down)
    - install a rotation locker app as this will autorotate apps to portrait when they are not suitable for landscape.
    probably there will be more but this i know about.

    Have fun..

    kodi 17 works, netflix works, youtube works, playstore works.
    There are probably a lot of issues but basics are there.

    Too be honest... personaly i would keep the original minix 4.4 for now...
    I post this to prevent bricked z64A's trying to install x86 on the internal storrage...
    midnight, kingsizept and Villa like this.
  17. dandi10

    dandi10 New Member

    Thank you for the info. Is there any chance to only upgrade to Kodi 17 and keeping for the meantime Android 4.4?