1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Android 8.0 upgrade?

Discussion in 'NEO U1' started by Bubba070, Feb 26, 2018.

  1. Bubba070

    Bubba070 New Member

    I have a Neo U1 with Lollypop 5.0 on it. Can/should I upgrade to Oreo 8.0?
     
  2. skynet

    skynet Moderator Moderator

    No you can't. No upgrade are planned (yet).
     
  3. ieswideopen

    ieswideopen Member

    Likely never.
     
  4. Adam Foreman

    Adam Foreman Member

    The only way the MINIX U1 will receive Marshmallow/Nougat or Oreo is by third party developers at XDA, Lineage OS etc.

    The only thing I would like is the ability to expand the internal storage using SD card or USB drive. Other than that, I don't really care.

    Sent from my Moto G (5) Plus using Tapatalk
     
  5. Gary Smith Aguero

    Gary Smith Aguero New Member

    Would it be possible to install Android Oreo Go?
    Supposedly it has been designed to run on outdated or low end equipme do and get all the latest software updates but on a very light version. I'm guessing this would also allow us to run the latest kodi.

    Has anybody tried it or know of a reason not to do it?
     
    Last edited: Jun 4, 2018
  6. skynet

    skynet Moderator Moderator

    You need Amlogic S905 divers for Oreo (API 26 & 27) and it's not available.
     
  7. Adam Foreman

    Adam Foreman Member

    Do you think that they will release them for the GO version of OREO? Otherwise I have no idea what the purpose of the GO version would be for

    Sent from my Moto G (5) Plus using Tapatalk
     
  8. skynet

    skynet Moderator Moderator

    I really don't know.
    However it should be a good idea for them to release it.
     
  9. Adam Foreman

    Adam Foreman Member

    Absolutely, currently Devs have to create apps to support older OS versions because of EOL support. By Google releasing the GO version will mean that even older devices will be brought up to date and make everyone's life easier right through the board.

    Sent from my Moto G (5) Plus using Tapatalk
     
    skynet likes this.
  10. Gary Smith Aguero

    Gary Smith Aguero New Member

    From what I have been reading, any device car run Oreo Go as long as kernel version is 3.18 or higher. I believe mine is 3.10. is that limited by the AMLogic as mentioned by @skynet?

    I've seen on other posts where they are manually upgrading the kernel to suit LiberElec, so I was hoping we could do the same. Although better coming from the MINIX develpoers!
     
    kingsizept likes this.