1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Custom ROM Android TV on NEO U1 !

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by MichiMess, Sep 16, 2017.

  1. MichiMess

    MichiMess New Member

    Aaargh :(

    Netflix considers these Streaming Media Players to be only ones certified to play Netflix HD video:

    There’s also initial reports from CNX-Software that the new WeTek Core will be able to play Netflix HD video, but not 4K as of yet.

    If you’re looking for your favorite Android TV box on the Netflix HD Android TV list, don’t bother. Android TV boxes like the MINIX NEO U1 or Zidoo X1 don’t run the official Android TV OS, so Netflix doesn’t consider them in that category either.


    Source:
    http://androidpcreview.com/netflix-hd-android-tv-box/
     
  2. JJ-KwiK

    JJ-KwiK Active Member

    @MichiMess - that info is dated man. See my previous post. My ATV ROM for the U9-H supports HD Netflix and 5.1 audio. It can work as long as you have the right DRM.
     
    midnight likes this.
  3. MichiMess

    MichiMess New Member


    This one i can see it at the home screen, but it doesnt start.
     
  4. Marty

    Marty Moderator Moderator

    I ported the kernel from the U1 into the boot.img which I assume rectified the Ethernet issue. Note that I used the AM1 which has Ethernet whereas the AM2 is WiFi only.

    Busy porting as we speak, it is actually very nice, I can confirm WiFi, Bluetooth and Ethernet are working, doing some polishing now. These guys really create cracking ROM's, the tools in this Marshmallow ROM are awesome.
     
    JJ-KwiK likes this.
  5. JJ-KwiK

    JJ-KwiK Active Member

    @Marty - Ah, I didn't know the A2 was wifi only. That may have been the cause of my frustration. I don't own the U1, so it's a little hard to test some things.

    Happy to hear some U1 users will have Marshmallow at some point.

    @MichiMess - Try downloading a clean version of the ATV Netflix from Aptoide and try again.
     
  6. John dejevij

    John dejevij New Member

    Thx for this ATV AM1 version, could not resist to give it a try. as such it runs very well indeed.

    Will flash back to something else though, since my main usage is Netflix and Youtube and with both of them I encounter issues.

    As already mentioned by Michimess, Netflix runs in SD which makes the subtitles take up 25% of the screen (they do in my country at least, horrible).
    I have tried several apk´s from this Board and from Aptoide, but they either are SD or do not start at all.

    Youtube wil not let me Login, so no subscriptions, favorite channels etc rendering it for me useless as is.
     
  7. wrxtasy

    wrxtasy Well-Known Member

    Yes but the U1 has no Widevine L1 DRM or HDCP 1.x both of which Netflix requires for even 720p streaming.

    You can get 720p Netflix streaming if you dual boot to alpha versions of LibreELEC Kodi Leia and do some DIY on S905/S905X devices.
     
  8. JJ-KwiK

    JJ-KwiK Active Member

    Ah. I just assumed yes to both. I don't own a U1, and assumed it had the proper drm/requirements based on the way everyone was talking.

    I did write," as long as you have the right DRM".
     
    Last edited: Mar 2, 2018
  9. Marty

    Marty Moderator Moderator

    Can you test Netflix now, I have enabled widevine in the build.prop no idea why they would have this disabled to begin with.

    I have added the Minix Power Settings and Netflix shortcuts on the home screen. I have also included an app called Tv App Repo which will allow you to add your own shortcuts for sideloaded apps if you so please. I noticed that you could re-arrange the shortcuts with a long hold of the OK on the A2 Lite remote, pretty nifty. I have replaced Kodi with SPMC, far more superior in my opinion as it utilises the amcodec.

    Two things to do after install:
    1 - Settings/More settings/Display/Additional action - set to Hibernation
    2 - Settings/Playback settings/HDMI self-adaption - switch to on

    Last remaining things to do is allow wake from Hibernation, at the moment you need to hit the power button on the box to wake it, if you leave the setting 1 above on Sleep then the Blue LED remains illuminated. The OK button on the stock remote does not work? Fine with the A2 lite? These I will play with if NetFlix is confirmed playing in HD, otherwise there is no point in moving forward with this.

    Again this is a free file hoster so grab it while you can, not sure how long they will host it for!!

    https://nofile.io/f/Hyxb9S91Kjr/AM1_0.0.7.tvMARTY.zip
     
  10. JJ-KwiK

    JJ-KwiK Active Member

    Awesome work.

    I modified the kl files for the minix A2, A2 Lite and A3 remotes to work with ATV (fixed the OK button and mic button if your remote has a mic). I can't remember if I patched the stock remote kl file. You can grab them from my U9-H thread if you want them.
     
    Last edited: Mar 3, 2018
  11. MichiMess

    MichiMess New Member

    Great work man! But Netflix is still not playing in HD :(

    Is there any other way to get Netflix in HD?
     
  12. John dejevij

    John dejevij New Member

    For the moment I have returned to stock FW13. When I use the Netflix_v5.3.1_HD.apk you can find on this Board I definitely have a higher resolution then SD (it does not come close to the quality Netflix on my Shield offers though)
    and the subtitles are in the size and font they should be.
     
  13. SaEt9000

    SaEt9000 Member

    @MichiMess @JJ-KwiK @Marty
    sounds really interesting to me what you are doing here.
    Some basic questions to be sure that i understood everything right so far:

    • the custom rom is based on a android 6.01 (android TV) - rigth?
    • the widevine DRM is enabled now, what about playready - is there something possible?
    • @Marty : is SPMC 17.x running as well as in your special SPMC-custom Rom?
    I am hesitating testing your rom because I am using the fineless Bob custom Rom 1.0 and it works very stable and smooth for me.
    Improvements are only thinkable regarding SPMC 17.x and playready-compatibility (and maybe the dolby-compatibility of some kodi-streaming addons as netflix in kodi 18)

    The missing framerateswitch in kodi 17 and 18 I could enable by implementing the frameratswitcher addon 2.05.

    If it only would be easier to backup and restore full images on minix....

    Thanks for your work and passion for our device (y)

    SaEt9000
     
  14. JJ-KwiK

    JJ-KwiK Active Member

    @SaEt9000 - The ATV ROM @Marty posted is Lollipop. I believe he is working on a standard Marshmallow ROM though, but I could be wrong. If not, I'd be willing to make a regular Marshmallow ROM and an ATV Marshmallow ROM if Minix or someone was willing to donate a U1.

    Widevine L1 is absent in this ROM. L1 can only be added by the manufacturer.

    Use TWRP to create a backup of your current setup. Try this ROM. If you don't like it, reflash the finless ROM and restore your backup. Super easy.
     
    Last edited: Mar 11, 2018
  15. SaEt9000

    SaEt9000 Member

    Thanks for your response.

    I understood marty in #29 that he had enabled widevine now - the U1 is widevine-ready by he manufacturer with its normal firmware.

    However - i think it makes sence to test the ROM. Thanks that you mentioned twrp. I found yesterday a twrp for the U1 at freaktab.

    http://freaktab.com/forum/tv-player...u/568330-unofficial-twrp-3-0-2-0-minix-neo-u1

    I will try it soon and hopefully faster able to switch between the ROMs. ;)

    SaEt9000
     
  16. Marty

    Marty Moderator Moderator

    The U1 only has L3 Widevine so it will not help for Netflix HD, as stated by @wrxtasy above in post #27 L1 is needed. Unfortunately I have to abandon the cause :-(
     
  17. xuw

    xuw New Member

    im testing this android tv firmware out on my U1, and it seems nice so far. really good work!

    a few bugs that i'm trying to figure out, maybe someone could help? all help is appreciated =)

    #1 - NETFLIX (com.netflix.ninja) for Android TV
    - anyone got this working yet? app went black screen and exits, as mentioned here before. after i tried adding a set of Widevine files found in freaktab forum (cant post links, not enough posts..) and adding the appropriate build.prop settings, the Netflix app now actually starts but gives the "this version of netflix app is not compatible with your device (-13)" error popup, from CONFIG_DEVICE_NOT_PERMITTED(-13) in netflix's StatusCode.java. Would emulating another device be possible for this? I tried changing ro.build.id/ro.product.model/brand/etc to Nexus Player, but the Netflix app gives same the error.
    (Netflix for mobile works nicely (com.netflix.mediaclient) versions 4.16/6.5.0 at least)

    #2 - A local live streaming app (for mobile originally)
    - i've been using this app with my U1 for a long time, but with this Android TV rom it won't hide the overlay bar, which covers parts of the screen.
    (possible surfaceflinger problem? -> logcat is spitting out 10 x "D/SurfaceFlinger( 2862): Hint osd video omx, need skip 3d,layer name is SurfaceView" every second)
    20180614_192313.jpg
     
    Last edited: Jun 14, 2018