1. Welcome to the official forum for MINIX devices!

Any suggestions for a NEO U9-H stuck at 9mbps?

Discussion in 'General Android Discussion' started by Mr Snappy, Oct 7, 2017.

  1. Mr Snappy

    Mr Snappy New Member

    Soooo....
    I am new to the game, but pretty tech savvy. I bought the U9-H and its been fun. Even figured out how to load builds on to Kodi!

    Here is my pain. I run a speed test and the box will not go higher than 9.4Mbps both up and down speeds. I am running ethernet cable to it. This is the same cable that brings 275Mbps consistently to my PC sitting not 3 feet from my Minix box. I even tried to use Wifi and get the same 9.4Mbps speed.

    Today, I updated my Xfinity router box. I then called Comcast and we walked through everything they could see and could not find any thing wrong. I am running this with normal config and a Dynamic-auto setting, the same as out of the box. Comcast suggested I contact Minix and request Ports and protocols. I can't even find on the Minix setting the option to choose port types.

    So that's the story. Anyone have any suggestions?
  2. Mr Snappy

    Mr Snappy New Member

    Disregard. It was a bad ethernet splitter.