1. Registration issues have now been resolved. New accounts are able to be created

Audio drops intermmittently with both Google Play Music, Pandora and XBMC

Discussion in '[Bugtracker] Official 002 firmware' started by tpcemit, Dec 8, 2014.

  1. tpcemit

    tpcemit Member

    I am using firmware 2.0 with XBMC 13.3.3beta6 (with frame rate switching on). When attached to an amplifier (on both a Pioneer and Onkyo) audio will drop out multiple time during playback of all video files. I can confirm the video does change to 24hz. I have utilized 2 different HDMI cables and attached to 2 different receivers to 2 different TV's. I have clean installed it multiple times throughout the beta process and now with final 2.0 firmware. This has happened ever since the frame rate switcher was introduced on multiple Minix XBMC's in all beta firmwares since the switcher. Also, when I manually set the Minix X8H to 24hz in the settings, no audio dropout is heard. In addition, when the frame rate switcher isn't utilized at all, audio is also fine. I would greatly appreciate your feedback, and I hope this is remedied, for I have also purchased the plus version. Thanks.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    There should be no more need for the use of switcher?
    We've integrated the feature to BETA 6 already.
  3. tpcemit

    tpcemit Member

    I'm 100% aware that it has been integrated. That is what I'm using. I was just trying to get across that when it wasn't integrated it dropped audio. Now that it's integrated it still drops audio.
  4. tpcemit

    tpcemit Member

    I guess I'll just have to live with it? No response? It's either the built in frame switcher, firmware or a faulty MINIX box. None of these are good. When I get my plus box tomorrow, I will test it to see if it does the same thing. If so, obviously a problem with software/firmware.
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You can't expect us to reply you all the time.
    We do read and will look into that.
  6. tpcemit

    tpcemit Member

    I have received the plus box and can confirm that every time I place the box in 1080p 24hz mode, the receiver it is hooked to drops audio intermittently. This is placing it manual or using the frame switcher built in XBMC 13.3.3 beta 6. So....2 different boxes, 2 different receivers and 2 different HDMI cables all with the same result.
    dquillman likes this.
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Can you check using stock 4K player instead of XBMC and report back?
  8. tpcemit

    tpcemit Member

    I can confirm that the stock 4K player drops receiver audio only when the box has been manually set to 1080p 24hz mode. I also moved the file from network to local to eliminate that. So, in conclusion it drops audio in 4K player, MINIX XBMC and the newest Kodi RC2.
    dquillman likes this.
  9. tpcemit

    tpcemit Member

    I also have another box made by a hard drive company that pushes out the 1080p 24hz through the same receiver/TV combos with no troubles.
  10. tpcemit

    tpcemit Member

    Just for your knowledge, I also noticed a few having a similar problem in the frame rate/refresh rate discussion on the main X8-h/X8 thread. It is on the last page.
    dquillman likes this.
  11. tpcemit

    tpcemit Member

    I tested something else out. I hooked box up to receiver via optical audio and straight to TV with HDMI....no audio dropout with frame switcher on. Straight to TV with just HDMI....no audio drop. Again, straight to receiver with only HDMI..audio drops again. I'm no expert, but it seems when both MULTICHANNEL audio and video are travelling through the HDMI it drops. When its just stereo and video, it doesn't. Just something to think about.
    dquillman likes this.
  12. tpcemit

    tpcemit Member

    It is still present in firmware 2.0A. Just so you know.
    dquillman likes this.
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You should check both cables between the hub, the receiver and the TV. On our side it's working fine @ 24Hz with a YAMAHA receiver and LG TV. Thanks.
  14. tpcemit

    tpcemit Member

    What I don't understand, is why does it play flawlessly @ 1080p 60hz? You are saying my HDMI cables are fine for that but not 24hz. That doesn't seem to make sense. What does make sense is that both MINIX boxes I have, do exactly the same thing on both TV's with 4 different cables. I have also read in different threads it is happening to others. We really must have a lot of bad HDMI cables. I will try what you say and probably reply with the same outcome. Thanks.
    dquillman likes this.
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I think the actual question should be:
    Why does it play ok not through the amplifier? Maybe your amplifier's calculation doesn't respond to the switching? Possible?
  16. tpcemit

    tpcemit Member

    Well, that would mean 2 separate amplifiers (pioneer/onkyo) are doing the same thing. One, not a problem, two, kind of a problem. I would buy a brand new amplifier but I don't have that much disposable income.
  17. tpcemit

    tpcemit Member

    Also, as said before, I have a WDTV live that switches and I have no audio dropout on both receivers.
  18. Jönke

    Jönke New Member

    I also had dropouts with default sync method in xbmc , changed it and dropouts are gone
  19. tpcemit

    tpcemit Member

    Also have a raspberry pi that hooks up to same receivers/ cables...no audio drops at 24 hz...very interesting.
  20. Tengujin

    Tengujin Member

    Confirmed audio dropouts when frame switcher activates if video stream is 24fps but output is set to 1080p/50hz. Dropouts usually occur during the first 5 minutes of any stream (either local or internet)
    Have been testing this with official xbmc gotham 13.2, kodi 14.0 rc3, and minix xbmc 13.3.3 beta 6 to 8
    No dropouts when video stream is native 25fps, so frame switcher does not activate.

    my setup:
    X8-h via hdmi to onkyo receiver,
    TV Sony bravia w4000 via hdmi to receiver
    X8-H set on passthrough