1. Welcome to the official forum for MINIX devices!

Box keeps giving no video after a while

Discussion in 'Official Firmwares' started by DarrenNewsgroup, May 29, 2017.

  1. DarrenNewsgroup

    DarrenNewsgroup New Member

    I have a U9-H (firmware 004A) with A3 remote connected via HDMI to my Pioneer AV amplifier which then goes to my TV via HDMI.

    I have not used this box much but recently I have noticed that the video picture (and sound) disappears after many minutes. I can't be certain but it's about 10+ minutes. Has anyone else got this problem?

    My Pioneer has a red light when it is receiving a valid video signal and this light goes out and my TV says no signal received. I have just watched a DVD on my DVD player for over 90 minutes no problem so I don't think it is the AV amplifier (although it could be the HDMI cable or the HDMI input on the AV amplifier). The U9-H box does feel quite warm but not too hot. I can keep my hand on the top of it without burning my hand. There is plenty of ventilation around the box. The only way I could get the red light back was to remove the power lead from the U9-H and reinsert it and turn the box back on again.

    Does anyone have any suggestions?
    Thanks
    Darren

    Sent from my LG-H815 using Tapatalk
    Last edited: May 30, 2017
  2. MrBig

    MrBig Active Member

    Sounds like the U9 is going to sleep. Check your settings.
    set HDMI-CEC to off, set one key power to off
    Go to Display/Daydream/When to sleep, change to never.
    I would also check your tv power saving settings
  3. DarrenNewsgroup

    DarrenNewsgroup New Member

    thanks I will try that and report back.

    I've updated my original post with some extra info that I forgot to mention at the time.

    Sent from my LG-H815 using Tapatalk
  4. DarrenNewsgroup

    DarrenNewsgroup New Member

    Ok, I had HDMI-CEC off before, power key definition was set to suspend and resume, display/daydream/when to sleep was set to after 6 hours inactivity.

    I've now set them to your suggested settings.

    I'll keep people posted if the problem occurs againwith these settings.

    Thanks
    Darren

    Sent from my LG-H815 using Tapatalk
  5. DarrenNewsgroup

    DarrenNewsgroup New Member

    Well that was quick. I made the settings changes and then tried to play Real Racing 3 as I am trying to get the A3 remote to work as a game controller. Anyway, about 2 minutes in to trying to get real racing 3 running the display went blank again and my Pioneer red light went out. I then turned my YouView box on, switched my Pioneer to the YouView input and the TV started displaying my YouView signal and the red light came back on. I then switched back to the U9-H and no red light and the TV says no tv signal. Interestingly the U9-H is relatively cold to the touch, much cooler than when I created this thread.

    I am thinking about a factory reset soon

    Sent from my LG-H815 using Tapatalk
  6. DarrenNewsgroup

    DarrenNewsgroup New Member

    Ok, I found another thread that says to go to developer options and disable standby there.

    The option I set was developer options/general/stay awake=on

    Hopefully this might be the answer.

    Sent from my LG-H815 using Tapatalk
  7. MrBig

    MrBig Active Member

    I've experienced many faulty HDMI cables. So try swapping HDMI cables, to rule out the cable.
  8. DarrenNewsgroup

    DarrenNewsgroup New Member

    That didn't fix it either

    I then put a new HDMI lead into the U9 and fed it into a different HDMI port on my Pioneer but I still did not get the red light or a video signal on the TV. I then put this new HDMI cable direct from my U9 to my TV and still got no signal. From this i conclude that it is not my HDMI lead, my Pioneer or my TV that is faulty (although still possible).

    I rebooted the U9 but this time I have moved the A3 remote dongle to a different USB port and also removed my Ethernet cable so am running off Wi-Fi now. Let's see if they make a difference.

    Sent from my LG-H815 using Tapatalk
  9. DarrenNewsgroup

    DarrenNewsgroup New Member

    Just tried that but it didn't work.

    I'm going to do a factory reset and see what happens.

    Thanks for the help.

    Sent from my LG-H815 using Tapatalk
  10. DarrenNewsgroup

    DarrenNewsgroup New Member

    one last try before a factory reset...I noticed that someone's I got "update& backup" stopped working so I went into settings/advanced settings/apps/update& backup/force stop/clear data. I then rebooted (shut down power off and pressed the power on button) and put youtube on auto play. I'm off to bed now so I'll see if youtube is still playing in the morning.

    Sent from my LG-H815 using Tapatalk
  11. DarrenNewsgroup

    DarrenNewsgroup New Member

    When I came down in the morning the box was still on, red light on my Pioneer and a picture on the TV. I tried plaguing real racing 3 and after a few minutes the picture died again, no red light on my Pioneer. In other posts people mentioned standby with a green light on the u9, my box still has the bright blue light on it. Does this mean the box is still alive? If so why no HDMI output? I had disconnected the HDMI cable and swapped it for another one before so if there is some sort of reset/initialization on plug entry it did not seem to do anything for me.

    Sent from my LG-H815 using Tapatalk
  12. DarrenNewsgroup

    DarrenNewsgroup New Member

    I did a factory reset from the settings menu. After the reboot I downloaded real racing 3 and stated it again. After a few minutes the box stopped again, I.e. Blue light on the u9, no red light on my Pioneer, no tv signal.

    Not sure what this really means now. Surely an app can't do this to an android box? What is going on?

    Sent from my LG-H815 using Tapatalk
  13. Marm

    Marm Member

    DarrenNewsgroup: I wonder if this disappearing video problem might be caused by your Pioneer Amplifier? I have experienced this same problem and a few others with my U9-H and a Neo U1 when connected to a Pioneer VSX-524-K amplifier but not when on my Yamaha HTR 6130 amplifier.

    The red light goes off as DarrenNewsgroup describes and the screen goes blank quite often. It seem to go to sleep. This often happens when I am browsing web pages, and inactive as I am reading the page. It almost seems that I must frequently move my mouse to keep the amp from going to sleep. Sometimes this happens when I am watching video or listening to audio.

    Also sometimes the screen stays black when starting up. Often I can get the screen to come alive by vigorously clicking and moving my Logitech 325 mouse. Sometimes the screen remains black and only by powering off and restarting the Minix box do I get a screen.

    Sometimes this Pioneer Amp will refuse to stay on the HTMI port with the Minix connected but instead will go to the port with my Bell Media TV signal on it even when my TV signal provider's. box is off.

    Also, sometimes I lose audio.

    I suspect these problems are ARC issues or HDMI CEC issues but have not been able find settings to fix the problems.
    Last edited: Jun 12, 2017
    DarrenNewsgroup likes this.
  14. DarrenNewsgroup

    DarrenNewsgroup New Member

    Thanks for that. Next time I get in testing mood I might try and get a method that loses the video signal, try to repeat it a few times, then repeat but this time going from my U9 direct to the TV, bypassing the Pioneer.

    Darren

    Sent from my LG-H815 using Tapatalk
    Marm likes this.
  15. DarrenNewsgroup

    DarrenNewsgroup New Member

    Some more updates...

    U9 is now connected directly to my TV on a dedicated HDMI socket on the TV. This takes the Pioneer out of the equation. I rebooted the box and noticed the signal went black soon after starting the box. I pulled the plug, reinserted and rebooted into recovery (20 seconds power button press), wiped the cache partition, rebooted. On restart I was offered the choice of Minix metro or launcher3. I chose Minix metro ("just once" option) but it lost its tv signal within a few minutes. Reboot. Selected launcher3 and too lost the tv signal. Next reboot i left it at the menu choice of Minix metro or launcher3 for a few hours, no problem still got tv signal. Choosing metro I managed to stay running as file explorer and noticed it said to auto update. As soon as I selected the auto update (with es file explorer, not Google play) I lost the tv signal. Next reboot i select metro and went to Google play, immediately lost tv signal.

    It looks like something internet related?

    I disconnected the Ethernet cable, rebooted, selected launcher3, went to settings, network, turned on Wi-Fi and lost the tv signal.

    Rebooted and lost tv signal within a second of seeing the metro or launcher3 selection. Rebooted into recovery, wiped cache, rebooted and could get a little way into launcher3 before I lost the tv signal. It seems moving from Ethernet to Wi-Fi has made it worse.

    During this testing I have rebooted my router h which is also the DHCP server).

    At least I have eliminated the Pioneer and most likely my HDMI cable.

    I guess my next option is a complete reflash. I guess a complete wipe of the NAND is in order. At this stage I guess I might as well make the move from FW004 to FW005 beta but I am not sure how to do it. Need a bit of researching and borrowing a laptop or moving the U9 to my computer I the other room. NOTE TO SELF - use the proper Minix power supply, not doing that is what blew up my old android tv box (I used my 12v supply instead of my 5v supply - doh). Oh well it was an old box and had issues so that was the excuse to get a U9 and Minix legendary support (seems a lot of teething troubles with this box, hopefully it will get better over time).

    @http://www.minixforum.com/members/minix-ken.11/ - Ken, have you seen this issue before? Can you give me any clues?

    Darren

    Sent from my LG-H815 using Tapatalk
    Last edited: Jun 13, 2017
  16. DarrenNewsgroup

    DarrenNewsgroup New Member

    Solution found...It was a faulty PSU.

    Sent from my LG-H815 using Tapatalk
    kingsizept likes this.
  17. MrBig

    MrBig Active Member

    Glad you found it. I hate when there is a malfunction and I can't figure out what the cause is. It always boils down to process of elimination and logic. Another one for the memory banks(y)
    Marm likes this.
  18. Marm

    Marm Member

    Over many years of servicing PCs I have occasionally found irritating intermittent problems that defied the usual process of reinstalling software swapping out cards, boards and RAM in the process of elimination that you mention, MrBig, only to solve the problem by lastly changing the power supply. With TV boxes we can't do as extensive physical troubleshooting but it is good to remember that the PSU can cause many pesky forms of behavior.

    As you say MrBig, a good one to remember. :)

    FYI, I solved my loss of video problem by replacing the Pioneer amp with a 2nd hand Yamaha amp. I like it far better than the Pioneer and now have two Yamaha amplifiers.
    Last edited: Jul 20, 2017