1. Official MINIX forum -Forum was offline for maintainance during last weekend and is back online now.

Bugtracker for NEO U1 FW011

Discussion in 'Official Firmwares' started by MINIX - Ken, Dec 2, 2016.

  1. bitweasel

    bitweasel New Member

    OK, glad this isn't just me.

    I'm thinking of reverting to firmware release 9. I can't remember now what I was after with the upgrade.

    Over the holiday I bought a new set, which means a new smart TV because what else is there these days?

    It's a sharp/roku set (I'm not too impressed with Roku - once you get past Netflix, the apps are unstable. I regularly have the Amazon app crash the entire TV!) but I like the high def and multichannel audio on Netflix. The downside - figuring out how to address a home (sharp) / up arrow (minix) remote conflict.

    I had a spare BT remote, and that helped, until I figured out how to get the Harmony and hte box to agree on a new key to use in place of the up arrow.
  2. Hub

    Hub Member

    I don't understand. What's connection between Netflix and your sharp tv and problems with avi/xivid/divis files on FW011 ? Definitely avi files doesn't working properly on FW011. In my situation films have sound but pictures is too speed (like x2 fast forward) or in some players can turn on but after pause or rewind freezes. ONLY in xcmb working without issues but even there I have one avi file which have problems in xcmb. In Mx player WE MUST change HW decoder to SW decoder and avi files working.

    In FW010 nothing happens like this with avi files. Working without issues on every player. I mean so Change log since FW010: 2.) Improved some standard definition (.avi, .mkv) videos playback smoothness must something wrong in firmware with avi files.
  3. bitweasel

    bitweasel New Member

    sorry, I was primarily being conversational there.

    I also thought it interesting that the Minix and Sharp remote codes overlap.

    Now, as I try to revert to fw 009A, I have tried:

    - using the ZIP on a microsd card. Zip cannot install; box reports that it can't install the zip over a newer
    firmware
    - using the .IMG file and image burning tool. Burning tool detects device but errors out.

    "[Err]--[0x10101002]Romcode/Initialize DDR/Identify/USB Control setup error"

    I will try with a straight 008 or 009 ROM next, perhaps there is an issue with the 009A having the zip
    set up as an update ratehr than a full install?

    System is no longer bootable.
  4. Hub

    Hub Member

    You must burn image by OTG and PC - please read all instructions on forum how to do.
  5. I have problems to delete my movie en TV show library. Al old maps that I deleted on the NAS still excist on Kodi.
    Did a cleanup library in kodi cleanup images reboot etc. no luck
    any idea's?
  6. Hub

    Hub Member

    So this dates must be in any hidden settings on NAS. Maybe on any cloud and connect with kodi. After new firmware by OTG - PC all dates will be erased.
  7. OverSoft

    OverSoft New Member

    We have about 100 Minix U1's running as Digital Signage boxes at one of our clients (soon to be expanded to 200).
    All of them are running on the latest FW (FW11). We installed our own launcher and narrowcasting player.

    We're two main problems:
    1) About 5% of the players crash randomly. Sometimes the last image stays on screen, sometimes the display turns pink. The system is totally unresponsive after this, nothing runs and it's not accessible by USB (ADB or MTP). This happened on older firmwares too. This seems like it's hard crashing, because a normal Android kernel panic would reboot the box (right?).

    2) Since FW009, some players keep cycling the boot animation, Android's "Starting apps" and then the launcher for 1 second. Logs in the "data system dropbox" directory points to this:
    A file is created (system_server_crash at [timestamp].txt) with the following contents:

    Sometimes clearing the cache works, sometimes it doesn't. This is not really workable, as these players are supposed to be maintainance-free.


    We developed our own USB hardware watchdog, to make the systems more reliable. But it would be great if we could run them without these devices.
    /edit: It would be great if we could work together with someone from Minix themselves, we are going to roll out more than a thousand boxes in the next few months.
    Last edited: Jan 10, 2017
  8. Viggen66

    Viggen66 New Member

    Never thought of using this box to display digital signage, really multiple uses, some even use it to surveillance, others to control gadgets in the house, really the sky is the limit
  9. OverSoft

    OverSoft New Member

    I even build our signage app especially for this box. The fact that this box has an MCU is really helpful (auto power-on without a jumper) and it's fast enough to handle 1080p content.
    I'd just like it to be 100% reliable. ;)
  10. mehgurd

    mehgurd New Member

    I also would like to state here that (since the latest firmware?) I'm having very irritating audio sync problems and also the popping/clicking sound that has been reported quite a while ago and that is still an active issue! I do feel that the audio problems here are being ignored by the mods/devs. Would appreciate it if these issues could get a thorough investigation which I'm more than willing to help with!

    Related topics:
    http://www.minixforum.com/threads/kodi-audio-desync-more-as-movie-plays.15335/
    http://www.minixforum.com/threads/static-pop-clicking-sound.14119/page-3

    Thanks for taking a look at this!
    Nadeox1 likes this.
  11. Viggen66

    Viggen66 New Member

    Oversoft this is an awesome mini pc with great support from the manufacturer can't ask for more.
    Minix takes care of its customers that's what's take them apart from the rest.
  12. bitweasel

    bitweasel New Member

    I unsuccessfully followed the instructions in this thread:

    http://www.minixforum.com/threads/how-to-update-with-usb-burning-tool.9641/ and was running as admin.

    the error message I quoted was from the Windows app I was trying to use to burn from.

    What I ultimately did worked, bearing in mind:
    - the stock recovery couldn't flash the update.zip because of the date check.
    - the TWRP recovery couldn't flash the update.zip because of a device identification error (I think TWRP has a different device identifier in its build.prop)
    - generally, you can't edit update.zip files for use by a stock recovery, as the stock recovery almost always looks at package signatures

    so I unpacked the update.zip, and found the updater-script at the path
    \U1_FW009A.zip\META-INF\com\google\android\

    I removed the first two lines, which are a date check and a device check,

    (!less_than_int(1471331950, getprop("ro.build.date.utc"))) || abort("Can't install this package (2016年 08月 16日 星期二 15:19:10 CST) over newer build (" + getprop("ro.build.date") + ").");
    getprop("ro.product.device") == "NEO-U1" || abort("This package is for \"NEO-U1\" devices; this is a \"" + getprop("ro.product.device") + "\".");

    Then I repacked the zip, booted from TWRP on USB OTG, and successfully flashed back to firmware 9.
    I was not able to get TWRP to read files from the microsd slot after it had booted from that slot, but realized it could both boot from and read from the USB.

    Sync on SD movies is vastly improved.
  13. Smartie36

    Smartie36 Active Member

    May have found a bug with pcm audio, I switched from hdmi to pcm to test an up mixer on my yamaha amp that makes use of my height speakers for non dolby atmos material and it works really well (amp displayed pcm instead of dolby digital so I know pcm audio was working initially) , I then switched the audio out back to hdmi to see how different it sounded and when I then switched the audio out back to pcm again my amp was not receiving a pcm signal like it was when I first selected pcm, it appeared stuck on hdmi even though it showed pcm as being selected!?

    Has anyone else experienced this? Never had a need for pcm auto out before but this neural:x up mixer on my amp is really impressive but it only works when receiving a pcm audio stream.

    Sent from my Nexus 7 using Tapatalk
  14. danlat1415

    danlat1415 Active Member

    If you're changing audio output, your best rebooting the Minix.
    Otherwise you get residual issues like the one you're having. Devices aren't always designed to constantly flick between different outputs.
  15. Apfelali

    Apfelali New Member

    easy Simple Client/TV
    After activated the Tv option and switch Tv channels I got a black screen (right mouse click)Normaly is a minimized running Tv programm.
  16. Menorca Man

    Menorca Man Active Member

    Hi OverSoft.

    Has anybody from Minix contacted you yet? If not, it might be worth your while contacting Minix at their Hong Kong headquarters direct:

    http://minix.com.hk/en/contact
  17. Viggen66

    Viggen66 New Member

    Only issue I have is metro minix launcher force close sometimes on boot nothing more.
  18. OverSoft

    OverSoft New Member

    Unfortunately, i haven't heard anything yet.
    I will contact Minix directly. We have a quite high failure percentage, so it would be helpful to have someone from Minix to work with us. Otherwise we might have to switch to a different, more reliable box.
  19. EdwardJ

    EdwardJ New Member

    Hi - I noted in another string that the audio sync problem might be in the XBMC software provided by Minix. I have Kodi 16.1 from Google on one of my two boxes and it seems to play fine while XBMC doesn't. I haven't tried a lot of files but one .AVI file that is so badly unsynced with Minix XBMC that it's unwatchable plays perfectly under 16.1. I'm going to experiment a bit more before I try reloading earlier versions of the U1 software.
  20. EdwardJ

    EdwardJ New Member

    More data - another MP4 file that had had a sync issue still plays badly offset when using 16.1. It appears that the issue may be deeper than just XBMC. Next step is to try reflashing FW11 and if that doesn't help step back to FW10.