1. Welcome to the official forum for MINIX devices!

Bugtracker for NEO U9-H FW003

Discussion in 'Official Firmwares' started by MINIX - Ken, Mar 13, 2017.

  1. whfseeguy

    whfseeguy New Member

    After updating to FW004, the PQ improved noticeably. Good job Minix.

    However, no sound from Dolby Digital HD and DTS-MA clips. It was working 100% with FW003. Regular DD and DTS are OK.

    Anyone having the same issue?
  2. Snakebite

    Snakebite Moderator Moderator

    Yes - same observation here, AVR doesn't attempt to switch to passthrough when launching dts-ma or atmos. Using Kodi 17.1 final
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Have you re-enabled the passthrough settings in system after OTA? All settings are forced reset during each OTA update.

    We are having holidays here and won't resume work until Wednesday, so sorry...
  4. whfseeguy

    whfseeguy New Member

    Hi Ken,

    I double checked the passthru settings on the U9H, mine is set at:

    Digital sounds : "PCM" (also tried HDMI, no difference)
    Output devices: "AUTO" (also tried HDMI, no difference)
    Security & Restrictions -> Unknown sources -> On

    On Kodi 17.1 final, pass thru was enabled, and all Dolby and DTS settings were enabled. (Not changed when I had FW003).

    Playing clip with Dolby TrueHD (with or without Atmos) or DTS-MA, my AVR (Anthem MRX1120) is showing the input is PCM 2.0 and I have no sound.
  5. Henri06522

    Henri06522 New Member

    Unfortunately, the update to FW004 did not change anything for me:

    - Deep Color Setting issue:
    Still the same; after restart it's set to Off

    - Brightness issue:
    Still the same: After playing playing an HDR movie (The Revenant) you see the brightness change to, how can I say, a too colourful setting. A lot of brightness, for example, the sand in the Magnificent Seven is so yellow it burns my eyes, but all detail in dark scenes is lost. When I switch deep color mode off and on, the brightness is back to normal in all movies until I start the Revenant again. After that, same issue. You see the brightness is changing 0,5 sec before the movie starts. By the way, I have this issue in Kodi v17,1 and XBMC for Minix 16.3.

    - XMBC for Minix borders issue:
    Still the same; when I play movies with XMBC for Minix it has borders all around.

    Sometimes I think something in general is wrong. Because when I disable HDR on my TV (Samsung UE55JS8500) my story from above is the same...so.....strange isn't it? Also no change is picture quality. Especially the combination HDR on or off makes no difference and the fact that the Deep Color setting resets after restart I think I have to search somewhere else to fix all those issues.

    So if someone has or had the same experience, please contact me. I was hoping for better times with FW004, but really no changes at all.

    Thank you!
  6. givecredit

    givecredit Member Beta Tester

    Great job on the HDMI spoofing, all working perfectly. Thanks ken and all at MINIX. Will report back later on further feedback after playing with MINIX for a while.
    Enjoy your holidays.
  7. Djvega

    Djvega New Member

    After update in fw004 can someone write in Hard drive?
  8. WeK05

    WeK05 Audio Visual Master Specialist

    While the grayscale issue is fixed in FW004, passthrough for Dolby Digital Plus/TrueHD/ATMOS, DTS-HD Master Audio/DTS:X are broken now. I am still not seeing HDCP 2.2 being enabled. Also, Showtime playback error is still present.
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I'm sure it's been enabled.

    Showtime - have you enabled HDMI spoofing option?

    Passthrough - we shall follow up on Wednesday, sorry about that.
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    That's another issue about BT709/2020 and a fix will be coming also in this month with fw005.

    We release fw004 because we don't want users having other issues to wait that long.

    It's a intermediate release. :)
    skynet likes this.
  11. WeK05

    WeK05 Audio Visual Master Specialist

    1) HDCP 2.2- DRM Info app still shows max level as 1.x. Since Netflix/Amazon 4K streaming doesn't work, is there any command to enable HDCP 2.2? I can only get HDCP 1.4 on my HDMI analyzer which is HDCP 2.2 capable.

    2) Showtime - Yes, I have enabled "Fake HDMI" and have also rebooted after enabling that. Playback works for about 30 sec and then it shows "Playback Interrupted" message. If you want to check, you can use the same login details. I have renewed the subscription for a month.
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Can you turned off fake HDMI and see if HDCP 2.2 can be detected? We tested on SONY and LG TVs. Also, this feature on Marshmallow is known to affect passthrough and that's why we are forced to make a switch, when it's on passthrough would be broken. We shall keep looking for a better way to do the spoofing.
  13. Hi Ken,

    From U1 to U9 now ;)

    Got problems like other with the DTS-MA. No sound on minix for xbmc or Kodi 17.1.
    Had received the firmware update last night.
    What I saw in post that follow setting had to been made
    digital sounds - PCM > in Kodi passtrhough enabled. (HDMI also not working)
    dolby sounds - DCR mode - RF (with line not working, or combination PCM - line / PCM - RF)
    DTS sounds - 0 % (also 100 or less not working)

    Question:
    What does DTS sounds setting do ?
    What does dolby sound setting do in RF or Line modes ?

    The u9 wont send HDCP 2.2 just did a check on my TV.
    With or without the fake HDMI.

    I notice that the brightness level is very low on the U9.
    Did a calibration with the U1 went okay.
    Got a AVS HD (itu-R BT.709 ) blue-ray.
    http://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html

    When I use Basic setting for the Black level clipping.
    The brightness level on my TV must go up to +20 / +25 to get the right setting.
    With the U1 or when playback directly on my TV the brightness must go max +3

    HDR is off, and with 1080p or 4k things are the same.

    I did several restarts after made the changes but no luck with the DTS-MA or brightness level.

    setup
    [ Panasonic CX800 65" with Marantz SR6010 ]

    Any settings you prefer so things should work. Would love to test it.
    the DTS-MA is the biggest problem for me now.
  14. Villa

    Villa Well-Known Member Super Moderator

    Which firmware version?
    Have you checked for FW004?

    @MINIX - Ken We need a FW004 Bugtracker thread!
  15. Build-nummer:
    U9-H FW004 20170331
    The latest I saw in earlier post ;)
  16. Robyn

    Robyn Member

    FW004 fixed the PQ
    Same issues here (double checked if android settings were reset)
  17. Djvega

    Djvega New Member

    Please can someone say me if you can write in hard drive?
  18. Higgs

    Higgs Yellow Dude Super Moderator

    I can write in usb stick formatted as external storage. I could do this in the previous firmware as well. Using ES File Explorer to copy files to/from the usb stick.
  19. Djvega

    Djvega New Member

    How do you do? When i try to use quasar kodi when i have to put destination folder to dowloads i try to put Hard drive but kodi has no permissions to write on my Hard drive and i can't do nothing
  20. Higgs

    Higgs Yellow Dude Super Moderator

    As I said;
    I haven't tried with Kodi and I don't use quasar.