1. Registration issues have now been resolved. New accounts are able to be created

Bugtracker for NEO U9-H FW004

Discussion in 'Official Firmwares' started by Gh0st, Apr 2, 2017.

Thread Status:
Not open for further replies.
  1. Gh0st

    Gh0st Australia's Finest Since 1981 Administrator

    Feel free to post any bugs you have found with the U9-H FW004 (20170331) here.

    Please include as much information as possible and any short clips of videos you're having problems with

    For non-rooted devices only
    Villa likes this.
  2. Gh0st

    Gh0st Australia's Finest Since 1981 Administrator

    My bug is I can't download it lol
    Not showing up OTA for me, tried with Adopted storage out, tried VPN set to US, Canada & Singapore.
    Used my left hand to push the button just in case but no luck :(
    KellyND1, midnight and Villa like this.
  3. DarrenNewsgroup

    DarrenNewsgroup New Member

    Ethernet says not connected in the settings page but i get a green Ethernet symbol at the top left of the Minix launcher. I had this on FW003 as well.

    I have my U9-H connected to my router via Ethernet. Wi-Fi is turned on but not connected to a network. I leave it that way so i can Miracast from my phone to the U9-H.

    It must be a settings display bug (annoyance really) since the U9-H can access the internet and my server fine.

    Sent from my LG-H815 using Tapatalk
  4. Villa

    Villa Well-Known Member Super Moderator

  5. Hi Ken,

    Because I posted my problem on the FW003 here is it on the fw004 bug tracker also with a edit

    From U1 to U9 now ;)

    Got problems like other with the DTS-MA. No sound on minix for xbmc or Kodi 17.1.
    Had received the firmware update last night.
    What I saw in post that follow setting had to been made
    digital sounds - PCM > in Kodi passtrhough enabled. (HDMI also not working)
    dolby sounds - DCR mode - RF (with line not working, or combination PCM - line / PCM - RF)
    DTS sounds - 0 % (also 100 or less not working)

    Question:
    What does DTS sounds setting do ?
    What does dolby sound setting do in RF or Line modes ?

    The u9 wont send HDCP 2.2 just did a check on my TV.
    With or without the fake HDMI.

    I notice that the brightness level is very low on the U9.
    Did a calibration with the U1 went okay.
    Got a AVS HD (itu-R BT.709 ) blue-ray.
    http://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html

    When I use Basic setting for the Black level clipping.
    The brightness level on my TV must go up to +20 / +25 to get the right setting.
    With the U1 or when playback directly on my TV the brightness must go max +3

    HDR is off, and with 1080p or 4k things are the same.

    I did several restarts after made the changes but no luck with the DTS-MA or brightness level.

    setup
    [ Panasonic CX800 65" with Marantz SR6010 ]

    And a question about the 4k setting>>>>
    Can you make a option to fix the 4k (or other resolution) so it always pushes this no matter what happens when switching on a receiver?
    At this point (and also with the U1) when I switch from TV (with ARC and HDMI CEC) to the MINIX the MINIX loses the 4k settings.
    Do a cold start (power all down) settings come back again.
    My Marantz got latest firmware and possibility to send 4k/60 etc. but at some point when switching around from TV tot minix or PS4 the 4k settings are gone.
    If I connect a BR player fixed on 4k I don't have problems and the TV got the 4k signal.
    Already did test with HDMI fake on / off, or HDMI CEC yes / no and so on...
    Maybe it's marantz related but If there is a possibility to fix the output signal you would be my hero ;)


    Any settings you prefer so things should work. Would love to test it.
    the DTS-MA is the biggest problem for me now.
  6. sangaz

    sangaz Member

    Ive noticed yesterday on the u9h the temperature is no longer there on the Minix launcher

    Sent from my SM-N9005 using Tapatalk
  7. WeK05

    WeK05 Audio Visual Master Specialist

    1. It is just the Dynamic Range Control scale. Applies only when you are using the hardware DTS decoder. If you are using passthrough, it has no effect.
    2. Different modes for Dolby DRC. RF is a heavier compression and is intended to be used with RF output. Line is a lighter compression. Again, these modes apply only for the hardware Dolby Audio decoder.

    3. Grayscale issue is mostly fixed in FW004. YCbCr output still has some small luma errors (is only 16-233 with MediaCodec) and larger chroma errors. @MINIX - Ken had mentioned that this YCbCr output error will be fixed in an upcoming firmware update.
    If you are using Kodi 17.1 calibration, bar 17 in the AVS HD 709 black clipping pattern is actually output as 16 due to YCbCr output error. 18 is 17, 19 is 18, 20 is 20.... There is a rounding error. It is correct when you play the clip in "MoviePlayer" (amocdec).
    Since bar 17 is actually output as 16, you may have to raise the brightness control on your TV to see it. This may be why you are seeing the difference between U9-H (MediaCodec) and U1.
  8. WeK05

    WeK05 Audio Visual Master Specialist

    This was posted in FW003 thread:
    No go with Fake HDMI turned on or off. Only HDCP 1.4.
    Are you saying that Fake HDMI breaks passthrough? If so, HD audio passthrough seems to be broken irrespective of Fake HDMI status.
  9. Thanks for the explanation !
    And as always keep up to good work to make this one perfect !
  10. KellyND1

    KellyND1 Member

    I have the same issue with the loss if 4k option in settings. It's not there, neither is most of the others that were....Now gone.
    I did add a SD card for extended memory. Anything to do with that....Maybe?

    Also my mimix Xbmc 16.3, when I open it I get a message from tvaddons.org saying I need to upgrade to the latest version of Kodi 17.1 to get the best streaming possibilities.
  11. mark2

    mark2 Active Member

    You should try Kodi 17.1 you may like it little bit to learn as it is laid out a bit different to Kodi 16
    but you'll get help here or google
    KellyND1 likes this.
  12. I don't know what advice here is but mine is to add Kodi 17 with the play store of google. This way you have the stable version and see automatically when a new version is released and installed. You can also do a download from kodi and choose stable or nightly.
    For the 4k settings I notice with cold start the settings are there.... so power down all systems, I disconnect the power on my power socket(don't miss this part) . Putting back on , power on all settings are back. Switching from TV back to minix or PS4 back to minix settings are lost.
    KellyND1 likes this.
  13. Villa

    Villa Well-Known Member Super Moderator

    Presently, Kodi 17 is recommended by @MINIX - Ken
    KellyND1 likes this.
  14. tunay

    tunay Member

    Its just a Desaster . I stuck on fw003 and i wont update to fw004. New firmware is released but with many bugs. Dts has to work. So what i need to wait fw005? OMG
  15. vincenz0

    vincenz0 New Member

    Hi, my U9 does not find any update.
  16. skynet

    skynet Well-Known Member Trusted Helper

    FW004 is broken so it has been removed for now.
    vincenz0 likes this.
  17. Cizzz

    Cizzz Active Member

    Indeed, I had the FW004, but did a full image flash back to FW003. The update to FW004 can no longer be found.

    So what's the schedule now?
    I really hope the write permission issues for SD and external harddrive will be solved soon. (+ internal samba server)
  18. skynet

    skynet Well-Known Member Trusted Helper

    The schedule is the fw005 release due to this month with corrections.

    Sent with my S7 edge
    KellyND1 likes this.
  19. KellyND1

    KellyND1 Member

    Will do, thanks much!

    Edit:. The 4k cold start worked like a charm. Thanx again

    Sent from my XT1254 using Tapatalk
    Last edited: Apr 4, 2017
  20. KellyND1

    KellyND1 Member

    Thanks Villa, appreciate it.

    Sent from my XT1254 using Tapatalk
Thread Status:
Not open for further replies.