1. Welcome to the official forum for MINIX devices!

Bugtracker for NEO U9-H FW005

Discussion in 'Official Firmwares' started by MINIX - Ken, Jun 26, 2017.

Thread Status:
Not open for further replies.
  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Please post any bugs or issues with Firmware 005 (20170623) here.

    For non rooted devices only!
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1) HBO still has the pixelation issue at the start of playback. It may be worse on this firmware. It used to clear up within a couple of seconds, but now you have to use the 10 sec. skip.
    2) Deep Color mode is still not working properly. It requires a reboot for 10-bit output to be enabled, but it persists power cycling. Refresh rate switch breaks 10-bit output. If you disable refresh rate switching, 10-bit output works for all fps content, but you have the issue of getting stuck in HDR mode. Also, it looks like Kodi, SPMC is taking a long time to exit.
    3) WebView input problem on certain apps is still there.

    Mentioned by @WeK05

    1.) Which HBO apk should we use to test the problem 1 you raised? There are many of them.
    2.) Problem 2 we didn't realize it's related to refresh rate switching, now we know.
    2.) Getting stuck in HDR mode, may I know how to copy?
    3.) WebView input problem... could you please name some apps for us?
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    - Bug with web TS (H.264) still not resolved.
    - Stagefright demuxer bug with web (http/https) mkv,mp4, etc. still not resolved.

    @Kondor , we need new samples from you as we tested those 3 samples* you submitted before and they play fine with Gallery player, MX player & Kodi 17.
    *Bollywood HD .TS, Bollywood HD .MP4, AMEDIA .TS

    We have fixed things based on the samples you submitted.

    So we need to know what problems are you still having right now.
  4. stayloa

    stayloa New Member

    I don't know if this is specific to this firmware as spoofing wasn't enabled on 4a but the sky sports app (UK) has very jerky playback. I can upload logs or a video but it seems that it plays a few frames then stops, few frames then stops. Audio is fine however. Let me know what you need.
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    need login/password to test?
    are you on vpn?
    network speed is good enough?
  6. stayloa

    stayloa New Member

    200meg down, 20 up. No vpn turned on.

    The problem with the app is you have to register a device via your cable subscription and you're limited to how many device changes you can make.

    I've got none left but may be able to add one in July. Is that the only way?
  7. WeK05

    WeK05 Audio Visual Master Specialist

    1. It is the HBO Go app : https://play.google.com/store/apps/details?id=com.HBO
    It doesn't happen with the HBO Now app, but I haven't verified yet whether HBO Now streams in 1080p or not on the U9. HBO Go streams in 1080p Dolby Digital Plus. HBO Go login is tied to cable subscription. So, I won't be able to help with that.

    2. In the beta 5 firmware, 10-bit output was totally broken. In this firmware, after 10-bit output is enabled it breaks when there is a refresh rate switch.

    3. You can reproduce this in Kodi 17.x. Disable refresh rate switching. Play a HDR clip, the TV will go into HDR mode and it remains in HDR mode forever (?). I haven't checked whether it will return to non-HDR mode after a while.

    4. This can be checked easily with NBC Sports App. (https://play.google.com/store/apps/details?id=air.com.nbcuni.com.nbcsports.liveextra). It also occurs on other apps that require a cable subscription login (U.S.).
    Menorca Man likes this.
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    For problem 1, unfortunately we can't do any testing from here, we can only check the log if any can be provided.

    For problem 2, we found that it seems only 25.000 fps switching is affected, and Amlogic have already promised a fix shortly.

    Problem 3, we shall conduct some tests.

    Problem 4, it's more like a Webview bug as we don't make it. I'm encountering similar issue on my phone.
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Yes, if VPN access is allowed...
    BUT, logs are absolutely helpful! We don't really need to test the app if logs can be provided!
    Meanwhile, please point us to the play store link of the app.
    Thanks!
  10. keanustar

    keanustar Member

    Btw, the HBO Go app has an adaptive image quality based on the internet speed. I'm using this app on Samsung and LG Smart TV and it does the same, because this is how it is working. This is not a BUG. It provides a lower quality video for about 10 seconds, until it buffers according to the internet speed each has.
    It my country, the HBO Go app even intorms you that this might happen and it may take until 30 seconds for the video quality to stabilize.
  11. stayloa

    stayloa New Member

    Hi Ken - the link for the app is here: https://play.google.com/store/apps/details?id=com.bskyb.sportnews&hl=en_GB

    Which logs do you need exactly? Never done it before but presumably via ADB? If there's a guide on here anywhere then I'll follow that but am comfortable with tinkering!

    Sorry - I didn't understand re. VPN. The app allows it but I think the 2 allowed devices are registered by MAC address and not IPs. Are you suggesting you could dial in to me via VPN to replicate the issue?
  12. WeK05

    WeK05 Audio Visual Master Specialist

    I am quite sure that this is not how HBO Go playback starts for you (check YouTube clip). At least this is not the way it is on other Android TV devices. I don't know how it is on Wet** devices (the only other devices with Amlogic SoC and Playready DRM). Have you tried the HBO Go app on your U9-H?

  13. WeK05

    WeK05 Audio Visual Master Specialist

    1. I brought it up because you had once mentioned that Amlogic is aware of this issue that affects protected buffer playback.
    2. I see it with all refresh rate switching: 24 to 60Hz or 60 to 24Hz, same with 25/50Hz.
    4. It is possible. It shows up only after WebView gets updated.
  14. keanustar

    keanustar Member

    Thanks for the youtube clip. This is not pixelation is something worse. Not sure how it is called.
  15. givecredit

    givecredit Member Beta Tester

    HDMI spoofing working perfectly.
    As said already I had to uninstall update to webview to get some apps working.
    Thanks for update.
  16. WeK05

    WeK05 Audio Visual Master Specialist

    There is no specific term for it. It is a video glitch/video corruption. Previously, I had described it as green mess. I agree, calling it as pixelation doesn't do justice to it ;).

    The video blackout is first. I haven't seen that before. Anyways... a 10 sec. skip fixes the glitch.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It will help solving it much quicker if we could obtain some logs from you or others.
    Thanks!
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Thanks, we have downloaded the apk to standby.

    Built inside the firmware there is an app to record logs,
    what you need is an external storage device and follow the instructions inside the app.
    stayloa likes this.
  19. Robyn

    Robyn Member

    @ Ken "Also, it looks like Kodi, SPMC is taking a long time to exit."

    This is already happening on FW005beta for me ;)
  20. Liam O Donnell

    Liam O Donnell New Member

    I have just loaded up the latest fw005 release . I still cannot write to a memory key or my usb external hdd.
    Some forums talk about changing a permissions file 'platform.xml', although I found a way of opening this file, I could not change it.
    How can I set the permissions so that I can write to external storage through an FTP server.

    Thanks
    Liam
    Berserko likes this.
Thread Status:
Not open for further replies.