1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

[Bugtracker] Official 004 firmware

Discussion in 'NEO X8-H PLUS 004 firmware via MINIX FOTA' started by MINIX - Ken, Apr 4, 2015.

Thread Status:
Not open for further replies.
  1. rawker

    rawker New Member

    mx player wont stream content, all i get is the spinning loading logo. please fix this issue.
  2. DeGroo

    DeGroo Member

    That's weird. Have you tried multiple sources?
  3. rawker

    rawker New Member

    i use bsdroid which is an app for ball streams, if i use es player it streams instantly but mx player does not. i can use xbmc to stream as well but i like mx player.
  4. DeGroo

    DeGroo Member

    Since other players are playing fine, it probably isn't a minix issue but an issue with mx player settings. Try switching between fw and hw decoders
  5. blue24

    blue24 Member

  6. vel tins

    vel tins Member

  7. blue24

    blue24 Member

    Hi Ken
    Rgarding my slow response remote issues. It turns out my NEO x8H plus was faulty , The new replacement works fine now(y)
  8. costaud

    costaud Member

  9. DeGroo

    DeGroo Member

    Another thing (tested on x8h plus):

    Up until fw003 the video playback of the dailymotion app was horrible, returning a frame every 5 seconds or so, so effectively unwatchable.

    After updating to fw004 finally video is playing, and there wasn't an update available for the app so it was something in fw004 that improved the situation. However, playback still suffers from intense judder which kicks in after a few seconds in each video.

    Can this be improved further with the next fw upgrade?
  10. ntux

    ntux New Member

    Hi all,

    I am facing an issue in fw 004 with openvpn (but probably still was present in older releases as I had the same problem).
    I have a openvpn client setup on my minix x8-h plus, that I use to pass through internet traffic to access tv streams from official tv channel apps. It works well, however as soon as I have the vpn connected, I can't access lan ressources anymore. I've tested with smb/nfs shares on my router (running openwrt) and other ressources on lan, and when the vpn is connected access to lan times out to every lan device.

    I know openvpn configs can get tricky, especially regarding subnets, routing and all, but I took extra care and all is correctly configured, and I also use the same config on other devices on my lan and they don't have this issue. The minix is connected through ethernet.

    I'll root the minix to see if I can see issues with routing tables, but in the meantime, do any of you have experienced the same issue?

    Thanks!
  11. WeK05

    WeK05 Audio Visual Master Specialist

    The easiest and simplest way to achieve this without rooting and modifying routing tables is by using OpenVPN for Android app and check "Bypass VPN for local network".

    http://minixforum.com/threads/remote-apps-will-not-work-when-using-vpn.3803/#post-33801
    ntux likes this.
  12. ntux

    ntux New Member

    Thanks ! that was just what I was looking for. I am using the openvpn android client, I should have checked the options... I assumed the client would have behaved like standard linux clients, and traffic to lan wouldn't have gone through the vpn default gateway as lan subnet would be present in the system routing table... my bad.

    Thanks anyway!
  13. deMARC

    deMARC New Member

    I confirm the bug is still there. This is my experience:
    It not occur in all videos but in a lot of them (mostly in mkv h-264 files). Every 3 mins. (more or less) there is a video stutter. So often it matches whit a sequence change in the film. I use SPMC 14.2 but it also happens on SPMC 14.1, Minix XBMC 13.3.3 final and even on XM Player so it seems it's not an app issue.
  14. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Is it "Web-DL" type of mkv files? if yes we are going to fix it soon, still analyzing the causes. We're 90% sure about the cause now.
    The problem is related to certain specific types of files and not refresh rate related.
    Last edited: Apr 22, 2015
  15. blue24

    blue24 Member

    Hi Ken

    where have you been!!! :)

    Great news about stutter/frame drop bug fix.

    Did you see my post regarding the remote control issue. it turns out my Minix was faulty. I now have a replacement, Everything is working fine now.
  16. eggz2004

    eggz2004 New Member

    Hi Ken.
    Can you tell us when the fix for this and the sleep issue in kodi will be released??
    Cheers
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    check here
    http://www.minixforum.com/index.php?threads/5320/

    but we don't recommend putting the hub to sleep while XBMC or Kodi is running because they have the wakelock which doesn't allow the hub to go sleep. it takes much longer time than usual to go sleep until the app releases the wakelock.
    we fixed the wakeup issue, not the sleep because it's not a bug, it's how the app is designed to work.
  18. DeGroo

    DeGroo Member

    Indeed there's still an occasional frame skip / momentary stutter but please note that this has nothing to do with the slow motion bug that was a very specific thing and it HAS been fixed
  19. ArcticWolfie

    ArcticWolfie Member

    Yes my 23.976 videos are suffering with random frame skips / judders now and then (once a minute or so... haven't measured the seconds in between).
    I tried FW003 and FW004 with Minix XBMC 13.3.3, Kodi 14.2, SPMC 14.2 and Vidon XBMC (0.0.0.5 I believe) and all 4 players and both firmwares show the same issue. I'm very sure it ain't my network or video sources (and my TV supports both 23.976 and 24hz)
  20. blue24

    blue24 Member

    This problem also exists with my own personal mkv files.
    Last edited: Apr 23, 2015
Thread Status:
Not open for further replies.