1. Welcome to the official forum for MINIX devices!

[Bugtracker] Official X8-H PLUS 005 FW

Discussion in 'NEO X8-H PLUS 005 firmware via MINIX FOTA' started by MINIX - Ken, May 8, 2015.

  1. benster

    benster Member

    Can you install skype and test it?
    I think my box is corrupted then.
    Camera works on 3 different windows pcs. Thanks ken

    Verstuurd vanaf mijn SM-G920F met Tapatalk
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Reflash the firmware may help.
    P.S. Our model is C525, it looks the same as C510 but it has autofocus.
    We couldn't get C510 here, sorry.
  3. benster

    benster Member

    I did reflash the firmware several times.
    Still buggy. When i change the usb port it works for 3 min then it crashes.
    Then i try a different usb ports same thing.

    Verstuurd vanaf mijn SM-G920F met Tapatalk
  4. kricsek

    kricsek New Member

    Looks like I've solved the issue with my wifi speed by buying an Asus ac87u router. Now the speed reaches 10.5 MB/s which is excellent. (AC/5GHz; same test for SGS5: 12 MB/s)

    However my audio problem still remains. I've configured HDMI-ARC and it's somewhat better than my original Minix->amp->TV configuration but it has different problem. I get a few seconds of audio dropouts now and then and sometimes the audio starts stuttering. When it happens I have to switch to another input on the TV and switch back. So basically I have to do the same thing to fix it as before.
    I'm starting to think again that there is something wrong in the way Minix is handling audio over HDMI.
  5. danlat1415

    danlat1415 Active Member

    You posted this 1 week ago today.
    Just wondering if everything is still on track for an imminent release or if it's been delayed for some more fixes?

    :)
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Uploading it today.
    The update window will open on Monday.
    New forum section has been created (not active for posting yet).
    Thanks.
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If it's better, it means the signal doesn't go well between your setup,
    or when you changed the configuration the jacks got better contacts.
    You should try changing either 1 or both of the cables.
    If it were a firmware issue, it wouldn't get better with a change of setup.
  8. kricsek

    kricsek New Member

    I've been using these HDMI cables for years and never had any issues with my laptop/PS3/PS4.
    However I tried the PS4's HDMI cable with Minix and the result is the same. When I start another youtube video I lose audio and I have to switch to another input on the AVR and switch back. After I do this there will be no problem with the audio/video. So even 2 hours long movies play perfect. I don't think the issue is caused by bad HDMI connection.

    There can be any number of reasons why HDMI-ARC behaves differently than Minix->AVR->TV. I lose audio less often but there are audio dropouts. So I don't prefer it anymore.

    Maybe the problem is caused by the frequent closing and opening of the audio stream. Maybe Minix should not close it but it should keep a constant PCM open even when there is no audio playback. That's how my laptop (Ubuntu) works. The AVR doesn't display any audio format on the front panel when I play something. It just stays PCM. No matter if I change to DD from DTS or whatever.
  9. Jeffers24

    Jeffers24 Active Member

    I have just updated to Kodi Isengard RC1 from the play store and am still suffering intermittent 1-4 second sound dropouts. Picture is always perfect.

    I don't experience any sound dropouts when watching from my Sky HD+, Humax PVR and Panasonic PVR boxes.

    Hoping 006 may fix the sound dropout issue.
  10. kricsek

    kricsek New Member

    006 didn't fix it for me.
    Do you use hdmi-arc? What AVR do you have?
  11. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Have you considered you box is faulty? You should get a swap ASAP while the warranty is still valid.
  12. Jeffers24

    Jeffers24 Active Member

    I am not very technical and do not make a lot of demands on my Minix box, which I mostly 98% use for streaming over broadband. I have a few music tracks/videos and photos stored on the internal Minix memory which I occasionally view. I have no external storage devices installed/attached.

    My sound dropout issue started when I upgraded from 004 to 005, two updates one immediately following the other via OTA as I did not use 004A.

    I first looked at ARC at Ken's suggestion as a possible solution. Looking into ARC on the net my understanding is that an ARC connection is inferior sound wise to a HDMI connection, the recommendation being use HDMI direct when possible.

    My boxes do not support ARC so I could not go down that route.

    Following my upgrade to 005 when I first started experiencing the sound dropouts I had a direct HDMI connection between the Minix and the AVR.

    My AVR only has 2 HDMI inputs which was not enough to connect all my boxes. When researching Ken's ARC suggestion on the net I realised I had an alternative which was connect all my devices with HDMI to my Sony TV and connect sound from the TV to the AVR via an optical cable.

    Now I have all my boxes connected via HDMI to my TV, my TV connected to my AVR via HDMI for video and additionally sound transferred to my AVR via an optical cable.

    I only suffer intermittent 1-4 second sound dropouts when using the Minix. These occur when I am streaming over broadband or playing a video stored in the Minix internal memory. Video is never affected.

    My AVR is a Samsung HT-D6750W 7.1CH Blu-ray box.

    I am using Kodi Isengard RC1 and still on Minix 005. I have not upgraded to 006 yet as I thought I would leave it for a few days and you stated 006 did not sort out your problem.
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    please try flashing the 006A firmware with full image instead of FOTA, we have seen many cases simply solved by doing this. Worth a try.
    WOW! I am also using 6750W so the firmware must be fine! Otherwise I would be damned too!! I check update for the 6750W every month, have you?
  14. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    ARC is also transferring digital audio, shouldn't be "inferior". It's a standard of HDMI.
    You don't connect using optical cable, just connect 6750W to the arc port of your Sony TV, choose output from external audio system and that's it!
    "D. IN" will be displayed as the input source on your home theater.
    remember to enable 24Hz mode support on your 6750W by the way!
    Last edited: Jul 10, 2015
  15. Jeffers24

    Jeffers24 Active Member

    Regards arc I am going off what I researched on the net. I am sure you could find the same.
    My Sony TV does not have an ARC port. Without the optical cable from my Sony TV to the 6750W I was not getting any sound, the 6750W changed to DIN automatically but no sound output.
    If I flash full image will I lose all my customisation/settings? If yes is there any way I can backup my configuration/settings and re-install following full image install?
    My 6750W is connected to wifi and tells me when an update is available giving me the option to install. I will go online and check latest 6750W versus what mine has installed.
    I have updated via two OTAs 006A, 006 then 006A, FOTA did not update my box from 005 to 006A directly. Following the updates my sound dropouts have got worse and I now get an occasional stutter which I did not get before.
    My thoughts are that the problem is with the Minix box around the FOTA updating as I don't have any sound issues with my other boxes. Which is why I will look at doing a full image update, following your answer to my query above.
    Not sure where setting for/what the 24Hz is/will do?
  16. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    what's your Sony model ? you need to choose audio output from external sound system inside of your TV menu. (assuming arc is supported and connected)
    the firmware should be fine, I am using 6750W for over a year
    last time I have had audio drop issue was a year ago and then I bought a good replacement cable and then no problem since then.
    24hz mode is the compatibity mode for watching movie files.
    Last edited: Jul 10, 2015
  17. Jeffers24

    Jeffers24 Active Member

    It's a Sony KDL-37W5810.
    I am using these HDMI cables,

    Link removed - links to resellers not allowed. You can write a description!



    [​IMG]
    IBRA® 1m High Speed PRO GOLD RED v2.0/1.4a HDMI Cable 3D 2160p PS4 SKY HD 4K Ultra HD(Version 2.0, 18Gbps, ARC)

    Are these good enough?

    I cannot find any reference in 6750W setup for 24hz mode, is it a display/sound setting, most of my setting options are auto/on/off

    The software version of my 6750W is 001023

    My other question is there a way I can do a full image install without losing or restoring my configuration/settings?

    As you do not have any problems with your 6750W tends to confirm my thoughts that my issue is my Minix box/updates which is why I am thinking of doing the full image update you recommend, did you do a full image update on the Minix you have connected to your 6750W?
    Last edited: Jul 11, 2015
  18. Argyrios

    Argyrios Member

    Hi Ken, same crashing happens with Kodi Official in all X8-H, X8-H Plus, X7 with latest FOTA firmware available. This is not happening on my Lollipop 5.0 on LG G3 for example.

    Seems libcurl.so is crashing. Take a look at the log below:

    http://xbmclogs.com/puqjkyfww
    1. 16:09:53 T:1750839904 INFO: global locale set to C
    2. 16:09:53 T:1750839904 INFO: CLangInfo: loading resource.language.en_gb language strings...
    3. 16:09:53 T:1750839904 DEBUG: POParser: loaded 3312 strings from file resource://resource.language.en_gb/strings.po
    4. 16:09:53 T:1750839904 DEBUG: SECTION:LoadDLL(libcurl.so)
    5. 16:09:53 T:1750839904 DEBUG: Loading: /data/app-lib/org.xbmc.kodi-1/libcurl.so
    6. 16:09:53 T:1750839904 NOTICE: Running database version Addons19
    7. 16:09:53 T:1750839904 DEBUG: void CDatabaseManager::Initialize(bool), updating databases...
    8. 16:09:53 T:1750839904 NOTICE: Running database version ViewModes6
    9. 16:09:53 T:1750839904 NOTICE: Running database version Textures13
  19. koying

    koying XBMC Guru Dev Group

    That log extract doesn't say libcurl is crashing. Just a debug notice saying that it is being loaded...
  20. Argyrios

    Argyrios Member

    You are right obviously, however this was the last loaded DLL recorded, hence it is the one that most likely crashing. Only a logcat would tell us what exact happened, and I cannot take that due to the fact that my minix is not rooted. But this debug output from Kodi seems similar to the issue listed below (hence my heuristic conclusion of libcurl.so crashing :) ). Of course you know better than me :):