1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

[Bugtracker] Official X8-H PLUS 006A FW

Discussion in 'NEO X8-H PLUS 006 firmware via MINIX FOTA' started by MINIX - Ken, Jul 7, 2015.

  1. rai

    rai Member

  2. rom69

    rom69 Member

    Hi Ken,
    I will create a post in the Kodi forum.
    Why are you developing a customized XBMC V15.0? Are there other technical things you are going to fix? Please develop the new version based on Kodi 15.1, as a view PVR stuttering issues, introduced with Kodi 15.0, have been fixed with Kodi 15.1 (for details please check Kodi 15.1 change log).
    regards
    rom69
  3. paulwit

    paulwit New Member

    please help, I started the update yesterday but after >24 hours the screen still says:"Systeemupdate installeren..." below that shows a wait bar which is at about 90%.

    what should I do? cycle power?

    thanks, Paul
  4. Higgs

    Higgs Yellow Dude Super Moderator

    Reboot and see how you get on. Worse case scenario, you'll have to flash the firmware using a PC but that is worst-case. Chances are the update will either recommence or you'll be able to restart it.
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We're finalizing the 007 firmware this week.
    Free WIng and rom69 like this.
  6. MarcR

    MarcR New Member

    Hi, new owner of a NEO-X8-H+ with fw 6A. I am using an harmony one to control it using Kodi 15.1. (I tested with The VidonXBMC Beta propsoed in the thread, but same result). I still can't access the details of a movie in movie list. Usually a full screen appear displaying a sumary of the movie, the cast, etc. and you can then select an actor per example to browse your library for all the movies with that actor. On the NEO X8-H+ FW6A, Logitech harmony one profile NEO X8 installed I can't find any key that make this window appear. I guess this should be the purpose of the "info" button. But it has no effect. I looked the kodi.log and kodi is not even detecting anything as far as I can see. Other actions are detected fine. As I read that this FW has support for Harmony Remote. I thought I would ask here. Let me know if it's not the good location to ask this question. Thanks.
  7. adi_tca

    adi_tca Trusted Helper Trusted Helper

    Your post seems to be mainly related to Kodi and not to the your X8-h Plus FW.

    You didn't mentioned which Kodi add-ons you are using, but do you have any movie scraper add-on installed? Have a look here: http://kodi.wiki/view/Add-on:Universal_Movie_Scraper.
    Also, you need to set the "view" option, below an example with "fanart" setting in "view options"

    upload_2015-8-18_11-54-37.png
    Last edited: Aug 18, 2015
  8. MarcR

    MarcR New Member

    Yes the question is related to Kodi and the harmony remote handling within the FW6 (new feature as I understand). My scrapper and other Kodi installation is fine. If I press "i" on the large minix remote with the keyboard in the back in movie list, the movie details appears right away. My question is "how to do this using the harmony one universal remote ?". Hope I am clear this time.
  9. adi_tca

    adi_tca Trusted Helper Trusted Helper

    OK, now your question/point is clear to me, but I cannot answer as I don't have this Logitech remote control. I saw it doesn't have a QWERTY keyboard like the other one you have (Minix A2?), so most likely the "info" button is not mapped to function as the "i" key on the A2. Maybe someone else that has this Logitech remote may answer.
    Have a look here also: http://kodi.wiki/view/HOW-TO:Modify_keymaps
  10. MarcR

    MarcR New Member

    The harmony one remote is only infra red. The chalenge seems to be able to send the "info" command using an IR signal. The neo x8 logitech profile maps the info button to a neo x8 function, but strangely, i can't see any thing in kodi.log when pressing the info button, while I see the command when pressing the ok button per example. Is it possible that the signal is prevented by reaching the kodi app ? By the android system ? Untill a signal reach kodi, the keymaps file (that i have been using in the past and i am familiar with) will not work.
    bubez81 likes this.
  11. junkyjunky

    junkyjunky New Member

    Just updated to this new released firmware. I have a Harmony 650 remote with new X8 profile (not X8+). I notice when I'm in guide view of KODI using my IPTV stream, entering the numbers works well to navigate to a specific channel, but when watching live TV and then trying to direct enter a channel number results in it assuming I've hit ok while I"m still entering the number or the number entry screen disappearing off the screen.
  12. andsol

    andsol New Member

    Gyus, who's using iptv apps? I've tried three IPTV programms with diffrent combination of video players, all of them working with the same way: video starts, plays for few mins, then video player crashes and it return back to Iptv app? Any solution for this?
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Android has no "info" key definition.
    It has been removed by Google for quite a long time.
  14. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It looks like a Kodi bug since the menu disappears itself.
  15. adi_tca

    adi_tca Trusted Helper Trusted Helper

    I doubt that Android blocks a specific key command from a specific remote by purpose, it may be that the generic Android keyboard profile is not a universal profile for any remote. This is the reason why Minix added the Logitech Harmony series remote controllers support by adding the Logitech corresponding .kl and kmc files, I assume.

    Now, as you mentioned, you should be able to overwrite the global KODI keyboard.xml functions by editing the keyboard.xml file found in the userdata folder. If you don't have such file, you can create a new one with Note++ for instance. The fact that you don't see an activity logged in KODI log file when you press the "info" button does not mean that its IR command has been blocked.

    You can get some inspiration maybe from below links, I'm sure you can search & find maybe better ones. I see there the "info" button being taken into consideration and an action defined for it:
    http://forum.kodi.tv/showthread.php?tid=220677
    http://kodi.wiki/view/Keyboard.xml

    I'm not sure what the "info" button does outside KODI, to me it doesn't sound like an "intuitive" action, such as "play", "pause" etc, irrespective if we talk about the Android OS or other OS.
    Unless Minix disagree, I would see this as a KODI related issue and not a FW issue (I understand that your Logitech remote works fine outside KODI), so these posts would belong to the XBMC/KODI forum section.
    Last edited: Aug 19, 2015
  16. MarcR

    MarcR New Member

    Thanks for the links and the answer. I will do more research and post in the mentioned XBMC/KODI forum section if I find a solution.
  17. Arin

    Arin New Member

    Hi!

    I have issue with Kodi 15.1 on this release. I can not fast forward or go to specific time in a video. Does anybody else have this issue? Is it kodi 15.1 issue or minix firmware update?
  18. Frederick_99

    Frederick_99 Well-Known Member

    what do you think ?
    might help if you gave us a bit of history on your updates to firmware and kodi
  19. rai

    rai Member

    I see a Firmware 007 is coming. SO maybe this problem is solved, but I still report it for 006A. In earlier releases i was not possible to install Google+ (and thus Google Photo). Since 006 it is possible. But showing photo's is working fine. Highest resolution of pictures is used. But watching the video's is only possible in LOW RESOLUTION. No HD. So I thought to be smart and first download the video from Google Drive. But even then Google is thinking that this device can't handle HD, so downloading it in lower resolution. I have to move the file to Microsoft OneDrive first to be able to download it in the full resolution. And then (surprise) Goggle is suddenly able to play it in HD. Can this be fixed?
    ChrisCiardy likes this.
  20. von

    von Member

    Clean install, No root or system mods etc... I'm unsure if this has been reported before or not. Box is connected via Optical cable to Samsung HT and HDMI to TV, Optical passthrough manually selected in both settings and KODI. playing any form of media in Kodi, sound works so far except if i reduce the system volume of the minix box from the A2 lite remote while sound is playing, it immediately introduces loud and continuous static noise ("sssssshhhhhhhhhhshshshshsh")... Something like that. Only stops if i up the volume back to maximum.