1. Official MINIX forum

[Bugtracker] Official X8-H PLUS 008/008A FW

Discussion in 'NEO X8-H PLUS 008 firmware via MINIX FOTA' started by MINIX - Ken, Jan 2, 2016.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all,

    Please report your problems found here.

    Only for those using official 008 (20151231)/008A (20160114) firmware without root.

    Thank you!

    Regards,
    Team MINIX.
    sangaz and yhadie69 like this.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Please kindly report those apps that don't work on X8-H PLUS,
    our next firmware will be focusing on increasing app compatibility.

    We wish to fix as many as we could, thanks.
    Postiga, sangaz and yhadie69 like this.
  3. tallest777

    tallest777 New Member

    The app that's not working on mines are preinstalled Minix XBMC , Kodi from Google play store and the Minix XBMC based on Isengard 15.2 build.

    A point to note.....I experienced the same problem when I updated to X8-H PLUS FW007_20150925. That was the 1st update I performed on my Minix Neo X8-H+. Can you guide me accordingly in correcting this, if it is not a general problem.

    Sent from my SM-N910H using Tapatalk
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It is not a general problem for sure, if it is everybody would be coming after us.
    Please reflash your firmware cleanly from a PC.
    Make sure you are having a genuine MINIX device because our version doesn't work on other boxes.
  5. tallest777

    tallest777 New Member

    I do have a genuine Minix device & I did flash it from a PC. Should I set it back to factory setting or erase all data before reflashing it?

    Sent from my SM-N910H using Tapatalk
  6. tusha123

    tusha123 New Member

    How to check genuine MINIX device?

    Sent from my NEO-X8H-PLUS using Tapatalk
  7. kaufman

    kaufman New Member

    I installed this firmware today (clean install) and the new XBMC 15.2.

    This new 15.2 XBMC gives jerky playback at times like it's dropping frames. This seems to happen when skipping forward or backward in a film and resuming playback. It doesn't sort itself out until you press pause and then play again. The previous version of XMBC seemed to cope better with smoother playback generally.

    I have noticed that this same jerky playback problem exists on the official KODI 15.2 when I installed that from the PLAY STORE recently.
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Do you mean only for a few seconds, if yes then it would be understandable because the app has extra large buffer setting and need more time to fill up.
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If you have a genuine device then the app will just launch straight away, nothing special has to be setup.

    All of our devices have a genuine hologram label on the gift box.
  10. MannyLee85

    MannyLee85 New Member

    It seems like a few members (along with myself) can't seem to get the NBA League Pass (formerly NBA Gametime) app to work. I'm currently on FW version 007 and I can't seem to get the app to even launch. Would love if you would be able to get this working in the next update. Much appreciated!

    http://minixforum.com/threads/issue-with-nba-app.8917/
  11. kaufman

    kaufman New Member

    It doesn't seem to correct itself very well (resume smooth playback) after fast forwarding or rewinding. If you push pause and then play it sometimes will correct it. I have also noticed when skipping through a film it has sometimes just stopped and restarted. This is probably as you say to do with the buffer as I have 1GB Lan wired connection with 75MB/s fibre connection. The old one seems to perform better.

    Is that something that can be corrected via advanced settings with the new build?
    swamprat96 likes this.
  12. selmimiinix

    selmimiinix New Member

    my minix get stuck very ofton after the update any one know why?
  13. coldfire

    coldfire New Member

    If updated fine on FOTA but after the update it got rid of all the shortcuts on the main screen :(
  14. Ahmed Osama

    Ahmed Osama New Member

    my minix gets stuck very often after the update any one know why? and the only solution is to reboot manually .. it gets stuck whenever I use the browser on it I tend to use "Now Browser" in fullscreen mode with youtube tv as a homepage enables using youtube as my TV when necessary but it just keeps getting stuck ever since the update .. HELP please
  15. sampleee

    sampleee New Member

    Hello people,

    i have a bug to report. it seems to be an amlogic related problem. i think so, because if you google the problem you can find people with other AML-equiped hardware reporting the same.
    still i assume this is the one place to adress myself to, since i run a x8h+

    the bug: when i switch channels in kodi in livetv, from time to time the picture vanishes (osd is still displayed) while the sound goes on.
    one fix for this is turning off hardware acceleration in kodi/xbmc. of course this is a very poor/unusable solution because HD channels without hardware acceleration..... no way.
    my "solution" is to keep switching up and down a couple of times and evetually everything is just fine.

    i report this here because i hoped 008 would fix the problem. it dindt. i had this problem from stock through all updates. rooted, not rooted. tried finless too. really tried everything.
    i tried all kinds of backends in a number of versions (tvheadend and vdr). i tried all kinds of "xbmc's"; the official minix ones, old and most recent versions from kodi.tv, spmc.... all that in all imaginable combinations. but the problem remains exactly the same. on other devices (android-phones and tablets, linux desktops, windows desktops) there is no problem at all. so i am very sure this is an amlogic thing.

    I would be very happy to help with logfiles, testing or whatever needs to be done in order to fix this.

    cheers! ^^
    Last edited: Jan 10, 2016
    rom69 likes this.
  16. Fogel70

    Fogel70 New Member

    I had problem with my unit freezing every couple of hours after the update, but it seems to have been resolved by performing a "Factory data reset". It's not fun to have to reinstall everything from scratch again, but I have experienced the same thing on other Android devices too.
  17. Jeffers24

    Jeffers24 Active Member

    You could have copied the hidden folder .Kodi before reset and re-installed after reset :)
  18. kaufman

    kaufman New Member

    Is there something I can do at my end to help with this?

    Anyone else experiencing this issue moving to the new 15.2 XBMC?
  19. Fogel70

    Fogel70 New Member

    It's not so much Kodi i'm worried about as a regularly backup it. It's all other apps that have to be installed/set up.

    But anyway, I might have been too early in my conclusion as my X8H-Plus has frozen once again. This time it took a whole day for it to happen, instead of every 1-2 hours as before I reset it.
  20. rom69

    rom69 Member

    Hi Ken.
    My wishlist for next firmware update:
    - Amazon video working.
    - No black screens on life tv channel switching. Regarding this topic, I have almost the same history like in the post attached. As all my other devices are working with different XBMC and Kodi versions, from my point of view this is X8-H plus or AMlogic related.
    Regards
    rom69