1. Registration issues have now been resolved. New accounts are able to be created

[Bugtracker] Official X8/X8PLUS/X8-H 004A FW

Discussion in 'X8, X8 Plus, X8-H Official Firmware 004' started by MINIX - Ken, Apr 24, 2015.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    there are many apps called "Livestream", could you please specify the region and the play store link? we fixed an app with the same name before, maybe yours is another one.
  2. Mtr77

    Mtr77 New Member

    Hi minix team just quick thanks for your hard work in supporting our media players as most other brands do not follow up with the product but with 4.0a my power back on after a few days off does not work I have to press the side power button manually please help regards mick it worked on 3rd & _2 version firmware
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I don't understand the problem, could you explain more?
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We've checked again this morning, the MAC address is static with this firmware?
  5. Mtr77

    Mtr77 New Member

    In the past i could use my logitech harmony 900 universal remote to wake up my neo x8 h as a part of my activity now it appears that the unit is in a deeper sleep and does not respond to wake up commands only a hardware press of the power button turns the unit on its only a problem with version 4 cheers
  6. viktor

    viktor New Member

  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    it's about the delay you set for the power command.
    our original IR remote, short press = sleep/wake; long press = power menu
    our firmware is to consider compatibility of our own IR remotes,
    you need to cope with our settings, we can't change it for you which may affect our own remotes,
    please understand.
    you may test and compare with our stock IR remote.
  8. KristianP

    KristianP New Member


    Hi
    I have same issue with my logitech remote. Thanks for explaining. Understand that logitech remote are very popular so this might impact many of your customers.

    Some questions
    Would it be possible with some kind of workaround? Maybe have some kind of setting?
    Why was it changed have worked perfectly in all previous firmwares?

    Otherwise thanks for a great machine and all your work with updates of firmwares.
  9. ChristopheC

    ChristopheC New Member

    Hi,

    You do a fantastic job, always happy with the updates and the device itself.

    But for the first time, i have some problems (minors but it's annoying 'cause i didn't have any on the other updates).

    1/ Youtube app provided with the stockrom. Black screen at every return/ back button with my official Minix A2 remote control.

    2/ Restart of the launcher at everytime i press home (i use squarehome, but it wasn't a problem before, maybe i must try Nova)

    3/ Freeze of the Minix Xmbc Gotham 13 and the app crashes sometimes. I never experienced a problem with it before.

    4/ The most annoying : Again in Xbmc some playback problems, sound is not sync with the picture, never experienced before.

    So my question is : Is it possible to go back to official firmware 3 ? Everything was perfect. I did the 4 firmware because of the Google+ support.

    Thank you for your support !
  10. adi_tca

    adi_tca Trusted Helper Trusted Helper

    @ChristopheC:
    I am also with 004 FW (X8-H), but I have no issues with Youtube; as launcher I use Nova, never had issues with it. I had quite few issues with Minix XBMC, but it happened also in previous FW releases (but never had the audio sync issue, or at least I didn't noticed it...). Looking in the XBMC log files in the past, I noticed that the issues were mainly coming from the video web source streaming bandwidth. That was the reason to use mainly xbmctorrent or kmediatorrent, best XBMC add-ons for me (like Navi-X also).

    If you want to go back to 003, you can do it via USB burning tool (forum server link worked best for me):

    Full system image & Windows USB burning tool:
    http://minix.com.hk/firmware/X8_X8PLUS_X8H_003FW.rar
    Forum server: http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_003FW.rar
    MD5 checksum: DDA77A0AAB8E907890BF45A3F17636F2
  11. ChristopheC

    ChristopheC New Member

    @adi_tca

    Thank you for your answer.

    I forgot to mention that the first second of every media that i play, the sound is missing (youtube, xbmc, vimeo on the browser, etc...).

    I will test Nova tonight. Regarding Xbmc, it concerns my video collection, which it's local and not streaming.

    Can i maybe test Kodi along with the Minix Xbmc ?

    I will test these before downgrading.

    Anyway, thank you ;-)

    AND Sorry for my bad english ;-)
    Last edited: May 5, 2015
  12. adi_tca

    adi_tca Trusted Helper Trusted Helper

    @ChristopheC

    You can also try Kodi 14.2, it installs in a separate folder than Minix XBMC. Did you had before any advancedsettings.xml file for Minix XBMC with some buffering settings for the local content? Not sure though if this XBMC settings file has any connection with the freezing/crashing you mentioned ...

    Good luck
  13. ChristopheC

    ChristopheC New Member

    No i didn't modify the settings....My version worked great so i didn't do anything...I will try Kodi tonight to...Thank you ;-)
  14. adi_tca

    adi_tca Trusted Helper Trusted Helper

    I was referring to an XBMC file named "advancedsettings.xml", where you can set how to handle buffering for local files (and a lot of other stuff), not to some specific settings in XBMC.
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I guess the black screen is talking about "self-adaptive refresh rate switching" as it should kick-in @ youtube videos
    You may switch it off. Next update we shall make this OFF as default since quite a number of users are confused with this feature.

    This update is a big one, from an old SDK to the latest SDK, if possible please perform a system factory reset,
    it should help to make the system more stable since we don't know what modifications have been done on your side between the updates.
    Thanks!
  16. kendub

    kendub Member

    This update is a big one, from an old SDK to the latest SDK,

    What is an SDK please

    And suggestion for next FW update
    a toggle / option, so the minix auto powers on
    (easier than having to change jumper on MotherBoard)
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    SDK is the source that our firmware is based on.
    the toggle you suggested is not possible by software update.
  18. Mtr77

    Mtr77 New Member

    I found a way to fix the power problem with logitech harmony remote as most of us have picked neo x5 device so we can use it with xmbc all the other button's work you have to do is click relearn power toggle and learn from power button from neo x8 original remote worked like a charm cheers mick
    danfozzy likes this.
  19. ChristopheC

    ChristopheC New Member

    Hey...i made a factory reset such as suggested. It seems like it solved the problems.

    I still have to check audio/video sync in Kodi...will keep you posted.

    Thank you ;-)
    MINIX - Ken likes this.
  20. wildbyte

    wildbyte New Member

    Hi,

    After press back button from latest minix xbmc my squarehome luncher is oversized. It has boundaries over the screen edges. To fix this i need to lunch any other app than go back to homescreen. On 003 such behaviour never happend.

    Thanks,
    Maciej