1. Welcome to the official forum for MINIX devices!

[Bugtracker] Official X8/X8PLUS/X8-H 006 FW

Discussion in 'X8, X8 Plus, X8-H Official Firmware 006' started by MINIX - Ken, Jul 9, 2015.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Here is my advice:
    Download the latest FW006 image, perform a clean reflash with a PC.
    Don't touch anything during first boot after reflash for 10 minutes to allow background installations to complete.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Can't do it without root access. As our firmware can't grant root access, you need to find an alternative.
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1.) Some steps seem missing, e.g. I don't see you enable DTS support (not relevant to your video anyway)
    2.) System volume level is zero (muted).
    3.) Is your sound blaster device capable to decode AC3, DTS streams?
    4.) We have the same test video, it works fine with our Yamaha amplifier.

    zero.jpg
  4. elgaard1979

    elgaard1979 New Member

    Thanks Ken - will try that when I get home from China after August 27th - and will post results. Not ideal, but I guess that's more of an Android issue than a Minix issue.

    BTW: Is there any way to do a full backup that will work? Any thoughts on using Titanium Backup for this - will that be ok?
  5. znie

    znie New Member

    do you mean the mac address reservation on my router? the issue is the minix x8-h's ethernet mac address keep changing.
  6. Howard_UK

    Howard_UK New Member

    Hi I upgraded from stock to 006 last night and since doing that when I start trying to play some videos the x8-h goes into sleep mode (TV shows no input message) but will not switch back on until I either do multiple power button presses or remove hdmi lead and reinsert then power on. It doesn't do it on every video or everytime on a video that it had done it on before. It does now seem to be getting worse. The box is currently virtually unusable.
    Last edited: Aug 11, 2015
  7. Higgs

    Higgs Yellow Dude Super Moderator

    Sounds like the auto refresh rate switching isn't compatible with your TV.
    Disable the adaptive refresh rate option in mbox settings.

    Sent from my MotoE2(4G-LTE) using Tapatalk
  8. Howard_UK

    Howard_UK New Member

    I haven't got self adaptive refresh rate switched on and I doubt it's anything to do with compatability issues with the TV as it's only a few months old. TV is a Samsung UE48H6400KXXU btw. This is happening in Kodi but as that's the only thing I watch video on I'm not sure if it is happening when not in the program.
  9. Higgs

    Higgs Yellow Dude Super Moderator

    Can you try another video app?
    Also make sure auto refresh rate option isn't enabled within kodi.

    Sent from my MotoE2(4G-LTE) using Tapatalk
  10. Howard_UK

    Howard_UK New Member

    It seems to be the Adjust display refresh rate in Kodi as suggested, thanks. Although I haven't adjusted this setting since updating to 006 so there must be something in the firmware causing it. I confess to not really understanding the full detail of what this option does or doesn't do but as Kodi defaulted the option to always on am I going to notice any ill effects from having it turned off?
  11. Ve3Mike

    Ve3Mike New Member

    Hi, I am currently using the X8 directly wired Ethernet connection. I noticed with the Official Twitch App from the Play Store that there is a lot of buffering issues on High/Source Quality with the video. I went back to Firmware 003 and the issue disappeared. I was wondering if this could be looked at?

    Thanks!
  12. Jimi

    Jimi New Member

    Mx player have a bug, if i play mkv video using hw decoder, if i skip frame the volume will be maximum for a few second
    stefan9999 likes this.
  13. Gabriel23

    Gabriel23 New Member

    Android-Box: Minix X8-H
    UHD-TV: Panasonic TX-58AXW804

    UHD does not quite work - it flickers. In FW006 it has become much better, but not gone.

    The TV has HDMI 2.0 port 4

    best Regards
  14. Problems with the CEC, looks like it stops working when device left on...
    Any others experiencing this?


    Sent from my iPad using Tapatalk
  15. ebrown761

    ebrown761 New Member

    Crackle Video app crashes on the Minix-X8 latest firmware
  16. wildbyte

    wildbyte New Member

    Sometimes after wakup from sleep embeded self-adaptive refresh rate switching options stops work till next system reboot.
  17. yc1437

    yc1437 Member

    Until today, I still encounter device never wake up after put the Minix to sleep with Kodi loaded.

    Sent from my SM-G900F
  18. Dennis_N

    Dennis_N Member

    Just updated to fimrware 006 and now there are hiccups in the sound of movies or music some times (spdif setting). Is this a known problem and is there a fix?
  19. elgaard1979

    elgaard1979 New Member

    So I did the full refresh from pc thing, and it seems to have worked. For more than a week now, I haven't had a green-screen or a reboot. It may still come, but I'm hopeful it has been solved. Hope I don't have to do THAT again, as it takes quite some time to set up - but if that solves it, then at least I have a workaround. Thanks Ken!