1. Official MINIX forum

[Bugtracker] Official X8/X8PLUS/X8-H 007A FW

Discussion in 'X8, X8 Plus, X8-H Official Firmware 007' started by MINIX - Ken, Sep 4, 2015.

Thread Status:
Not open for further replies.
  1. gjs999

    gjs999 Active Member

    Its better to wait than rush out a firmware update which has unsolved issues . I'm sure Minix could push out a copy now but then everyone would bitch this error or another , when you think of the multiple configuration /apps people can have it must be a nightmare for testing and some issues will be cause by the core of andriod itself (which Minix has no control over)
    sangaz and WilfredG like this.
  2. Copylex

    Copylex New Member

    Can we also espect an android update for the Minix X8-H plus? Currently it has 4.2.2.??
  3. Villa

    Villa Trusted Helper Super Moderator

    Current Android version is 4.4.2
    Also you posted in the wrong forum if you have an X8-H Plus !
    This forum is for the X8-H, X8 Plus & X8

    You should be looking here...
    http://www.minixforum.com/forums/official-firmware-releases.96/
  4. max80

    max80 Member

    I have 2 problems:

    1) the most important: I have the same audio drop issue reported by many other users. Everything worked fine with stock 002 firmware; the problem came out after fw upgrades (made via FOTA) and currently persists in latest 007 firmware.
    (I cannot identify the fw version that brought that issue cause I updated from fw 002 to 006 in one day, after a year of Minix working flawless... that's so frustrating)

    Wish there is a way to solve this issue apart from flashing the device to 002 firmware.

    2) the 'enter' key in the A2 Lite keyboard still does not work (when updated via FOTA, this was reported as fixed bug)

    my setup: Minix X8-h connected via HDMI cable to Sony TV, PCM Audio output, automatic framerate switch disabled.
  5. Higgs

    Higgs Yellow Dude Super Moderator

    1 Most if not all of the audio drop issues have been reported by users connected to receivers. I'm not sure if there were any issues reported with a straight hdmi connection to a TV. If there are then please correct me. Is the issue in all apps?
    You could try a factory reset to see if this fixes it, as updating via FOTA might not clear any existing bugs that are present.

    2 Can you give a bit more detail on the enter key not working? I seem to recall this but I'll have to search back through all my posts.
    [edit] I see this was reported fixed in the 007A fw update and confirmed by different users. I also don't see any reports since. If you're sure you have the 007A fw and still have this issue, then I would do a factory reset.
    Last edited: Jan 13, 2016
  6. max80

    max80 Member

    The problem is that a device that requires a factory reset for every fw update is quite unusable.. I'll try and report if issues still persist.
  7. Higgs

    Higgs Yellow Dude Super Moderator

    The fact is that most users don't have to do a factory reset ever and certainly not with every fw update.
    But bugs do happen and sometimes a factory reset in the only solution. I haven't had to do a factory reset on my X8-H Plus, since fw002, but I've had to reset my Motorola phone twice in 12 months (not in last 6 months so hopefully I won't have to factory reset it again).
    sangaz likes this.
  8. max80

    max80 Member

  9. Higgs

    Higgs Yellow Dude Super Moderator

  10. max80

    max80 Member

    The audio issue is present with MX Player and 4k Player too, so it's not XBMC related.
    This is a screenshot of the minix sound settings:
    Screenshot_2016-01-13-15-48-57b.jpg

    these are some lines from xbmc.log that seem to be related with my audio issue:

    15:21:52 T:1879291304 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
    15:26:49 T:1911798424 WARNING: Previous line repeats 1125 times.
    15:26:49 T:1911798424 DEBUG: CDVDPlayerAudio:: Discontinuity1 - was:318779842.577883, should be:318656000.000000, error:-123842.577883
    15:26:50 T:1879291304 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
    15:26:51 T:1911798424 WARNING: Previous line repeats 6 times.
    15:26:51 T:1911798424 DEBUG: CDVDPlayerAudio:: Discontinuity2 - was:320680933.000000, should be:320663766.972183, error:-17166.027817
    15:26:52 T:1879291304 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
    15:30:10 T:1911798424 WARNING: Previous line repeats 673 times.
    15:30:10 T:1911798424 DEBUG: CDVDPlayerAudio:: Discontinuity1 - was:519052934.972183, should be:518944000.000000, error:-108934.972183
    15:30:10 T:1911798424 DEBUG: CDVDPlayerAudio:: Discontinuity1 - was:519154914.000000, should be:519040000.000000, error:-114914.000000
    15:30:10 T:1879291304 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
    15:30:24 T:1782854368 WARNING: Previous line repeats 42 times.
    Last edited: Jan 13, 2016
  11. Vidman

    Vidman Member

    Drop outs happen in all apps and when connected to an avr or direct to TV doesn't matter
  12. Rogier

    Rogier New Member

  13. max80

    max80 Member

    Already viewed that post, but I dont' trust beta releases and nobody explained if that patch requires a particular fw version installed and it seems that it hadn't solved the problems for some users, and I was waiting to see if this patch would have been included in FOTA updates. I spent a lot of timeinstalling apps and configuring my device, so I really hope Minix will find a solution to this issue and include that in a regular FOTA update.
    Rogier likes this.
  14. novichok19

    novichok19 New Member

    I also have dropouts. Did yesterday FW007A with USB_Burning_Tool and not posed as FOTA and drop outs are gone.
    Rogier likes this.
  15. Vidman

    Vidman Member

    Did you actually read the first post ? It is a patched version of fw003 that was having audio issues we are now on fw007a
  16. Vidman

    Vidman Member

    I not understand you post , can you explained more betterer?
  17. max80

    max80 Member

    I just flashed fw image 007a via otg and usb burning tool. The audio problem SEEMS disappeared. (I've only tested with the latest video file that suffered that issue, so it could be just a coincidence). Now I'm gonna reinstall other apps and restore my data back. I'll keep you updated in the next days hoping that the issue won't come back (crossed fingers). If everything will be ok, I think it's reasonable to think that the problem is the fw update process.
    Obviusly if everything works I'll not do any FW update in the future.
  18. Vidman

    Vidman Member

    Yes please let us know here either way
  19. novichok19

    novichok19 New Member

    Sorry, Google transalate. Audio Problemme gone with me after flashed fw image 007a via USB OTG and burning tool.
  20. Vidman

    Vidman Member

    OK thanks so it's sounding like reflashing is the fix
Thread Status:
Not open for further replies.