1. Registration issues have now been resolved. New accounts are able to be created

Can't get any firmware to work ?!

Discussion in 'NEO X5 mini Official Firmware Releases' started by richy_h, Dec 17, 2014.

  1. richy_h

    richy_h New Member

    I have the neo x5mini which always worked well enough, but was prone to random crashing, so I thought I'd try flashing newer or older firmware. Downloaded all available versions (for the x5mini) from the official site, followed all instructions to the letter, using the rkbatch tool, waiting 10mins after each flash etc
    My box now no longer works with any of the versions :( Depending on which one I've flashed, I either get a minix/android logo which stays on infinately. The same logo but flashing, a black screen or an android recovery screen which gets to "starting boot" but then freezes.
    Please can anyone help, spent about 2 days with this !
  2. Higgs

    Higgs Yellow Dude Super Moderator

    When you flash using the rkflash tool, do you get any error messages or do you get a success message at the end?
    Try flashing the latest firmware again (with the hdmi cable connected to a monitor/TV if possible). At the end of the flash process you should get either a fail or success message in the flashtool and you should see the box reboot, perform a first boot and start to load the preinstalled apps etc. This might take 5-10 mins.
  3. richy_h

    richy_h New Member

    Thanks for the response Higgs.
    Yes, appears to flash ok, all the script logs say "success" and 0 fails or similar.
    The minix then re-boots, (as supposed to) but then the screen freezes up as described above.
    Have left it up to 30mins just to make double sure !
    One of the update versions does allows me to enter recovery mode on the box.. I've found some zip versions of the firmware, so going to try flashing them that way instead.
    I read about maskrom mode, where you open the box up and short two points together..would this help in this situation, do you think ?
  4. Stevenakis

    Stevenakis New Member

    I have exactly the same problem.
    Has anyone been able to get around this ? The 4.2.2 "upgrade" turned my Neo X5 mini completely useless. Even installing the original FW doesn't help anymore (boot screen staying black forever).
    Help please !
  5. mithat

    mithat New Member

    i had the same problem.
    then i used rkbatchtool version 1.6 , that did the trick for me.
    the black screen was gone.
    dont use rkbatchtool 1.7
  6. Stevenakis

    Stevenakis New Member

    Thanks Mithat for your reply. Unfortunately rkbatchtool version 1.6 doesn't work for me. Results are exactly the same as described by richy_h.
    Sigh... will have to start looking for an alternative. This for sure won't be a Minix again :mad:.
  7. Stevenakis, have you tried to contact support directly?