1. Welcome to the official forum for MINIX devices!

Color depth issue: 8-bit color only!

Discussion in 'NEO Z64 Windows 10/8.1' started by Lars2, Mar 26, 2015.

  1. Lars2

    Lars2 Member

    Hello

    I have tested my new Z64w now for some days. The picture Quality is very bad, photos look very bad, also fan art in KODI Looks very bad (i.e. the poster of a movie).

    I have connected it to my projector. With the projector I can show some info about the video source. There I can see that the color depth is only 8-bit. So now it´s clear why the photos look that bad...

    I checked in the Intel HD-Graphics Settings, there it is set to 32-bit Color depth.
    (Go to: Control Panel > Intel HD-Graphics > Display > Color)

    Has anyone an idea how i can fix this?

    Thanks
  2. WeK05

    WeK05 Audio Visual Master Specialist

    There is nothing to be fixed here. It is just a matter of how the color depth is reported.
    Intel HD Graphics - 32 bit/pixel - 24 bit true color (8 bit/channel) + 8-bit for the Alpha channel (Transparency where needed).
    Projector - 8 bit/channel - 24 bit/pixel
    Only few video formats support alpha channel - Apple animation, Apple ProRes 444, Quicktime, Flash Video, VP6, VP9
  3. Lars2

    Lars2 Member

    So there is no way to enhance the picture quality? Photos look very bad...
  4. WeK05

    WeK05 Audio Visual Master Specialist

    There are some luma and chroma errors in the output signal, but it is nothing that I would call as horrendous. Can your projector auto adjust the dynamic range? The output of Z64 is RGB Limited (16-235). If your projector is in RGB full range (0-255), image will look washed out.
  5. Lars2

    Lars2 Member

    I checked the projector settings and the manual of the projector. Dynamic range is correctly set to "standard" wich is 16-235 according to the manual.

    I compared the same photos on my computer using the attached computer Display, and there is really not that huge difference. They look a bit smoother on my computer though.

    I have to check on the Minix with some higher quality photos and again with Kodi/XBMC how the movie posters look like...
  6. Lars2

    Lars2 Member

    I tested the Picture Quality also on my TV now. There I figured out that I have reduce sharpness and set it to 0 (Zero). Doing so made the Picture Quality much better and the photos are not as grainy as they where before. I have to re-check with my projector to see how sharpness affects the picture quality.

    I will try to take some Pictures to show what I meant exactly with the poor picture quality. But it's much much better now!
  7. WeK05

    WeK05 Audio Visual Master Specialist

    Although sharpness is not supposed to have an effect on digital signal, I have seen many reports where it actually affects the picture quality. You may have to tweak the settings.
  8. Zohar Bar-Yehuda

    Zohar Bar-Yehuda New Member

    Try changing to RGB Full Range as explained in the post "Why black looks gray using Intel HD Graphics drivers on Z3735F and z3770?" (won't let me link, just google this phrase)

    It solved the issue on my Samsung TV which was expecting full range, and therefore blacks looked gray until I applied this change.
  9. Corinthian

    Corinthian New Member

    Can you walk me through, step by step how to do this as explained in that post below. I'm not sure what the instructions are telling me to do exactly and I'm nervous about mucking with my regedit. Please ELI5

    (Solved using regedit

    1) Go to the "display" registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\****

    2) Create DWORD value:

    EnableRGBFullRange

    and set it to 1)

    3) Reboot.
  10. WeK05

    WeK05 Audio Visual Master Specialist

    Keep in mind that all video content has 16-235 levels as per ITU-T Recs. It is OK to change RGB levels to Full (0-255), but doing so will crush black and clip white in all of your videos. RGB Full is for games and other PC applications. If your display does not support RGB Limited, changing the levels to full might be the only option to avoid washouts.
  11. Zohar Bar-Yehuda

    Zohar Bar-Yehuda New Member

    Just double-click EnableRGBFullRange.reg in the attached zip to add the key to the registry, and reboot.
    If you're not happy with the results, simply double-click DisableRGBFullRange.reg to remove the key, and reboot again.

    Hope this helps.

    In my case (Samsung F5000) the default "HDMI Black Level" "Normal" setting on the TV is equivalent to "Full" range, but when I tried changing it to "Low" which should be equivalent to the "Limited" range blacks seemed to become too dark.

    Setting EnableRGBFullRange on the device itself and keeping the TV at default settings seems to produce the best result.

    Attached Files:

  12. jje

    jje New Member

    Thank you so much. You made my day !
    =)
  13. jje

    jje New Member

    Also, could you do a fix for 3D monitors ?
    Intel settings has to be changed on every movie, no matter what it revers to RGB. Unfortunately the tv is only Limited RGB 16-235. But after applying your fix, i dont need to change the 2D setting manually every single time. Thanks again.