1. Registration issues have now been resolved. New accounts are able to be created

Custom ROM Configurable Custom Firmware

Discussion in 'X8-H & X8/Plus Custom ROMs, Kernels & Discussion' started by messer, Dec 14, 2014.

  1. etwintje

    etwintje New Member

    Happy new year and the best wishes for everyone in 2015!

    I don't use an adapter to connect the x8h to my tv, my tv is a 26" lg tv with hdmi inputs and a maximum resolution of 1280*720 (720p) but it should be able to run 1080p scaled down. My monitor is a 24" and it is a 1080p monitor. Both are directly connected without any adapter through hdmi. I'm not sure if the screen is also too wide, or only hight is off. But i did some kind of error: error opening sys/class/leds/lcdblacklight. If I'm correct it was TWRP showing this error. Also I don't have to adjust the screen size in android, it fits perfectly, so no problem on that. It might be a problem in the communication between the tv and the screen? Strange thing is that my pc monitor supports 1080p and it got a resolution of 720p send to it. If I need to test anything just give me a shout!
  2. messer

    messer youthful doter Dev Group

    That's a TWRP error message which is independent from the aroma installer issue.

    This point seems to be the problem. Unfortunately Aroma installer and Edify offer only a very limited command set ... HDMI communication is definitively not a part of that.

    I will send you a PM with a link and some comments. Would be great if you could test it.
  3. hawzman

    hawzman Member

    Happy New Years to all!!! Messer great to see you here!!!
    This rom is awesome no problems at all
    Thanks for all the hardwork
  4. messer

    messer youthful doter Dev Group

    Hi!

    @hawzman
    Thanks for you positive feedback!

    @all
    Well, during the last days I have spent all of my spare time trying to re-produce the truncated screen output. I have made tests with my 2 devices including the usage of all setting options. Furthermore I have tested it with the TVs of 3 friends.
    At the end I was not able to re-produce this effect :(.
    As a last step to find a solution I have asked etwintje to check several test files with intention to find a solution. As soon as the results are available I will let you know.

    In order to make people aware of this effect that is arising very seldom (by now only twice) I will add this as a known issue in the first entry of this thread.

    If etwinje's tests will not lead to a solutions I will have to accept this curious effects :cry: ... as long as nobody else has a good idea how to solve it.
  5. HiMaNeN

    HiMaNeN Member

    Thanx for the ROM works great couldt get the Installer to run at first but it worked fine after i disconnected my 2.5" hd.

    Is it possible to create a plaintext file from the installer? ive been playing around with an own custom rom and added Telnetd login with busybox and i would like to be able to set the password the user want from the installer.
  6. Edwin

    Edwin Member

    Hi Can anyone tel me if this custom Rom support the following:

    1- static ip addressing ! (this does not work on stock firmware,nor the guru beta 9 i have tried, it forgets the static ip settings after reboot ( yes i completed all the fields)
    2- dutch keyboard in xbmc Kodi od xbmc minix version (i never got this to work, my Azerty dutch Logitech K400 always comes up as a querty keyboard

    Thanks in advance for all the great work you have put into this custom Rom!
  7. messer

    messer youthful doter Dev Group

    Hi HiMaNeN,

    to be honest - I don't understand what you mean with plain text ... my assumption is that you want to enable a user to set parameters for the installation (e. g. password for telnet connection). This approach is not possible with this firmware.
  8. messer

    messer youthful doter Dev Group

    Hi Edwin,

    the custom firmware is based on the standard Minix firmware (without any network related changes). Thus it behaves identical to the stock firmware.

    In order to get the k400 keyboard working with a dutch keyboard layout you need two keyboard specific files that include the layout (Vendor_046d_Product_c52b.kcm which has to be placed in the folder /system/usr/keychars and Vendor_046d_Product_c52b which has to be placed in the folder /system/usr/keylayout). Both files are included for German keyboard layout (got it in a German forum) but not for dutch.
    So, if you could find the corresponding layout files somewhere in a Dutch forum I will be able to include it into one of the next firmware versions (if you send it to me).
  9. HiMaNeN

    HiMaNeN Member

    Yes that what i ment =) Thanx for a good rom and let me know if i can help you in any way
  10. Jarred_D

    Jarred_D New Member

    Hi

    How do you flash this rom? I tried but get "verification signature failed" and a few other failures. I used the update & backup method then goes to revovery screen and used "install from zip file" and "install zip file from udisk"

    thanks
  11. HiMaNeN

    HiMaNeN Member

    Install TWRP a custom recovery flash this file custom recovery
    Then flash the rom from the new recovery.
  12. Jarred_D

    Jarred_D New Member

    THanks but is there any tutorial on how to do this? I searched but could not find
  13. messer

    messer youthful doter Dev Group

    That's the first time that somebody is coming up with a signature error :( ?!? Never got that feedback before - to be honest, I have currently no idea why (but will investigate into it).

    I have never written a tutorial because this zip has to be installed like any other zip ...
    ... boot into recovery (e. g. as mentioned above)
    ... install zip from sdcard
    No secrets or something similar.
  14. Jarred_D

    Jarred_D New Member

    I know its so weird, i managed to use TWRP recovery also but it also says "signature error" or something and wont install. Ive installed plenty of roms before but this one has me stuck.
  15. Willis

    Willis New Member

    Sounds, to me, like the download is corrupt - did you get the TWRP you installed out of this download, or from elsewhere? I'd try downloading again, maybe from a mirror, to see if another download might work...
  16. Jarred_D

    Jarred_D New Member

    Thanks for the help guys, still getting the "zip signature verification failed" but will keep trying and see what happens. I tried another download file and same thing. The TWRP i downloaded from here Willis but ill try your suggestions. Thank you Kindly. (y)
  17. Willis

    Willis New Member

    Are you altering anything in the *.zip file after the download? That would give you the error...
  18. Jarred_D

    Jarred_D New Member

    I did not alter anything, just copied file straight onto sd card (n)
  19. Jarred_D

    Jarred_D New Member

    If i dont select Zip Fil Verification then the error message is "No MD5 file found", "Error Flashing zip"
  20. etwintje

    etwintje New Member

    And you are not trying to install it on a x8-h plus?