1. Welcome to the official forum for MINIX devices!

couldn't connect to server

Discussion in 'Kodi/XBMC for MINIX' started by gr3atn3ss, Sep 20, 2016.

  1. gr3atn3ss

    gr3atn3ss New Member

    I can't seem to add any type of addons on kodi..anytime i try, the only message i get is that it couldn't connect to the network server. I can still use and watch tv shows/movies on my the addons i already had installed but won't let me add anything new. I have even tried using the browser on the android box to ensure that it was indeed connected and everything else seems to work fine, i just can't get any addons anymore. I'm hoping someone can help, i've tried almost everything, but it wasn't enough since i havent fixed the problem, i know i'm missing something and a bump in the right direction would be great. I am using the z64 android box if that helps any, and i have uninstalled kodi, updating kodi and that hasn't fixed the problem either. Please help. Hope you all enjoy the rest of your day.
  2. Higgs

    Higgs Yellow Dude Super Moderator

    Which version of Kodi are you using? Where did you install it from?
    Maybe an issue with the repository server?
    Which repository are you adding from? Have you tried different repositories, including the official Kodi one?
    Can you describe the steps you are using to add the addons and where/when you get the error.
  3. gr3atn3ss

    gr3atn3ss New Member

    I tried it using Jarvis, I think thats 16.1, and didnt work, so i tried it using the Kodi that came preinstalled on the box, which is kodi 15, and that didn't work..So i go to system settings, file manager, type in the Fusion url, name the source. I've double checked the URL countless times to make sure i've typed in correctly. When i click done, the message pops up, saying it "couldnt retrieve directory information, this could be due to network not being connected". However, as i mentioned above, everything else on the box seems to be working, the browser, older addons, but unable to add any new source. I've tried multiple solutions, but nothing seems to be helping.
  4. Higgs

    Higgs Yellow Dude Super Moderator

    Then either the URL you entered is wrong or the 'Fusion' URL isn't working.
    In either case the tvaddons site is the best place to go for help with 'fusion' addons.
  5. gr3atn3ss

    gr3atn3ss New Member

    Any URL i've tried to add has the same result, but guess i gotta keep trying to fix it .
  6. Higgs

    Higgs Yellow Dude Super Moderator

    What are all the URLs that you tried?
    Have you tried adding an add-on from the installed kodi repository?
    Sent from my MotoG3 using Tapatalk
  7. Villa

    Villa Well-Known Member Super Moderator

  8. gr3atn3ss

    gr3atn3ss New Member

    It worked in the past, followed exactly the link you sent me when i first got my android box. I had no problem at first, each source was added quickly, never really had any problems with it. I've double checked to make sure the fusion URL is correct a thousand times because that's what majority of the people were saying could be the issue.
  9. smera

    smera Member

    Maybe it has something to do with your internet provider?
  10. Marm

    Marm Member

    Since you are getting no where and your Internet is working, and you are basically desperate why not start over? I have had a bad installation where nothing would install. I had to start over. So I suggest you uninstal Kodi (or XBMC for MINIX) then get a fresh install of the latest stable version. Next, carefully install Fusion and then any other add-ons.

    Oh, if you have copied the URLs down, go get them again.

    I just remembered a year or two ago, many people were panicking as they could not install Fusion while the servers were down briefly.

    I doubt they would do this but if you still can not get to the URLs there is a remote chance that your ISP is blocking them. If that is the case, you will need a VPN to get to there.
    Last edited: Sep 21, 2016
  11. rmaijala1

    rmaijala1 Member

    Another thing, if you copy and paste from a Web page sometimes there are hidden characters or a space at the start or the front of the address that you can't see. Try typing them in if you can.

    Sent from my SM-T715Y using Tapatalk
  12. Villa

    Villa Well-Known Member Super Moderator

    As far as I am aware it's not possible to copy and paste in to Kodi/XBMC..
    Marm likes this.
  13. tommulv

    tommulv New Member

    I too have this problem when I try to add a source on my new Neo X8- H plus , (I have done it lots of times on my old box ) However when I downloaded a new Kodi app I could add the source Fusion to it ,but every time I run the Kodi app it runs as a first time run but it works fine .The problem seems to be on the original XBMC that came installed on the box
  14. tommulv

    tommulv New Member

    I think I have sorted it out when I go to System /Settings/Services/Remote control ,switch on allow programmes on other systems to control XBMC .I was able to connect to server when I did this
  15. COSTAS

    COSTAS Member

    Hi. Was your connection issue resolved?