1. Welcome to the official forum for MINIX devices!

Default Windows audio level 37%, how to change it?

Discussion in 'NEO Z83-4' started by emanuelsj, Jun 21, 2017.

  1. emanuelsj

    emanuelsj New Member

    Hello everyone,

    My Minix Z83-4 is working flawless, except the audio level in the Windows mixer, which always starts with 37% when I turn on the device. Of course, I can raise the volume up from the system tray sound icon, by moving the slider, but the next time I will restart the device, it will show back 37%.

    It is annoying always to change the sound level, because my bluetooth mouse is not the best and is hard to grab the little slider to raise the volume. Also, for the next two weeks my Minix device will be used by someone who has really low PC knowledge, so is important to start at 100% by default, if I shut down the device with this value.

    Thank you in advance for your help!
    Emanuel
    kresko likes this.
  2. emanuelsj

    emanuelsj New Member

    Just wanted to add that modifying the value in "Control Panel/Sound/select the audio device/Properties/Levels" to 100% and clicking "Ok" will not keep the value to 100% after reboot, but it will turn to 37%.
  3. emanuelsj

    emanuelsj New Member

    I have also disabled sound effects, but still no joy.
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Are you using headphone jack?
  5. emanuelsj

    emanuelsj New Member

    Hello there! Yes, I have connected the external speakers using the jack connector.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It's some kind of "ear protection" thing introuduced by Microsoft...
  7. emanuelsj

    emanuelsj New Member

    I will be able to test audio through HDMI in two days. Regarding the ear protection feature, I doubt about it, since there is usually a warning first, which allows users to bypass (or not) the safe level, which is usually set to 80%, not to a rather random value such as 37%. And also, I have other Win 10 devices, which doesn't have a similar behaviour, therefore I would say this looks like a bug.
  8. Villa

    Villa Well-Known Member Super Moderator

    37% is definately what it gets set to if you select "Don't allow" !

    http://bfy.tw/CYHg

    I didn't read much, but the consensus is to roll back the audio driver.
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    37% is defined by the Realtek audio driver, not us...
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  11. BadProduct

    BadProduct New Member

    NO USE...the trick posted by Ken does nothing for my MINIX and would disable some Windows functionalities.
    This is one of very annoying things for this product, however, we've paid for it so try to be with it.

    I use nircmd.exe to automatically adjust volume to 100% and then select the "Allow" option on the popup dialogue, for me.

    1. Download nircmd.exe (just use Google to find it...get the 64-bit version)

    2. Unzip to where you like, such as, c:\nircmd folder.

    3. Create a batch file (*.bat) using Notepad and place the following command.

    c:\***folder containing nircmd.exe**\nircmd.exe changesysvolume 65535
    timeout /t 2 /nobreak
    c:\***folder containing nircmd.exe**\nircmd.exe sendkeypress left enter

    Then save it where you like. I recommend to save them in c drive to ensure that Windows always see them.

    4. Add this batch file to "Task Scheduler" and set it to run every time you start Windows.

    5. At Windows startup, you will see a black command window on screen for about 5 seconds, the volume dialogue will be automatically closed, and your volume is set to 100%.

    Note: The value 65535 means 100% volume level, 0 is 'mute'. If you need other volume level than 100%, you may try other number in between 0 and 65535. Also this trick makes the volume reset every time you re-boot, in other words, the user adjusted volume is never saved.

    This is quite techy but I have no other better choice.
    Last edited: Jul 2, 2017
  12. Villa

    Villa Well-Known Member Super Moderator

    But this is a Windows 10 feature! Nothing to do with the product, unless by product you are referring to Windows 10 and not the MINIX device? o_O
  13. BadProduct

    BadProduct New Member

    We have got much many of Windows 10 devices here, only MINIX needs this stupid trick ! Ha ha ha.
  14. emanuelsj

    emanuelsj New Member

    It still looks like a bug to me. Windows is not warning me about any safe level for the ears. The default Windows mixer level remains at 37%, no matter what. I rolled back audio driver, then I installed the latest Realtek version from http://www.realtek.com.tw/downloads...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false which I found it into another thread of this forum. In "Communications" I have selected "Do nothing" already. Whenever I restart the device, the volume goes back to 37%. Any other suggestion besides the batch file? Maybe a Windows registry to modify?
  15. BadProduct

    BadProduct New Member

    Good news & Bad news !

    I've just CLEAN reinstalled Windows using USB installation because the start button didn't work after updated Windows, tried every trick from internet but no luck.

    I noticed that the very first few restarts Windows did not reset the volume level back to 37%, and all sounds work normally, VOILA. But after doing driver updates using the drivers provided from this forum, the same 37% volume resetting come back, T.T

    MINIX may take this clue into investigation of what sound driver is best for this device.
    Last edited: Jul 22, 2017
  16. emanuelsj

    emanuelsj New Member

    Your findings are important, because at least we have now a strong confirmation on where the problem lies. My device works flawlessly and it would be sad not to have such minor but buggy problem solved. Looking further for a fix, MINIX! :)
  17. emanuelsj

    emanuelsj New Member

    BadProduct, since you reinstalled Windows 10, could you let me know if I must provide a new serial number if I would do that or if the SN is already contained into the device's bios? Thanks!
  18. BadProduct

    BadProduct New Member

    The product ID is recognized automatically. Be aware of doing this, your installed apps/settings/data on the Windows drive will be lost. And I can't guarantee that you would get the same result as mine.
  19. emanuelsj

    emanuelsj New Member

    Thanks for the confirmation, BadProduct! I'm enough IT savy in order to reinstall the OS without loosing data. Also, I have created a C: drive image with the default Windows state, therefore in case anything might go wrong, I will always have a B plan. Have a good weekend ahead - and let's see how fast will MINIX be with the audio fix! :)
  20. emanuelsj

    emanuelsj New Member

    Any news on this audio driver matter?