1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Default Windows audio level 37%, how to change it?

Discussion in 'NEO Z83-4' started by emanuelsj, Jun 21, 2017.

  1. emanuelsj

    emanuelsj New Member

    Still hoping for an audio drive update here.
     
  2. emanuelsj

    emanuelsj New Member

    Guys, is there a chance to get this audio driver fix any soon?
     
  3. The DA

    The DA New Member

    We've purchased 20x Minix NEO Z83-4's for commercial use in a public space. Our interactions depend on sound to guide children and instruct them on what to do with these interactions. We weren't expecting this show-stopping audio issue, as others have said, it's the first and only time I've ever encountered this issue on Windows 10. Our systems require restarting daily, which also mean tediously remoting in and manually adjusting these sliders daily for the next 2-3 years, the life of this activation.

    Who do we need to prod to get this resolved?
     
  4. carlosd

    carlosd New Member



    Did You ever get a fix for this?
     
  5. emanuelsj

    emanuelsj New Member

    Well, I'm still waiting for a fix too!
     
  6. carlosd

    carlosd New Member

    Maybe if someone with a little more know-how helps me out we can probably get this resolved.

    I went and did some research and found out that this is something related to the EU. Apparently, it IS a feature of some sort built into the driver to protect you from blasting your headphones by accident.

    I've found this out from opening up the driver installation file provided in the Minix driver package (sorry I cant post links yet... but I found it here on this forum).
    in that archive:
    Z83-4_device_drivers\Audio\AudioRealtek\isstrtc\isstrtc.inf

    I opened it up with note ++ and found a section that actually lets you set this feature. lines 105-109 under [IntelSSTAudio.AddReg]

    Code:
    ;; For EU set GenerateVolLimitUI = 1 (else unset) and TimerVolLimitUI=cumulative listening time
    ;; example EU recommended 20hrs value is 0x11940 seconds
    ;; IMPORTANT - to enable EU warning set GenerateVolLimitUI
    HKR,AudioVolBoost,GenerateVolLimitUI,0x00010001,1
    HKR,AudioVolBoost,TimerVolLimitUI,0x00010001,0x11940 

    I thought why not change it and install it?
    if someone with more knowledge can take over will this take us somewhere?

    once the driver has been modified it will no longer pass the signature checks and will tell you its been tampered with.
    so you have to disable driver signature verification
    google:
    How to: Disable driver signature enforcement on Windows 10

    but again this is all I know and I may be missing something because I tried and I didn't get it fixed...
    maybe this is something that a registry edit can fix?
     

    Attached Files:

  7. carlosd

    carlosd New Member

    the European Committee for Electrotechnical Standardisation (CENELEC) amended its safety standard for personal music players.

    Now all personal music players sold in the EU after February 2013 are expected to have a default sound limit of 85dB.

    The user can choose to override the limit so that the sound level can be increased up to maximum 100dB. If the user overrides the limit, warnings about the risks must be repeated every 20 hours of listening time.
    this looks just like what that driver is setting.
     
  8. emanuelsj

    emanuelsj New Member

    No, it's not. I have checked the sound level at 37% and is way lower than 85dB. I would be curious from other Z83-4 owners if their default volume is always at 37%, no matter how previous settings were modified.

    Hey, Minix Support are you already working to have this issue solved?