1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

X7 mini Device failing to boot after pressing recovery button [solved]

Discussion in 'NEO X7 mini' started by Rockchipper, Oct 11, 2016.

  1. Rockchipper

    Rockchipper New Member

    Hi, I've got an X7 Mini that I was hoping to flash, I followed the steps in the guide in order - hold down recovery button on the back, plug in 5v power, plug in USB OTG via the Male-Male USB provided. I can't get the device to a point where the Rockchip BatchTool even notices the device, let alone flash it.

    Neither Mac OS, nor Windows (both native install and VirtualBox image) notice the box. Nothing is recorded in Device Manager, with or without the drivers. I'm trying to just get it back to the default mode but I can't receive any feedback from the device. The blue LED does not turn on, and no HDMI signal is detected by the display.

    How can I knock the box back into standard Android mode?
  2. Rockchipper

    Rockchipper New Member

    Back again, managed to get the box back booting and running it's app.

    Not a clue what caused it to switch out, tried multiple permutations of (power off | plug in | power on) and somehow got it back.

    If you're in the same situation, just turn the box off for a while then plug it back in. Maybe the CMOS capacitor drains out, clearing debug boot flags?
    I dunno, don't really care that much.
    Villa likes this.