1. Official MINIX forum

Digital noise on HDMI with "5.1 files"

Discussion in 'NEO X8-H Plus' started by grgart, Sep 8, 2015.

  1. grgart

    grgart New Member

    Hello,

    I got Minix X8-H Plus connected to:
    TV (Panasonic TX-P42G10E) via HDMI
    DTS/dolbydigital receiver (Yamaha RX-V520RDS) via SPDIF

    Audio at Minix and Kodi are set as in attached pics, and this way i have audio on whatever of two devices is turned on.

    minix.jpg kodi.jpg

    All is fine, got audio on tv and receiver, but only when AAC5.1 movies (posibly all 5.1 files) are played with
    Kodi, i got digital noise on TV (HDMI), SPDIF is fine, i got ok dts/ac3 detection/processing on receiver.
    So I have to disable passthrough in Kodi to avoid this issue with 5.1 files on TV.

    Any sugestion how to solve this issue, to avoid manually enabling passthrough when playing 5.1 movies?

    Thanx

    G
    Last edited: Sep 8, 2015
    duffer likes this.
  2. Frederick_99

    Frederick_99 Well-Known Member

    try turning off simultaneous HDMI/Analogue audio output. you dont need it on
  3. grgart

    grgart New Member

    Did that but HDMI noise problem is still there.
  4. Frederick_99

    Frederick_99 Well-Known Member

    what happens if you mute the TV volume when using 5-1 passthough, do you get 5.1 through your amp ?
  5. grgart

    grgart New Member

    I got the 5.1 passthrough to amp (SPDIF) ok all the time.
    Its just tv (HDMI) get "confused" when AC3 file is playing.
    I could mute TV when AC3 files are played, but rest of the family does not care about amp and just use tv, and get confused when for some reason digital audio noise is emitted instead proper sound :)
    For now the only solution is to have passthrough in Kodi disabled, and if I really want to amp autamaticly recobnise AC3 stream, i turn it on manually.
  6. WeK05

    WeK05 Audio Visual Master Specialist

    Your TV seems to support Dolby Digital/DTS audio only from its internal tuner. It doesn't support it on external input. This is why you are getting noise from multichannel audio. Unfortunately, there is no option to have PCM and Passthrough at the same time.

    I haven't checked this: Can you check what happens when you turn on digital audio detection and leave all other settings as is. This may work only when you have the TV on and the AVR off.
  7. chriswaterman

    chriswaterman Member

    Hi grgart. Have you tried it in the arc HDMI port
  8. WeK05

    WeK05 Audio Visual Master Specialist

    His TV doesn't support HDMI ARC. It has only HDMI 1.3a ports.
  9. grgart

    grgart New Member

    Yes, 2009 plasma I guess is to blame, but it would be nice to have minix setup option to send PCM to hdmi and passthrough to SPDIF :)
    I thought that it can be done setting Digital audio output to "SPDIF passthrough" instead "HDMI & SPDIF passthrough" but then i just get audio on SPDIF.
    Last edited: Sep 9, 2015
  10. Jaffa

    Jaffa New Member

    I agree with you, option to send PCM to hdmi and passthrough to SPDIF. Because I have the same problem on my tv (plasma LG50PK950). Passthrough is enable on Minix + Kodi and i can hear only noise on TV via hdmi. Receiver via SPDIF is OK. When i disable passthrough in Kodi then its OK on TV. Problem is only in Kodi. When i use MX Player or 4K player everything is alright. Tv and Receiver.
  11. mihvel

    mihvel New Member

    I can confirm the issue, I had exactly the same problem.

    I do not know how complicated is to implement in the Minix Android FW an option to separately define audio formats per output, so that we can choose e.g. "SPDIF: PCM/ Passthrough/ Disabled", "HDMI: PCM/ Passthrough/ Disabled"? That would be the solution for all issues with the digital audio which is so often reported on Minix forums.
    Last edited: Feb 5, 2016
  12. sansiro2

    sansiro2 Member

    Did anyone ever resolve this? Getting worried as found this issue on 4 different Android boxes and have ordered an X8-H plus as I was assured this was solved by this unit.
  13. ilGimmy

    ilGimmy Member

    I have the same TV.
    My "workaround" is to leave pass through disabled in Kodi.
    When I want to use the ampli, I mute TV and enable pass through in the audio menu, while playing...

    Inviato dal mio A0001 utilizzando Tapatalk
  14. sansiro2

    sansiro2 Member

    Thanks, not exactly a solution but can live with it. I think it's actually a limitation of Android boxes and my set up.

    Sent from my HTC One M9 using Tapatalk
    duffer likes this.
  15. Jaffa

    Jaffa New Member

    Any new suggestion how to solve this issue?
  16. CRD

    CRD New Member

    I would also love to see a solution to this annoying problem!!

    Thank you:)
  17. ilGimmy

    ilGimmy Member

    I read that is an issue related to how bitstreaming was implemented in old Android Kodi.
    Kodi tells the system it's sending PCM, while instead it sends AC3/DTS.
    That's the reason of the volume bug (pressing volume key on remote give noise, because Android thinks it's a PCM and change the data to reduce volume) and that's the reason a TV not compatible to AC3/DTS receives an invalid stream (Android thinks it's PCM so the TV supports it).