1. Welcome to the official forum for MINIX devices!

Downgrade from FW009 to FW007A

Discussion in 'Official Firmware Releases' started by senzalice, Apr 3, 2016.

  1. senzalice

    senzalice Member

  2. Villa

    Villa Well-Known Member Super Moderator

  3. senzalice

    senzalice Member

    Understood ! Thanks Villa. (y)
  4. senzalice

    senzalice Member

    I want to downgrade from FW009 to FW007A.
    I've installed USB_Burning_Tool_v2.0.4.3 on my desktop PC win 7, connected Minix box with supplied OTG cable to PC.
    I used pin to push in Recover button while holding power button, then connect the power.
    Nothing happens...how long do I hold recover button & power button? (i've done it up to a minute)
    I have also tried different USB ports.
    I then tried doing the same thing on a laptop computer.
    Nothing seems to happen.
    I must be doing something wrong !!!!
  5. senzalice

    senzalice Member

    I followed the instructions here to flash the FW007A image... http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
    I tried many times but could not get "connection success"
    Eventually I succeeded by changing some steps in the guide as follows...
    ....

    3.) Install the Windows USB flash tool, downloading from:
    http://minix.com.hk/downfile/USB_Burning_Tool_v2.0.4.3_user.rar
    Choose "Install anyway" when system prompts for driver installation,
    4.) Connect the Micro USB cable supplied with the box between the OTG port of the box and your computer (Windows based);
    4a) Insert pin and push and hold the "Recover" button located at the back of the hub first;
    4b) then open the application, and choose English (picture 1 & 2);
    5.) Power up the device
    by pressing the power button 3 secs
    6.) Upon successful connection the "Connect success" message will be displayed inside the application (picture 3);
    ....
    The rest was straight forward and had my system running again with FW007A.

    However, the AVI problem is still there.
    The AVI starts for 15 secs and then freezes, knocking out my wifi...and I have to reset my modem.
    This happens both with XBMC Minix and KODI....but not when the file is played from a USB stick.
    As reported in another thread, it happened after I upgraded to FW009.
    Flashing back to FW007A has not fixed it.
    Has my X8H-Plus Minix box been permanently damaged ???
  6. senzalice

    senzalice Member

    Is anyone else having problems playing AVI files with KODI over WiFi with X8-H Plus ?
    If you're playing AVI files ok, what version Firmware and what version KODI are you using ?
    Thanks for sharing any information. (I can't believe i'm the only one with this problem !!)
    Why is there no further news on FW009, even though the update was available through OTA?
    swamprat96 likes this.
  7. George Georgiou

    George Georgiou New Member

    I personally haven't hit problems with fw009. Only have my box for Kodi. What are you trying to watch so I can try on mine? Things I watch are mainly MKV and MP4. I also use wifi for kodi as I'm too lazy to make up an ethernet cable to my router and run it through the walls and conduit.

    Sent from my GT-I9301I using Tapatalk
  8. swamprat96

    swamprat96 Active Member

    Just checked a bunch of Avis working fine on 008a -xmbc for minix 15.3.
  9. senzalice

    senzalice Member

    I just want to play AVI files over WiFi on my home network.

    But I may have solved what has been giving me problems.
    In another post, http://minixforum.com/threads/newnew-firmware-update.12029/#post-94319, I mentioned that when playing AVI over wifi I would lose the connection and had to reset my modem/router.
    This happened on both 2.4GHz & 5GHz bands....and on ALL the KODI versions, 14.2, 15.2, 16.0 & 16.1.
    I forgot to mention that this is a new dual band modem/router, TP-Link Archer D7.
    I later installed the latest version of XBMC Minix 15.3 and AVI play fine on both 2.4GHz & 5GHz bands.
    Out of frustration, I dug out my old Linksys modem/router (only 2.4GHz) and AVI's played fine on KODI...but with buffering.
    That was my main reason for buying the TP-Link with 5GHz as it was suppose to eliminate buffering.

    So...it appears that all the versions of KODI I tried and the TP-Link Archer D7 have some sort of conflict with AVI video.
    Not sure what I can do about it...probably nothing.
    Meanwhile, I'll think about going back to FW009 and XBMC Minix ver 15.3 as it probably should be OK for AVI's.
  10. swamprat96

    swamprat96 Active Member

    Why not try Ethernet over power? I use this successfully here as wiring Ethernet was not possible for me.
    Otherwise you could try using a dlna server on your video source which might lower the bandwidth needed.
    But- you should be able to stream over Wi-Fi. I checked and can stream a 1GB avi without issues. I did in both 2.4 and 5ghz. Bigger Avis may be an issue.
  11. senzalice

    senzalice Member

    Thanks swamprat96, but no need try Ethernet over power.
    As I said in the above post, I tried XBMC for Minix 15.3 and AVI's work just fine in 2.4 and 5 GHz.
    Its only when I used KODI that I had problems...so I won't bother trying KODI with Ethernet over Power.
    But out of curiosity, I may try KODI using Ethernet connection as I have a spare Cat5 cable.
  12. sangaz

    sangaz Member

  13. swamprat96

    swamprat96 Active Member

    yes- he's having trouble with AVI's on 009. I'm waiting for the official firmware thread and some input from Ken before I make a call
  14. Menorca Man

    Menorca Man Active Member Trusted Helper

    Correction. He was having trouble playing avi's over the 5Ghz wifi band. Seems his new TP-Link Archer D7 router and Kodi (all versions) didn't play nicely together for some reason but everything worked well once he ditched Kodi and changed over to XBMC for Minix v15.3.
    Higgs likes this.
  15. senzalice

    senzalice Member

    Well, it's a bit of a coincident that I purchased a new TP-LINK Archer D7 modem/router a few days before doing the upgrade to FW009.
    Then when I played AVI files over wi-fi using KODI 16.1, the AVI file froze after 15 secs and I would lose the wi-fi connection.
    It made no difference if using 2.4 or 5 GHz...and made no difference which version of Kodi I used.
    Naturally I thought it was all due to FW009 that I had just upgraded. (what else was I suppose to have thought?)

    I tried a different modem/router (Linksys) as mentioned previously ...and just a while ago I tried a Netcomm modem/router ...and can tell you AVI files play fine over wi-fi using any version of Kodi.
    I have now been able to connect a different media TV box with my TP-LINK Archer D7...and guess what?....AVI files over wi-fi do not work !!!
    This at last proves there's incompactability between my TP-LINK and KODI.
    I don't think it has anything to do with FW009.

    For now I will use XBMC for Minix 15.3 instead of Kodi, as it seems to play all files that i've tried...AVI, MPG, TS, MTS, MP4, MKV.
    I just hope my TP-LINK will come good with the next firmware upgrade...which I believe could be out soon.
    swamprat96 and Menorca Man like this.