1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Tutorial Enabling passthrough on X8 & X6 series

Discussion in 'X8-H Plus Guides & FAQs' started by MINIX - Ken, May 2, 2015.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all,

    We've noticed some of you are having questions enabling passthrough.
    Here is a simple, step-by-step guide.

    1.) Enabling passthrough inside the system
    - Go to the basic setting folder on the MINIX launcher screen, or open the "SettingsMbox" app directly;
    - Move to the 3rd category - Advanced;
    - Make sure the "Digital audio auto-detection" option is "OFF";
    - Scroll down to the last option - Digital Audio Output, click into it;
    - Choose the passthrough option you need - either SPDIF passthrough (not applicable for X6), or HDMI passthrough, or both (not applicable for X6);
    1.jpg
    2.jpg
    After step 1, you may proceed to step 2 if you want passthrough from XBMC/Kodi;

    2.) Enabling passthrough inside XBMC/Kodi
    - Go to SYSTEM -> Settings, click to go inside;
    - Scroll all the way down to the last option - System, click to go inside;
    - Scroll all the way down to the last option again - Settings level, click 3 times to "Expert" level;
    - Scroll up to the Audio output option, move right, select "Enable passthrough" + "Enable Dolby Digital transcoding", total of 5 blue dots will be checked;
    - Enjoy;
    3.jpg
    4.jpg
    5.jpg
    Last but not least, if you are NOT connecting the box's HDMI to the external decoder directly, or if you're connecting using the SPDIF OUT port from the TV, then first of all you must check whether your TV could handle these multi-channel streams, we can't help you if the TV doesn't support that:

    http://www.cnet.com/news/20-tvs-tested-which-sets-can-pass-surround-sound-to-a-sound-bar/
    http://www.avsforum.com/forum/166-l...s/1389050-tvs-5-1-passthrough-hdmi-spdif.html
    https://forums.plex.tv/index.php/topic/30034-the-lg-smart-tv-dts-tragedy-thread/


    Regards,
    Team MINIX.
    DavideG, Pablo7, Rawhide85 and 2 others like this.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Some possible setup combinations for reference:
    passthrough_combinations.png
    Free WIng and von like this.
  3. Madnix

    Madnix New Member

    I am getting no sound out of my Minix X8-h Plus over HDMI to a Pioneer reciever. Any thoughts?
    MarkZeds and Rawhide85 like this.
  4. Rawhide85

    Rawhide85 Member

    Great tutorial. Worked perfect. +1

    Sent from my SM-N900A using Tapatalk
    MINIX - Ken likes this.
  5. von

    von Member

    This image cleared up my issue. Was initially having no sound with passthrough enabled, however it was the HDMI-ARC connection that was messing up the sound. Disabling that on both the TV and HT fixed it.
    MINIX - Ken and Rawhide85 like this.
  6. cesarus

    cesarus New Member

    I have same problem with yamaha 7.1 reciver DPS-1092, and HD ready Samsung TV. No DD5.1 sound on TV and reciver. Reciver can produce DTS. 4K player work with DD5.1 and AAC but xbmc minix, kodi evan try spmc nothing work. I try all combinations but nothing work.
  7. Higgs

    Higgs Yellow Dude Super Moderator

    Post screenshots of your xbmc sound settings. They should match those in the first post.
  8. cesarus

    cesarus New Member

    I can post screenshots is my friend setup. But is same like first post. I tried every combination. When I uncheck Dolby Digital transcoding stereo sound work. On my yamaha HTR 3... everything work. I even tried my box on his reciver and tv same thing no dd 5.1.
  9. Marcelo90

    Marcelo90 New Member

    I have the same config and no 5.1 in Kodi / XMBC. In 4K player 5.1 works.
  10. Higgs

    Higgs Yellow Dude Super Moderator

    Please post screenshots of your settings. A number of users have thought they had the correct settings but then discovered they have overlooked something (e.g. No of channels = 2.0)
  11. Marcelo90

    Marcelo90 New Member

    I will try to explain my best, sorry for my english.

    [​IMG] [​IMG] [​IMG]

    That is my config. With that, i have sound in 4K player or MX for example. But, in XBMC/Kodi, i have NO sound at all.
    Im using a Creative 5500 that only support Dolby Digital, no DTS. Its old, so no HDMI, only optical audio.
  12. Higgs

    Higgs Yellow Dude Super Moderator

    Have you tried unchecking DTS capable receiver, since you say your receiver doesn't support that?
  13. Marcelo90

    Marcelo90 New Member

    Yes, and still getting no sound. If i only leave ON Enable passthrough + DD AC3 capable receiver, i get 2.0 sound. Never 5.1
    In 4k Player and MX player i get always 5.1 sound and i havent config anything in these.

    EDIT: My config is Minix to TV with HDMI and Minix to Creative with optical cable.
    Last edited: Oct 19, 2015
  14. Frederick_99

    Frederick_99 Well-Known Member

    as your settings but
    in minix settings set No output to USB audio to ON
    in Kodi settings disable DTS capable receiver

    and post a screenshot of the audio information from something like mediainfo to confirm the video does indeed contain a 5.1 soundtrack

    https://mediaarea.net/en/MediaInfo
  15. Marcelo90

    Marcelo90 New Member

  16. cesarus

    cesarus New Member

    If your tv have optical try trough him. But it will work only if tv suport dolby digital. Uncheking dts capable reciver not work. I think the problem is beacouse reciver(in your case Creative) cant produce compresed dolby digital signal only pure dd.
  17. Frederick_99

    Frederick_99 Well-Known Member

  18. Marcelo90

    Marcelo90 New Member

    Ok i will try your setting, tell you later.
  19. Marcelo90

    Marcelo90 New Member

    Nothing, i tried ALL possible combinations. Only get 2.0 audio (both AC3 and DTS) in Kodi.
    In 4K player. ALWAYS 5.1 of AC3 sources, zero audio if it is DTS.
  20. Frederick_99

    Frederick_99 Well-Known Member

    confirm your firmware version and kodi version and that you have not installed a customised "build"

    i would propose that you do a clean usb flash tool install of your firmware and install latest kodi 15.2 and nothing more before you try again ( this will of course wipe your system clean)