1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Even simpler way to install Windows 10 Creator Update

Discussion in 'NEO Z83-4' started by Jaap van der Velde, Mar 5, 2018.

  1. Jaap van der Velde

    Jaap van der Velde New Member

    Sorry for top-posting this, but I think it's an important issue and people shouldn't mess with their device in ways that aren't required.

    If you've been getting the 0xc1900200 error after an update, some people have already posted that enlarging the system reserved partition is a solution that works (as long as you have enough free space on the C: drive as well).

    However, there is a simpler way to achieve just enough free space, while avoiding tools like PartitionMagic.

    Microsoft provides a good description of the solution here:
    https://support.microsoft.com/en-gb...m-reserved-partition-error-installing-windows

    For me (with a GPT type drive, which I would assume everyone with the Z83-4 has), it came down to just emptying the folder EFI\Microsoft\Boot\Fonts on that volume. It frees up about 15 Mb and that's enough for the update to go through. Please follow their instructions, it only takes a minute and requires no special tools.

    Hope this helps, it took me quite some time to solve this very annoying problem.

    -----

    As an additional tip: if you are having trouble getting enough free space on the C: drive for something like the Windows 10 upgrade, where you only need *temporary* space, you can do the following for some folders, like Windows10Upgrade:
    - insert a storage device on USB and move the folder you want to temporarily relocate (you'll be asked to provide admin rights in some cases - don't move essential system files like this!)
    - open a command prompt as admin (open start menu, type 'cmd', rightclick the command prompt icon and select 'Run as administrator')
    - then go to where the folder you moved was, for example 'cd \' to go to the root of C:\ if you moved Windows10Upgrade. And enter 'mklink /J Windows10Upgrade D:\Windows10Upgrade' (assuming your USB device shows up as 'D:').

    Once the upgrade is done and you've cleaned up any remaining temporary files, you can either just remove the link and delete the files, or if you moved files you still need, you can just delete the link and move the folder back to where it was before.
     
    Last edited: Mar 12, 2018
    Buntashin and kav2001 like this.
  2. Villa

    Villa Administrator Administrator

  3. Jurgibl

    Jurgibl New Member

    Thanks for the information. I can't find the way to do so.

    I can't remove the contento of EFI\Microsoft\Boot\Font. I tried to do so with EaseUs Partition Master and Mini Tool Partition Wizard. I can see the content but can't remove.

    Could you explain, how did you do so?

    Thanks


     
  4. Jaap van der Velde

    Jaap van der Velde New Member

    Sure, did you follow the instructions on the web page Villa linked?

    In my own words:
    - Open the Disk Manager (easy way, hit Win+R and in the Run window, enter 'diskmgmt.msc')
    - First check the type of the disk the system volume is on. Right-click the disk in the disk manager, select 'Properties' and check the 'Partition Style', which should be either GPT or MBR.

    Assuming that it's 'GPT', as it was in my case, you should start a command prompt with admin rights:
    - Open start menu and type 'cmd', right-click the Command Prompt icon and select 'Run as Administrator'
    - Enter 'mountvol y: /s' and hit enter, you should now be able to change drive to Y:
    - On the Y: drive you now have, empty that folder by entering 'del Y:\EFI\Microsoft\Boot\Fonts\*.*'

    If that doesn't work, please post at what point you're having a problem with this procedure.
     
    Last edited: Mar 10, 2018
  5. SAGB

    SAGB Member

    Microsoft tech support did all of that when I contacted their tech support and spent 3 hours trying to get it to install... Nothing worked. I had to wipe it all out and start over. Doesn't work for everyone. And then the next major update wouldn't work either... it kept installing to 18% then restarting the computer then uninstalling the update then re-downloading it and going into a continuous loop of trying to update again. Again Microsoft spent hours trying to get it to work and again I had to wipe everything out and start over. The 32GB drive is just not adequate. It should have been at least 64GB. Hardware manufacturers and some software manufacturers are not letting software install to drives other than C: and some of these printer/scanner drivers and software are ridiculously large. Microsoft also won't allow Microsoft Office to install to anywhere other than C: (Microsoft Tech support does not support any of the so-called work arounds and says they will cause problems). As much as I like this little computer, it seriously needs a larger main drive.
     
    Last edited: Mar 12, 2018
  6. Jaap van der Velde

    Jaap van der Velde New Member

    I don't disagree with your comment that it is in need of a larger C: drive.

    However, I closely watched disk space during the install and it never exceeded the amount it said it needed, in fact it stayed well under it. Note that the solution I posted has nothing to do with free space on C:, it has to do with the system reserved partition, which is a small extra partition that's particularly crammed on the Minix (something that could also be fixed if they put a bigger C: drive in there).

    I'm not saying tech support didn't try their best, but are you 100% sure they actually tried this procedure? Did you try the same thing?
     
  7. SAGB

    SAGB Member

    They mounted the drive, deleted stuff from it, they deleted the backups of Windows from previous updates, they deleted previous update files. They still could not get it to update (That's when they gave me the command for retrieving the Windows license code and told me make a USB install and wipe the system out). The second time the partition sizes were more than adequate, and still it wouldn't update properly. It wouldn't give them an actual error code, and just kept looping the install (which was probably a Windows update problem and not a space issue). They ran repairs on the update system, disabled processes from starting at bootup. They had to disable the update function until I could get time to back up my stuff and run a system restore. Then I spent two whole days re-installing stuff and making sure all the drivers were working. They also gave me an update for the video drivers (Apparently the same as one of the Intel Compute sticks). Then after I got everything all setup, I found out that Microsoft's system image backup doesn't allow SD cards to be backed up. So it will backup the main drive and an external HDD but not the D: drive. And if all your programs are on D:, it makes the system image pretty useless. You can't just copy the D: drive either, because they now encrypt the Apps folder. So if you have the Apps installed on D: good luck. I used Nero to back D: up to my network drive, but I don't know how it will work if I need to restore it.

    The only programs I have installed on C: right now are MS Office, and the drivers and software for my printers (Epson's stuff is huge, HP's was minimal) and my drive is nearly full. I installed all my other software to D:, but I could see during the installs that they were also still putting stuff on C:. Corel's PaintShop Pro installs a bunch of additional software without asking what drive. I will have to un-install them and MS Office for the next update. I only have 5.7GB left on C. And that is after a disk clean up.

    I've since installed an old version of WordPerfect to my D: drive to make sure it works, because at least I know it will go where I tell it.
     
    Last edited: Mar 12, 2018
  8. Jaap van der Velde

    Jaap van der Velde New Member

    Thanks for going into a bit more detail, at least they did try, from the sound of it.

    However, respectfully, it sounds to me like they didn't do the one thing that they should have. It's important to realise that the system reserved partition is a part of the system that's not normally accessible to the user (like most of the things you mentioned were tried). All of those address the lack of space on the system drive (which is what Windows reports as the problem, so that makes sense), but Windows *misreports* the problem and the actual problem is not with the system drive. So far, I've gotten it to work on three separate occasions (my own, my dad's and a friend that heard I had a working solution).

    Also, please note, I'm only talking about failing installations that end in an '0xc1900200' error - perhaps your problem wasn't exactly that...

    Anyway, of course by now there's no way to tell if fixing that specific problem would have solved your situation - it's a pain to have to reinstall, but hopefully that resolved the issue for you?
     
  9. SAGB

    SAGB Member

    As I said, they mounted the reserved partition and deleted stuff, but he then also told me the partition wasn't big enough. He even tried enlarging it himself and it wouldn't work, which was about the time he asked me to wipe everything and start over (even with the deletes). So the reserved partition on mine when I first got it was way too small.

    So far everything has been working now except that I was getting the occasional disappearing micro SD card slot. But I think the BIOS update has resolved that. I will have to see how things go.
     
  10. Jaap van der Velde

    Jaap van der Velde New Member

    Oh ok, I see. Well, in that case, it's good to know for people that their mileage may vary. Hopefully others have a more successful experience with it. Did you get the '0xc1900200' error when Windows did try to install?

    You mentioned it only got to 18% and then it restarted. The behaviour for me was that it would get almost all the way, but then still fail with that error.
     
  11. SAGB

    SAGB Member

    The second time I had to re-install, it wouldn't display an error code... It would go to 18% then restart, then 18% then say the installation had failed and that Windows was undoing the changes (with no error code). Then it restarted and started downloading the same update again and would do the same thing again. I think that puzzled the Microsoft techs. They took screen shots of my partition sizes and what I had installed. Then they disabled all processes starting at boot up that were not necessary. I think they felt that something was locking out access to a file that needed updating. I'm suspecting the Windows Update install did it while I was working on a video on my external SSD. I was using Nero, and it took almost 24hrs to convert the video I was working on. It got to 98% complete when Windows update shut the program down and re-booted the machine (so frustrating). So, maybe something in Nero locked access to a file and because Windows Update forced it closed it didn't unlock it. Just my guess. Windows Update shouldn't be forcing programs to shut down like that when they are in use. So perhaps make sure all your programs are closed before you allow an update to commence because you might lose permissions to access certain files. Problem is, I didn't even know it was updating till I came back half a minute later after I saw the 98% on my video conversion and found the program had closed and a message saying that windows was going to shut down to run an update.
     
  12. Jurgibl

    Jurgibl New Member

    Thanks, it works!


     
  13. Daraku

    Daraku New Member

    Thanks a lot, this method worked like a charm, now I got the 1709 updated and working.
    OFC now the new 1803 fails to install...I wanna cry, may I cry?
     
  14. Wonko

    Wonko New Member

    I successfully installed 1709 by freeing up enough space, then came 1803.

    It refused, despite being given 10.7GB free space. No update fixers or anything else worked.

    Downloading the current win10 image (from MS) to usb and attempting an upgrade install also failed.

    So no other option but a fresh install, so download drivers, reinstall OS and then drivers, fix modem driver etc.

    Which not only worked but the system is significantly more responsive, after drivers and the same software I had on before were installed.

    So...save yourselves some time, backup anything that needs to be, do a fresh install, and end up with a much more responsive z83. Apart from multitasking issues, caused by having significantly less memory, it's nearly as responsive as my N42C-(12) - which did make me wonder precisely why I went to the effort and expense of fitting a m.2 and another 8GB to it.
     
    Villa and skynet like this.
  15. skynet

    skynet Moderator Moderator

    I agree ! (y)
     
  16. sland

    sland New Member

    so why doesnt something get done about this. Why do we have to jump though hoops to keep things working?