1. Welcome to the official forum for MINIX devices!

Everyone who had problems with updating.

Discussion in 'X8 - X8H Official Firmware 002' started by Roylegr, Dec 8, 2014.

  1. Roylegr

    Roylegr New Member

    I see that many of us had problems with updating and get stuck in the recovery mode.
    They have the 2 files in the root of the usb stick.

    I had this issue too.!!

    My solution was actually very easy.
    The usb stick i used was formatted in FAT32 but...... it says sdb5
    that's not good, the 5 will means 5 pads or something and the b is also not good.
    you MUST have sda1. Then it works flawless.

    I formatted the usb stick with mini tool partition wizard and was set it to primery instead of logical.
    But that was my solution, get the sda1 when you press select.
    GaryD and WolfP like this.
  2. Roylegr

    Roylegr New Member

    And also after the update i could not reach my NAS with smb in XBMC, this is a known issue.
    My solution was uninstall xbmc and install version 13.3.3 beta 3 and after that i tried version 13.3.3 beta 6 over the beta 3.
    and also it works flawless.

    Edit..... now i'm on beta 3 because i updated to beta 6 (1dec) and much problems with stuttering. so back to the problemless beta 3.

    So after what problems and searching the forum.....

    Good job, Welldone and thanks to everyone who worked on the 002 and spent his time for it.(y)
    Last edited: Dec 12, 2014
  3. Zlatko

    Zlatko New Member

    Thanks. I had the same problem and with your tutorial I success upgrade my minix. Thanks.
  4. ksylon

    ksylon New Member

    Hi, I have a problem. I followed the guide but the firmware update won't install giving me this error (in the picture). I'm obviously trying to update a MINIX x8-h.[​IMG]
  5. Roylegr

    Roylegr New Member

    Weird screen never seen that and (i thought) the x8 and the x8-h had the same firmware.
    You updating throug ota?? Or usb.? Or pc.? And the device is a x8-h?
    Best update via usb on the device self
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Have you installed a custom firmware on a custom recovery.
    You may need to either uninstall the custom recovery or reinstall official firmware using the usbburning tool.

    Sent using Tapatalk
  7. ksylon

    ksylon New Member

    I have installed only a new recovery (TWRP). I solved it installing the stock ROM 2.0A in zip format from the recovery.

    Thanks
  8. hrishig

    hrishig New Member

    I am able to get the usb to sda but not the sda1. After selecting the upgrade screen , the system restarts but it gvives me option to

    1) reboot the system
    2) upgrade from XXX
    3) upgrade from ext
    .....

    now none of the options work.
    /
    How to format usb to sda1 insted of sda? and what should be selected during 3-4 options which are given?
  9. ArceeKay

    ArceeKay Active Member

    Got the same problem here and finally fixed it. My Minix is updating from USB now!

    While updating, here's what I did:
    1. Download Minitool Partition Wizard from here: http://www.partitionwizard.com/free-partition-manager.html (thanks @Roylegr!)
    2. Format the USB stick with Minitool Partition Wizard in FAT32 format
    3. Rightclicked the USB partition in Minitool Partition Wizard, and under Modify, selected Change Partition Type ID
    4. Selected 0x81 Minix/Linux and clicked OK
    5. Then clicked Apply on the top left (don't forget this, as Minitool Partition Wizard doesn't apply immediately)
    6. Now I copied only the .aml and update.zip on the stick
    7. Then inserted the stick into my Minix Neo X8-H and did the update process

    I've been breaking my head on this for a week now, and this finally fixed it! Can't wait for the update to be ready.
    hally187, GaryD, Ozito and 2 others like this.
  10. Higgs

    Higgs Yellow Dude Super Moderator

    The update is ready. look in your apps for Minix System Update.
  11. ArceeKay

    ArceeKay Active Member

    Thank you @Higgs! Indeed, after running the update procedure, there is a new Minix System Update icon.
    And indeed, in there I find yet another update, dating 13 december 2014. It's downloading now!
  12. Cylon1978

    Cylon1978 New Member

    Thanks for this topic. Update finally working..
  13. Steve

    Steve New Member

    Thank you very much for this, after many unsuccessful attempts this worked like a dream. :)
  14. dquillman

    dquillman Member

    THANK YOU!!! This fixed the problem I was having. I already had a FAT32 USB stick with the update files on it and so I downloaded the Mini Partition Wizard and set the Partition ID to 0x81 Linux/Minix and that fixed the problem. THANK YOU!!!
  15. CharlieHoople

    CharlieHoople New Member

    hello all, I had issues (would not load the files off my usb key, would say signature verification failed after i checked MD5 checksum?) anyway I tried the usb update about 10 times and always failed, so I installed the files on an SD card, it said unable to install from ucard, then I was able to select from ext and pick sd card, and it worked.

    very strange but it is downloading the on air update right now :)
  16. Hammerhead

    Hammerhead Member

    You guys that are having issues with the USB not finding the file. You should be using the OTG cable for this upgrade this is what it is for. One end has the micro USB the other has a normal USB female for your USB stick to plug into. When you go to upgrade and choice select it will automatically find the UPDATE.ZIP FILE.. Just highlight it follow the on screen prompts.



    After updating the Search feature in Netflix no longer works properly. When you try to input letters they don't show up in the sear bar. A bunch of Chinese charters pop up above the keyboard. with the letters but makes no sense. All the letters are now in Chinese and cant be changed to English even though it says its on English . Nothing gets imputed into the search bar itself. The search function is rendered useless now with the on screen or remote keyboard. I hooked up a mic to the MINIX this works so far. Now on my Box I cant use the on screen or remotes keyboard I have to use the mic and speak the movie tiles.. The Mic works very well but not everyone is going to have a spare mic laying around like I had.
    Last edited: Jan 5, 2015
  17. dquillman

    dquillman Member

  18. Hammerhead

    Hammerhead Member

    I thought it said that in the instructions ???..That's what I used when I did the update. I just checked the manual it does say to use the OTG port for Manual upgrades..


    If anyone is having issues with black bars at the top and bottom you can fix this with the video cal. The easy way to do it is with a movie playing so you know where the Black bars start and stop. I had a heck of a time calibrating it with no movie playing.. I kept getting black strips at the top and bottom of the screen..


    Still cant find a fix for the Netflix search issue ..
    Last edited: Jan 5, 2015
  19. Kit

    Kit New Member

    THIS ADVICE has just put the last 2 hours of recovery menus and reboots, formatting and stress to ease...... 1000 thank you's !!! :)
    dquillman likes this.
  20. billmc51

    billmc51 New Member

    None of this works for me. E: signature not found and there is another one. I just give up for the day. Been doing some type of tv things for years, never had a file this hard to do unless the file itself was jacked up.