1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Factory reset weirdness

Discussion in 'NEO X7 mini' started by Rob Nicholson, May 26, 2016.

  1. Rob Nicholson

    Rob Nicholson New Member

    I upgraded my Neo X7 Minix to v2.50 (250) months ago via the Rockchip utility. This was fun in itself as I just couldn't get the Rockchip USB drivers working under Windows 10 x64 (any news on that BTW?) so had to image my laptop, zap it back to MBR so I could install Windows XP. Anyway, that's a bit of an aside.

    Something happened over the last week that meant I lost the system icons at the bottom (task switcher, volume) but most importantly, couldn't navigate on the home screen using the remote control. So I did a factor reset but that introduced some very weird problems.

    Firstly, there used to be an XBMC for Minix app pre-installed. That had gone! I've registered with Minix for XBMC but not holding my breath as some people say the latest KODI is actually better.

    Secondly, I was unable to add my Google account - complained about not being able to connect to the Google Servers. I found a post that said this was a problem with Google Play Services and had to manually install it via the APK. This took me to the very useless but very technical apkmirror. For reference the Neo X7 Mini is a Rockchip RK3188 chipset which is contains a ARM Cortex-A9 CPU which is 32-bit CPU implementing the ARMv7 architecture. So one needs the Google Play Services APK with the 030 tag (0 = <v5; KitKat is 4.4; 3 = armeabi-v7a and 0 = no DPI.

    After installing this via USB drive, I was able to add my Google account and then install KODI so I was back in business. Phew!

    But couple of quirks still - can't get the home button to work on my remote (at least the arrow keys work again) and I can't get the system tray icons back (task switcher, volume, home button). These aren't show stoppers but I'm perplexed why they've disappeared.

    Has there been an OTA upgrade that might have changed something?

    If I've got time, I'll re-flash v250 ROM but it's all a bit perplexing.

    Cheers, Rob.
  2. Villa

    Villa Trusted Helper Super Moderator

    You don't need to image you laptop you can use a virtual machine with Windows 7/XP installed.
    http://www.minixforum.com/threads/x7-kitkat-250-february-8th-2016.10905/page-13#post-99543
  3. Rob Nicholson

    Rob Nicholson New Member

    I tried (a lot) to get a VM working and it just didn't work. I've used VMware Workstation for years (so understand it well) but just couldn't get the USB passthrough to work. I'll have another go - just thought of something; the VM I tried might have been upgraded to USB 3 and that does sometimes cause problems.
  4. Villa

    Villa Trusted Helper Super Moderator

    I've never tried it actually, but I have heard others have and been successful!
    I must try it myself!
  5. Sleepinruff

    Sleepinruff New Member

  6. Higgs

    Higgs Yellow Dude Super Moderator

    The img file is the firmware.

    Sent from my MotoG3 using Tapatalk
    Sleepinruff likes this.
  7. Sleepinruff

    Sleepinruff New Member

    hi, thanks for the reply.
    i just tried it and...

    snip minix missing firmware 1.jpg

    any ideas?