1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Tutorial Fix A2 & A2 Lite back button in XBMC

Discussion in 'NEO A3, A2 Lite Airmouse' started by Michael Farrugia, Jan 3, 2015.

  1. Dog's dinner

    Dog's dinner New Member

    Thanks Bennett for the file and the tip, but that's the bit I don't know how to do, how to get the file into the keymaps folder.

    I'be just tried copying the file from the download folder on the tablet over to the keymaps folder, but the tablet esl file explorer can't see the esl file explorer on the Minix, and vice versa. Using the A2 lite mouse pointer to get from a to b is near impossible because the pointer slides across the screen all the while even when I'm holding the remote as still as poss. I'tried using the ftp address - but that doesn't work.

    I copied the xml file to my computer and found it via esl on the Minix, but there's no way to copy it. There's no ctrl+c on the remote, and the menu button doesn't work in the esl environment.

    So the long and the short of it is I'm stumped.

    PS using the scan for new LAN units from esl on the Minix fails to find the tablet.
  2. Bennett83

    Bennett83 Active Member

    You need to show hidden files in es file explorer,its on the left hand side on new version but it's in display settings on older versions. All I did is open es file explorer on the minix and sent it using es on my android phone. They both need to be on the same network and no VPNs enabled. Your remote sounds like it needs recalibrating and/or new batteries
    Last edited: Aug 23, 2016
  3. Dog's dinner

    Dog's dinner New Member

    I had show hidden files on on the Minix, but not on the tablet. It's now allowed on my tablet, S7 edge and minix. I've made sure everything's on the same network, as far as I can. Unfortunately, minix esl doesn't confirm when you're connected or which network you're connected to, it just reverts back to the menu "Join a network. Waiting for joning a network". Buf it must be joined to the network because it can see my main computer, plus a couple of other things. But not the tablet or s7.

    I'm giving up for tonight. Started on this 4 hours ago and am still on square one. But thanks for your help so far.
  4. Villa

    Villa Administrator Administrator

    Using your U1 and a browser, browse to this thread and download the keymap.xml file direct to the device. Then use ES File Explorer to put it in the correct location. Simple! (y)
  5. Thommo7777

    Thommo7777 New Member

    I've downloaded keymap file onto my minix u1 ,I can find that on es explorer ,I can't find the location to copy it to on es explorer ,I got hidden files highlighted I haven't got a clue how to use es explorer,it doesn't help that seem little big for the screen
  6. Dog's dinner

    Dog's dinner New Member

    Turns out there are 2 keymap.xml files in esl download folder. Think I must have pressed 'download' twice.

    But I'm still baffled how to delete the one I don't need and move the other to the keymaps folder. Which keys on the a2 control are the delete and move functions? As far as I can see, there are none, not in the esl screen interface either. I've looked through every option on the esl screen interface. I wasn't asked where I wanted to download the file to either, which would have helped.

    I've pressed every button on the key pad with and without Fn on while hovering over the xml file (marking or shading it) in the download window. I've searched through the written instructions that came with the remote (using the Hubble telescope for magnification), and searched online. Not a dicky bird. There's a logic here that I'm just not getting.

    Still, at least I know where the xml file is. So it's one step forward.
  7. Thommo7777

    Thommo7777 New Member

    I've downloaded 4 times lol,I'm trying to figure out how to copy it to keymap folder
  8. Villa

    Villa Administrator Administrator

    Select and hold on the file, the file will become checked and the Copy, Cut, Delete, etc... will appear at the bottom.
    Select Copy, then go to the location where it needs to be and select Paste.
  9. Thommo7777

    Thommo7777 New Member

    Thanks I worked it out in the end,I had to do it twice I have kodi and smpc installed ,Ive only had this box a week ,I installed kodi / reinstalled kodi 3 times I thought there was a bug in it ,it was doing me head until I googled it and found this site.
    sangaz likes this.
  10. Villa

    Villa Administrator Administrator

    (y) Welcome! :)
  11. Thommo7777

    Thommo7777 New Member

    Your better of downloading direct to your box,that's what I did and follow villas instructions which is lot easier.
    Villa likes this.
  12. Dog's dinner

    Dog's dinner New Member

    Thanks Thommo7777 and Villa both for good advice. But I did download the xml file direct to the device - if that's what you mean by the 'box' Thommo7777 - it's residing in the download folder on the Minix. And I selected it at least 20 times yesterday, keeping it selected for minutes at a time, but no menu appeared at the bottom of the screen (or anywhere else) with the options to delete, move etc. Indeed, nothing changed at all on the screen. The same 8 options were there as before, i.e., Exit, Theme, Settings, New, Search, Refresh, View, More. And as I said, I've explored them all and pressed every button combination on the remote known to man. In fact, when I woke up and turned on the TV today and the Minix, the xml file was still selected and still no options to move or delete were in sight.

    My experience with streaming boxes is limited to two editions of the WD TV Live, one G-box midnight media player and something called an Android box Q7, that's before getting the Minix. But then I never had any need to dig into the internal setup, so all this is new to me.

    I'm just wondering if there isn't an app I can use on one of my devices instead of the A2 lite, which is great for short commands, but unwieldy to use on an internet page for example. To negotiate xmbc/Kodi, I've always used Yatse, but that doesn't help in these circumstances.

    I'm sure I'm missing a beat somewhere.
  13. Dog's dinner

    Dog's dinner New Member

    By the way, if it'll help I can take pictures of the TV screen showing the download folder on the Minix etc. and upload them (if that's allowed).
  14. Villa

    Villa Administrator Administrator

    This shouldn't matter but it sounds like you are using an old version of ES File Explorer!
    It sounds like you aren't selecting and holding on the file!

    Before select and hold...
    Images will look different to yours as using latest app version!



  15. Dog's dinner

    Dog's dinner New Member

    Ah, I see. I'm using the esl that came with the Minix, but I'll try updating it. Brilliant idea Villa!
  16. Villa

    Villa Administrator Administrator

    I actually don't know what you mean by esl? I assumed you meant ES File Explorer!
  17. Dog's dinner

    Dog's dinner New Member

    My mistake - you're completely right, it is the ES file explorer. I've got a fixation on the old Quad ESL electrostatic loudspeakers, that's where the extra L came from. Anyway, when I get a mo I'll try and update the ES explorer. I bet that'll do the trick.
  18. Villa

    Villa Administrator Administrator

    No, it shouldn't matter if you are using an old version. Sounds like operator error to me! ;):ROFLMAO:
  19. Higgs

    Higgs Yellow Dude Super Moderator

    Updating the ES File Explorer is a good idea but in all honesty I don't think this is the cause of your problem.
    For what you've said "And I selected it at least 20 times yesterday, keeping it selected for minutes at a time" it leads me to believe that you are not doing 'click and hold' but rather just selected the item and waiting for the options to change.
    You need to long-press, long click, click and hold.... however you want to word it.... for the options to change.
  20. Dog's dinner

    Dog's dinner New Member

    Updating ES I think solved the dilemma. The menu appeared at last at the bottom of the screen when I long-held the selection arrow and I managed to move the file to the keymaps folder. I'll let you know the outcome when I restart the Minix. It's very likely the menu would have appeared in the old ES version if I'd kept the button pressed long enough, I just didn't try it. The new ES file explorer interface looks infinitely better than the old, by the way.

    I would never have managed this without help. The last thing that would have occurred to me would have been to press and hold. I'll need to note this down somewhere for future use.
    Villa likes this.