1. Registration issues have now been resolved. New accounts are able to be created

FTP transfer Rate tanked on U9

Discussion in 'Official Firmwares' started by Liam O Donnell, May 29, 2017.

  1. Liam O Donnell

    Liam O Donnell New Member

    I have two X8 units setup to transfer data to/from a PC. I can achieve transfer rates of between 20MB/s and 25MB/s.
    I purchased two U9 units a couple of months ago. I have posted messages on the form re some problems I was having with the units when used with ftp apps. The FTP Server app on the FW003 and FW004A image would not work. I downloaded "FTP Server Ultimate" which connected to the units but only in read-only mode. I could not change the permissions to allow RW access. I noticed one of the messages that popped up, stating that this app was designed for an earlier version of Android. So I went again to Play-Store and downloaded another FTP server. (Ftp server 1.3.1 by 'The Olive Stree Software').

    This time I connected in RW mode. However, the transfer rate plummeted to less than 10MB/s. This is a big drop based on the Older version. I expected the newer unit to maintain at least the best speed of the older unit.

    Is there any way I can tweak this, or am I stuck with this paltry transfer rate.
    Or do you have an FTP server to recommend which would be better than above.

    I have now tried 3 firmwares FW003, 4A and 5beta.


    Regards
    Liam
    Last edited: May 29, 2017
  2. Liam O Donnell

    Liam O Donnell New Member

    in settings app permissions ... 'this app was designed for an older version of Android. Denying permission may cause it to no longer function as required'. This is the message I spoke about in my earlier message. (This includes the ftp server bundled with the base Minix image on both fw003 and fw004a and fw005beta).

    With respect to the drop in transfer rate, is it likely that the app limited the transfer rate in favour of one purchasing the 'pro' version?.
    Unfortunately, I cannot do a like for like test, as the app I normally use (FTP Ultimate Server) does not have the permission to write to the external storage ... this is definitely a problem ... I've spent the day downloading and testing a number of ftp servers, all bar one could not write to external storage with the message above shown when looking at the app settings. And the one that did write was disappointing.

    Ok, so this appears to highlight a couple of problems.
    1) Ftp server bundled does not work, cannot connect using client ftp. Note: The same error above appears when viewing settings for this app, so I guess, if even there was a way to connect with this ftp server, writing to external storage would still be a problem.

    2) Although the only setting which can be set on external storage is set, these apps designed for pre Marshmallow Android cannot write to external storage in Minix U9.

    - I'll presume at this point that the speed problems are FTP app related for now, until I can successfully test with pre Marshmallow ftp apps. With a view to being able to directly compare the use of 'FTP Ultimate' on X8 and U9 units.

    Q. Are these know issues?

    Let me know what I can do to get FTP operating satisfactorily.

    Thank You
    Liam
    Last edited: May 29, 2017
  3. Villa

    Villa Well-Known Member Super Moderator

    You may edit your post! ;)
    Just select Edit beneath the post. :)
  4. Liam O Donnell

    Liam O Donnell New Member

    Thanks Villa, updated my posts accordingly
  5. Dr Goodvibes

    Dr Goodvibes The Doctor

    Model: Minix U9-H
    Firmware: 005 (Released 26-Jun-2017)
    Root Access: No (not yet. ;) )
    FTP Application: FTP Server Pro
    SDcard: 64GB SanDisk Extreme U3 (tested real 70/55MB/sec IO)
    Format: exFAT
    FTP Source: Intel i5 NUC
    FTP destination: MicroSD Port
    Media: 1GB Ethernet (940Mbits/sec)

    FTP Read and Write to MicroSD card using a 150MB binary file saw an avg download/write of 43.7MB/sec and avg upload/read of 44.8MB/sec
    With smaller files there will be an element of write-ahead and caching which could cloud real IO.
    Downloading a 22GB Blu-ray movie saw an avg 24MB/sec write to the MicroSD card.
    This would probably be more reflective of true IO.

    Google Play: A1 SD Bench sees an avg 27/27MB/sec read/write to the MicroSD card and approx. 35/35MB/sec for a USB 3.0 thumb drive.
  6. Liam O Donnell

    Liam O Donnell New Member

    I installed fw005, and also installed FTP server Pro.
    I'm using a 1GB ethernet connection,
    Im using a WD My Book 2TB connected via USB.

    This same connection on a X8 device achieves the same performance you have demonstrated.
    My U9 device cannot get above 10MB/s, I expected a rate closer to 24MB/s.

    Image shows the transfer rate achieved to the U9.
    [​IMG]

    What can I do to fix this?

    Thanks
    Liam
  7. MrBig

    MrBig Active Member

    My 5tb drive is formatted NTFS and I achieve similar speeds as @Dr Goodvibes.
  8. Liam O Donnell

    Liam O Donnell New Member

    So, what am I missing? I have tried this many times, using the same network setup and switching the X8 with the U9 units.

    Liam
  9. MrBig

    MrBig Active Member

    I think I misunderstood you. Is your External HD connected to your PC or U9-h? My USB drive is connected to my U9-h and I'm transferring files to the PC from the U9-h and from the PC to the U9-h, by either using FTP, ES File Explorer on the U9-h and smb on the PC. I connected the drive to thew U9-h because the throughput is faster when playing videos from my library and I don't have to rely on the network and the lag it may cause.
  10. Liam O Donnell

    Liam O Donnell New Member

    My two X8 units are in separate rooms, connected to the home network via an 8-port Ethernet Cisco Switch, each Minix has a 1TB WD USB External HDD connected.
    Files are synchronised between the PC and the Minix boxes from time to time.

    I have trying to replace my two X8 units with the new U9 units, but am very hesitant in doing so, as the transfer rate is so poor by comparison


    My Setup
    =======

    PC -> 8-port 1Gb/s Cisco Ethernet Switch
    Switch -> Minix
    Minix -> USB 1TB WD External HDD (My Book)

    Let me know if you need any additional info.

    HTH
    Liam