1. Welcome to the official forum for MINIX devices!

FAQ How to enter recovery mode?

Discussion in 'NEO U1 Guides & FAQs' started by MINIX - Ken, Feb 1, 2016.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    Does it boot okay normally (not in recovery mode)?
    I'm assuming it connected okay to the usb burning tool and you got the Burning Successful message at the end of flashing the firmware. According to the guide the first boot after the firmware flash can take 'some minutes' but I assume you've waiting a while.
    The only thing I can suggest is to try the usb burning tool once more (make sure you use normal erase and follow the guide step by step). If you still have no luck after that then return it.
  2. Elvis

    Elvis Member

    Yes it booted normally. Yes it said Connected success. I can't be real sure about the rest you asked but I believe I followed the instructions as I wrote them down before hand. One thing I found weird is that xbmc minix app was still there although it was like starting from a clean install. Is this normal or should I've had to re-download it ?
  3. Elvis

    Elvis Member


    BTW: There was a reset button (I assume, it had a plunger) in that little hole. I tried putting into recovery with no luck after the failed full image install.
  4. Higgs

    Higgs Yellow Dude Super Moderator

    Just a thought... I had never tried the recovery mode before on my U1 so thought I would give it a go.
    Steps taken;
    1. Switch box off (Power menu - Power off)
    2. Switch TV source back to correct HDMI (as it automatically switched back to TV)
    3. Hold power button (on box) in for approx 6 secs
    4. After the Android logo appears release the power button
    5. Box boots into recovery menu.
    Note: Step 4 to Step 5 may take a few seconds.

    I'm thinking maybe its step 4 you are missing?
  5. Elvis

    Elvis Member

    Tried again multiple times. I will do a couple of full firmware re-flash''s and if no joy I will order a new one and ship back this one. New to Minix but love the support which is real important to me.

    Thanks to all
  6. Elvis

    Elvis Member

    I have to agree with Alex.

    I paid $209. Canadian that included the A2 lite remote. I would like away to enter recovery mode from the convenience from my easy chair. I don't think you should necessarily put it in the power management (sleep, restart, power off) icons, as it may be to easy for a child, teenager or someone else to erase someones setup.I have read where several other brands have used an addon or app to do this.

    Is there a thread/forum I should post this where the development team may read and consider something like this ?
  7. newbie99

    newbie99 Moderator Moderator

  8. Elvis

    Elvis Member

    Perfect I will go post over there.
  9. newbie99

    newbie99 Moderator Moderator

    hehehe, I found a """backdoor"""... It's a little bit tricky... use the
    UPDATE&BACKUP app
    [Select]
    You will get a list of found zip-files at the system
    - as an example I took/select the metadata.album.universal-2.6.0.zip
    [Update]
    Now the system reboots to recovery BUT will of course get a secure check error while trying to use this file for an update because this zip file have not the right signature (it's something like crc to be sure the zip you want to use isn't corrupt and "legal")...
    Now I have full access to the recovery...
    skynet and PatrickvH like this.
  10. Elvis

    Elvis Member

    Works like a charm. Great find Newbie!!!
  11. newbie99

    newbie99 Moderator Moderator

    :) :) :) You are wellcome
    (but so I think something is wrong with the power-button at your U1)
  12. skynet

    skynet Well-Known Member Trusted Helper

    Very good idea ;)
  13. Elvis

    Elvis Member

    Thought I post how my issue was resolved.

    I just learned this afternoon that my sd card stopped my U1 from going into recovery mode. I had a recovery file from a previous non Minix box stop my u1 from going into recovery. Who would of thought that a file from another box to go into recovery would stop the Minix going into recovery.
  14. newbie99

    newbie99 Moderator Moderator

    Yes, the AMLogic bootloader also look at the SDcard (before at the NAND) and if it will find a recovery.img at it then it tries to use it :)
  15. bovirus

    bovirus New Member

    @Higgs

    Could you please the meaning of color for frontal led?

    ex.
    Blue light = POWER On
    Blue = Standby
    others?
  16. Villa

    Villa Well-Known Member Super Moderator