1. Registration issues have now been resolved. New accounts are able to be created

How to flash firmware image (X6, X8 series)

Discussion in 'General - Guides and FAQ' started by HardwareGuru, Aug 10, 2014.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    Dear all X6, X8/X8-Plus/X8-H/X8-H-Plus users,

    To flash the image firmware, you need to:

    1.) Download the .img firmware package;
    2.) Extract it;
    3.) Install the Windows USB flash tool, downloading from:
    http://minix.com.hk/downfile/USB_Burning_Tool_v2.0.4.3_user.rar
    Choose "Install anyway" when system prompts for driver installation, then open the application, and choose English (picture 1 & 2);
    1.jpg 2.jpg
    4.) Connect the Micro USB cable supplied with the box between the OTG port of the box and your computer (Windows based);
    5.) Power up the device while holding the "Recover" button located at the back of the hub first;
    6.) Upon successful connection the "Connect success" message will be displayed inside the application (picture 3);
    3.jpg
    7.) Load the firmware image by selecting "File -> Import image" (picture 4 & 5);
    4.jpg 5.jpg
    8.) After loading, the 1st and 2nd box of "Configuration", "Erase flash" (Normal erase) and "Erase bootloader", should be checked by default. Then, click "Start" to start flashing (picture 6); DO NOT check the 3rd and 4th box for safety reasons (4th option would erase all keys such as MAC address, be careful)
    6.jpg 7.jpg
    9.) The upgrade process will take approximately 3-4 minutes, the last 5-10% takes really long time, and you MUST make sure the power can't be disconnected during the upgrade or your box could become a brick;
    10.) Upon successful upgrade, the application will display the message "Burning successfully" (picture 8), then it's safe to unplug the power and connect your hub back to the TV for 1st start (which is also very important);
    8.jpg

    So about 1st start:
    The first start takes MINUTES to complete!

    It's very important that you DO NOT cut the power off from the hub during the 1st start,
    since preloaded apps. will be installed in the background, if you power it off in the middle of the installation, some preloaded apps. might become be missing.

    NOTE: Always use the "Normal erase" option
  2. Wiggly

    Wiggly New Member

    I had no success trying this method. I spent about 90 minutes trying this before I gave up and wondered if I had a faulty Minix box recover button. The USB Flash tool would never recognise the minix. Are we supposed to have the HDMI plugged in to TV so we can see anything is happening? Very frustrating.

    I tried the other method updating via USB or SD Card using TV as per your other forum and it worked perfectly 1st time, much simpler than this method. threads/update-10-aug-2014-x8-h-flashable-zip-for-neo-x8-h.98/
    Avivmalihil and YAronfari like this.
  3. JC1

    JC1 New Member

    The very first time I did this, the driver was installed and nothing happened(no connect message). I pulled the power, and started over, the second time it worked fine. It seemed the initial pass doesn't work, but try again. Of course, don't do any power pulling if you're in the middle of any burning :), just if nothing took the first time.
    ruprect likes this.
  4. Wiggly

    Wiggly New Member

    I pulled the power out many times. Computer never recognised the Minix, I guess I could try again but the other method using USB or SD is so much simpler that I don't think it is worth stuffing about with this method.
    YAronfari likes this.
  5. Magic-Goat

    Magic-Goat New Member

    Same here. is there a link to the correct drivers?

    edit: Did as JC1 said, works fine now :p
  6. Jayesh Samji

    Jayesh Samji New Member

    Hi guys, can I use an Apple Mac to upgrade the firmware, or directly onto the device using a SD card?
  7. marianparlors

    marianparlors New Member

    This post really helped a lot! Keep me posted pls. Thanks!
    andrianpaul likes this.
  8. Thomas Morkenborg

    Thomas Morkenborg New Member

    WORKS like a Charm! easy proces and this new beta is really running well. Took me about 5 min all included - Needed a proper length USB to micro USB cable though, but that in itself was the biggest challenge ;-)
  9. Dnerve

    Dnerve Active Member

    Unfortunately, if on a mac without bootcamp, you wont be able to update without going the SD card way. As it is unofficial, the only other way would be to wait for the update to be pushed OTA.
    Jayesh Samji likes this.
  10. Pico

    Pico New Member

    Did I just bricked my Minix..

    following steps in step 1 I got an window error in USB Burning tool; check the log...

    My log has the following entries


    [20:08:48 370][HUB2-1][Err]--Identify status failed
    [20:08:48 870][HUB2-1][Err]--[20:08:49 370][HUB2-1][Err]--[20:08:49 371][HUB2-1][Err]--[0x32010101]USB error occur when sending identify command at Uboot Erase stage
    [20:09:18 387][Global][Inf]--User click refresh button
    [20:09:18 873][Global][Inf]--Burning thread HUB2-1 start
    [20:09:19 373][HUB2-1][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&13b963d1&0&1#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x000001f0
    [20:09:19 443][Global][Inf]--User click refresh button
    [20:09:19 473][HUB2-1][Inf]--Connect path=Standard Enhanced PCI to USB Host Controller/P0/P0
    [20:09:19 473][HUB2-1][Inf]--Start burning...
    [20:09:19 973][HUB2-1][Inf]--------------ERASE BOOTLOADER------------
    [20:09:19 974][HUB2-1][Inf]---1-0-0-0
    [20:09:19 975][HUB2-1][Inf]--------------DOWDLOAD DDR------------
    [20:09:22 976][HUB2-1][Inf]--0-7-0-16
    [20:09:22 977][HUB2-1][Inf]--No need download
    [20:09:22 977][HUB2-1][Inf]--------------DOWDLOAD UBOOT_COMP------------
    [20:09:22 979][HUB2-1][Inf]--0-7-0-16
    [20:09:22 979][HUB2-1][Inf]--No need download
    [20:09:22 979][HUB2-1][Inf]-------------Download meson-----------
    [20:09:22 981][HUB2-1][Inf]--0-7-0-16
    [20:09:22 986][HUB2-1][Inf]-- download mem dtb normal 19238
    [20:09:23 002][HUB2-1][Inf]--Send download command success
    [20:09:23 002][HUB2-1][Err]--
    [20:09:23 003][HUB2-1][Err]--[0x31010302]download command return failure at Uboot Partition 1
    [20:09:37 775][Global][War]--Close tool
    [20:09:38 504][Global][Inf]--Burning thread HUB2-1 end run
    [20:09:38 504][Global][Inf]--Burning thread HUB2-1 exit
    [20:09:38 825][Global][War]--Controler exit

    Can anyone help?
    Last edited: Aug 17, 2014
  11. Dnerve

    Dnerve Active Member

    @Pico

    I'm not good in reading logs but:

    -What OS are you on?
    -Did you wait for the driver to fully install and accepted all the prompts? If not/unsure change port and reconnect your Minix and let it install, it can take some time.
    -how is your unit after this? How does it behave?
  12. Pico

    Pico New Member

    @Dnerve

    Running Windows 7 Home Premium
    Yep...once connected I see the drivers install..Says world cup driver installed
    Minix doesn't start up at all....but still connects to the USB Burning Tool

    Attached Files:

  13. Dnerve

    Dnerve Active Member

    Ok so you are still in upgrade mode. Did you power cycle the minix since then? Have you tried flashing again?
  14. Pico

    Pico New Member

    I had to power cycle the minix as my tool crashed and didn't recognize the minix...once I completed a power cycle..I connected and got further but...crashed again..

    Kept the minix on and connected the OTA to a different USB port on my desktop and tried again and it was successful..phew!


    [21:10:36 128][Global][Inf]--User click open button
    [21:10:38 977][Global][Inf]--Image path C:\Users\Administrator\Downloads\X8_X8H_002BETA8\aml_upgrade_package.img
    [21:10:46 208][Global][Inf]--Parsing burning package
    [21:10:46 216][Global][Inf]--Load configuration file C:\Program Files (x86)\Amlogic\USB_Burning_Tool\temp
    [21:10:46 225][Global][Inf]--Parse burning configuration file C:\Program Files (x86)\Amlogic\USB_Burning_Tool\temp\burn_config.xml
    [21:10:46 256][Global][Inf]--Get burning key
    [21:10:50 629][Global][Inf]--User click start button
    [21:10:50 631][Global][Inf]--SetErase
    [21:10:50 631][Global][Inf]--Enable burning 1
    [21:10:50 631][Global][Inf]--Scan usb device
    [21:10:50 632][Global][Inf]--Aml scan WorldCup Device
    [21:10:50 637][Global][Inf]--Host: Standard Enhanced PCI to USB Host Controller
    [21:10:50 637][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4396&subsys_26151019&rev_00#3&267a616a&0&92#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 637][Global][Inf]---->Roothub:USB#ROOT_HUB20#4&25ae17b9&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 638][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 638][Global][Inf]-------->[Port1]NoDeviceConnected
    [21:10:50 638][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 638][Global][Inf]-------->[Port3]NoDeviceConnected
    [21:10:50 638][Global][Inf]-------->[Port4]NoDeviceConnected
    [21:10:50 638][Global][Inf]-------->[Port5]NoDeviceConnected
    [21:10:50 639][Global][Inf]--Host: Standard Enhanced PCI to USB Host Controller
    [21:10:50 639][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4396&subsys_26151019&rev_00#3&267a616a&0&9a#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 640][Global][Inf]---->Roothub:USB#ROOT_HUB20#4&2f4a75d&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 640][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 643][Global][Inf]-------->[Port1]\\?\usb#vid_1b8e&pid_c003#5&13b963d1&0&2#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
    [21:10:50 643][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 643][Global][Inf]-------->[Port3]NoDeviceConnected
    [21:10:50 643][Global][Inf]-------->[Port4]NoDeviceConnected
    [21:10:50 643][Global][Inf]-------->[Port5]NoDeviceConnected
    [21:10:50 645][Global][Inf]--Host: Standard OpenHCD USB Host Controller
    [21:10:50 645][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4397&subsys_26151019&rev_00#3&267a616a&0&90#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 645][Global][Inf]---->Roothub:USB#ROOT_HUB#4&27ee42a9&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 645][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 648][Global][Inf]-------->[Port1]Other device
    [21:10:50 648][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 649][Global][Inf]--Host: Standard OpenHCD USB Host Controller
    [21:10:50 649][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4397&subsys_26151019&rev_00#3&267a616a&0&98#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 650][Global][Inf]---->Roothub:USB#ROOT_HUB#4&32447878&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 650][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 650][Global][Inf]-------->[Port1]NoDeviceConnected
    [21:10:50 650][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 652][Global][Inf]--Host: Standard OpenHCD USB Host Controller
    [21:10:50 652][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4398&subsys_26151019&rev_00#3&267a616a&0&91#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 652][Global][Inf]---->Roothub:USB#ROOT_HUB#4&1c2c115&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 652][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 652][Global][Inf]-------->[Port1]NoDeviceConnected
    [21:10:50 652][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 654][Global][Inf]--Host: Standard OpenHCD USB Host Controller
    [21:10:50 654][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4398&subsys_26151019&rev_00#3&267a616a&0&99#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 654][Global][Inf]---->Roothub:USB#ROOT_HUB#4&1cd53005&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 655][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 655][Global][Inf]-------->[Port1]NoDeviceConnected
    [21:10:50 655][Global][Inf]-------->[Port2]NoDeviceConnected
    [21:10:50 656][Global][Inf]--Host: Standard OpenHCD USB Host Controller
    [21:10:50 656][Global][Inf]--DevPath:\\?\pci#ven_1002&dev_4399&subsys_26151019&rev_00#3&267a616a&0&a5#{3abf6f2d-71c4-462a-8a92-1e6861e6af27}
    [21:10:50 656][Global][Inf]---->Roothub:USB#ROOT_HUB#4&14dee91a&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [21:10:50 657][Global][Inf]-------->[Port0]NoDeviceConnected
    [21:10:50 657][Global][Inf]-------->[Port1]NoDeviceConnected
    [21:10:50 657][Global][Inf]--Scan USB host controller complete
    [21:10:50 658][Global][Inf]--Update data center with HubMap
    [21:10:50 658][Global][Inf]--Update hub2 device data
    [21:10:50 658][Global][Inf]--Update HUB2-1
    [21:10:50 658][Global][Inf]--Update HUB2-2 \\?\usb#vid_1b8e&pid_c003#5&13b963d1&0&2#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
    [21:10:50 658][Global][Inf]--Update HUB2-3
    [21:10:50 658][Global][Inf]--Update HUB2-4
    [21:10:50 658][Global][Inf]--Update HUB2-5
    [21:10:50 658][Global][Inf]--Update HUB2-6
    [21:10:50 818][HUB2-2][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&13b963d1&0&2#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x000001f4
    [21:10:50 944][HUB2-2][Inf]--CloneImageProxy
    [21:10:50 951][HUB2-2][Inf]--Connect path=Standard Enhanced PCI to USB Host Controller/P0/P1
    [21:10:50 951][HUB2-2][Inf]--Start burning...
    [21:10:51 461][HUB2-2][Inf]--------------ERASE BOOTLOADER------------
    [21:10:51 492][HUB2-2][Inf]--0-7-0-16
    [21:10:51 492][HUB2-2][Inf]--Identify status success
    [21:10:51 494][HUB2-2][Inf]-- low_power
    [21:10:51 499][HUB2-2][Inf]--Low power command success
    [21:10:51 502][HUB2-2][Inf]--Read low power success
    [21:10:51 502][HUB2-2][Inf]--bootloader_is_old
    [21:10:51 502][HUB2-2][Inf]--Bootloader command success
    [21:10:51 508][HUB2-2][Err]--failed: bootloader is new
    [21:10:51 508][HUB2-2][Inf]--Bootloader is new
    [21:10:51 527][HUB2-2][Inf]--------------DOWDLOAD DDR------------
    [21:10:54 528][HUB2-2][Inf]--0-7-0-16
    [21:10:54 528][HUB2-2][Inf]--No need download
    [21:10:54 547][HUB2-2][Inf]--------------DOWDLOAD UBOOT_COMP------------
    [21:10:54 549][HUB2-2][Inf]--0-7-0-16
    [21:10:54 549][HUB2-2][Inf]--No need download
    [21:10:54 550][HUB2-2][Inf]-------------Download meson-----------
    [21:10:54 551][HUB2-2][Inf]--0-7-0-16
    [21:10:54 580][HUB2-2][Inf]-- download mem dtb normal 19238
    [21:10:54 581][HUB2-2][Inf]--Send download command success
    [21:10:54 597][HUB2-2][Inf]--Read command status success
    [21:10:54 605][HUB2-2][Inf]--Transfer complete
    [21:10:54 605][HUB2-2][Inf]--Send download get_status command succeed
    [21:10:54 609][HUB2-2][Inf]--get_status success
    [21:10:55 109][HUB2-2][Inf]-- low_power
    [21:10:55 110][HUB2-2][Inf]--Send command success
    [21:10:55 114][HUB2-2][Inf]--Read command status success
    [21:10:55 114][HUB2-2][Inf]-------------ERASE FLASH-----------
    [21:10:55 114][HUB2-2][Inf]--disk_initial 1
    [21:10:55 115][HUB2-2][Inf]--Send command success
    [21:10:55 121][HUB2-2][Inf]--Read command status success
    [21:10:55 122][HUB2-2][Inf]--0-7-0-16
    [21:10:55 122][HUB2-2][Inf]-------------Download boot-----------
    [21:10:55 124][HUB2-2][Inf]--0-7-0-16
    [21:10:55 124][HUB2-2][Inf]--download store boot normal 8595216
    [21:10:55 124][HUB2-2][Inf]--Send download command success
    [21:10:55 140][HUB2-2][Inf]--Read command status success
    [21:10:57 051][HUB2-2][Inf]--Transfer complete
    [21:10:57 051][HUB2-2][Inf]--Send download get_status command succeed
    [21:10:57 055][HUB2-2][Inf]--get_status success
    [21:10:57 055][HUB2-2][Inf]--verify sha1sum c0cdb46c053cd921725b03510435cc340fa35ac3
    [21:10:57 056][HUB2-2][Inf]--Send verify cmd succeed
    [21:10:57 879][HUB2-2][Inf]--Get verify status success
    [21:10:58 379][HUB2-2][Inf]-------------Download logo-----------
    [21:10:58 380][HUB2-2][Inf]--0-7-0-16
    [21:10:58 381][HUB2-2][Inf]--download store logo normal 8985920
    [21:10:58 381][HUB2-2][Inf]--Send download command success
    [21:10:58 396][HUB2-2][Inf]--Read command status success
    [21:11:00 406][HUB2-2][Inf]--Transfer complete
    [21:11:00 407][HUB2-2][Inf]--Send download get_status command succeed
    [21:11:00 411][HUB2-2][Inf]--get_status success
    [21:11:00 411][HUB2-2][Inf]--verify sha1sum 6524bcf4d9c6b5278ac203c8cd88be8d827bbf2d
    [21:11:00 411][HUB2-2][Inf]--Send verify cmd succeed
    [21:11:01 271][HUB2-2][Inf]--Get verify status success
    [21:11:01 771][HUB2-2][Inf]-------------Download recovery-----------
    [21:11:01 773][HUB2-2][Inf]--0-7-0-16
    [21:11:01 773][HUB2-2][Inf]--download store recovery normal 9759184
    [21:11:01 773][HUB2-2][Inf]--Send download command success
    [21:11:01 789][HUB2-2][Inf]--Read command status success
    [21:11:03 957][HUB2-2][Inf]--Transfer complete
    [21:11:03 957][HUB2-2][Inf]--Send download get_status command succeed
    [21:11:03 961][HUB2-2][Inf]--get_status success
    [21:11:03 961][HUB2-2][Inf]--verify sha1sum 51967624e6a7022d08101d753afb6963a61c0eed
    [21:11:03 961][HUB2-2][Inf]--Send verify cmd succeed
    [21:11:04 894][HUB2-2][Inf]--Get verify status success
    [21:11:05 394][HUB2-2][Inf]-------------Download system-----------
    [21:11:05 396][HUB2-2][Inf]--0-7-0-16
    [21:11:05 396][HUB2-2][Inf]--download store system sparse 640371664
    [21:11:05 396][HUB2-2][Inf]--Send download command success
    [21:11:05 413][HUB2-2][Inf]--Read command status success
    [21:13:01 499][HUB2-2][Inf]--Transfer complete
    [21:13:01 499][HUB2-2][Inf]--Send download get_status command succeed
    [21:13:01 503][HUB2-2][Inf]--get_status success
    [21:13:01 503][HUB2-2][Inf]--verify sha1sum 25e717b9b45a5ae9b77559e79f952078037b4031
    [21:13:01 504][HUB2-2][Inf]--Send verify cmd succeed
    [21:14:07 683][HUB2-2][Inf]--Get verify status success
    [21:14:08 183][HUB2-2][Inf]-------------Download bootloader-----------
    [21:14:08 185][HUB2-2][Inf]--0-7-0-16
    [21:14:08 185][HUB2-2][Inf]--download store bootloader normal 363314
    [21:14:08 185][HUB2-2][Inf]--Send download command success
    [21:14:08 199][HUB2-2][Inf]--Read command status success
    [21:14:14 057][HUB2-2][Inf]--Transfer complete
    [21:14:14 057][HUB2-2][Inf]--Send download get_status command succeed
    [21:14:14 061][HUB2-2][Inf]--get_status success
    [21:14:14 061][HUB2-2][Inf]--verify sha1sum 4e7c63bfc6ab1c7a0e050d06002d4ce3dee666cc
    [21:14:14 062][HUB2-2][Inf]--Send verify cmd succeed
    [21:14:14 356][HUB2-2][Inf]--Get verify status success
    [21:14:14 856][HUB2-2][Inf]--save_setting
    [21:14:14 857][HUB2-2][Inf]--Send command success
    [21:14:15 748][HUB2-2][Inf]--Read command status success
    [21:14:15 748][HUB2-2][Inf]--burn_complete 3
    [21:14:15 749][HUB2-2][Inf]--Send command success
    [21:14:15 827][HUB2-2][Inf]--[0x00000000]Burning successfully
  15. Dnerve

    Dnerve Active Member

    Sorry, fell asleep last night, glad to near it went well!
    Arturo likes this.
  16. mikehump3

    mikehump3 New Member

    minixforums indicates that an SD card can be used for the latest update - UPDATE 23-july-2014: X8-H Flashable zip for NEO X8(H) However, minixforums is now closed to posts. My question is, 'can I use a remote keyboard already registered to my Neo 8 instead of a USB connected keyboard?
  17. HardwareGuru

    HardwareGuru Developer Administrator

    Please use the search on this forum and you had found it.
    Again; Please keep my zip releases out of the official release topic.
    Thanks.
  18. Jayesh Samji

    Jayesh Samji New Member

    Thanks, so do I download the firmware, then extract it onto the SD CARD,?
  19. mikehump3

    mikehump3 New Member

    Thank you HardwareGuru. I used a USB flashdrive, copied the .rar file to it and followed the instructions. So far, everything has worked correctly and I have a fully restored Neo 8H
  20. Jayesh Samji

    Jayesh Samji New Member

    What format was your USB stick?