1. Registration issues have now been resolved. New accounts are able to be created

How to flash firmware image (X6, X8 series)

Discussion in 'General - Guides and FAQ' started by HardwareGuru, Aug 10, 2014.

  1. tvjunkie

    tvjunkie New Member

    To quote myself :)
    I already bought new boxes, but today I was browsing trough forum and I saw new 008 fw. So tried everything again with hope that something will change.
    No luck again

    So everything goes perfectly well. But it wont boot. Tried USB method too. No way to boot into android.
    Changed TV/HDMI/LAN w and w/o, nothing helps.

    Does anyone have idea what can be a problem? Because with usb burning tool, as you can see I always get success result, but it wont boot to Android. (Nor OpenElec, tried that too).

    Attached Files:

  2. bboy71

    bboy71 New Member

    Im having issues getting my minix neo 8 to boot now,I tried the boot without hdmi cable connected method but still wont boot.Ive downloaded the firmware/usb burning tool but when I get to around 6% I keep getting the following error:
    (0x30404004)UBOOT/partition boot/get download status/Error re
    Does anyone have any idea of why im getting this error?ive read through most of this thread and I dont seem to find any solutions to the problem.Thanks
  3. Grippy Man

    Grippy Man Active Member

    Is your box bricked ?
  4. Grippy Man

    Grippy Man Active Member

    Dear HardwareGuru, Please tell about First Start. Burn was successful and now I've powered it up for the first time but seeing nothing on the screen. Is there any ambiguity ?
  5. Wiggly

    Wiggly New Member

    No, not at all. I use it often. Now on Kodi 16.1 and it generally works great almost 2 years on.
    Just the 1st update I found I had to do from the SD card or USB datakey, after that all updates have worked via the System menu, then all the way at the bottom under 'About' there is an Update option which always works, the other update options in other parts of the System menu do not work for me (OTA or System Update).
  6. Grippy Man

    Grippy Man Active Member

    It was really a mistake buying X8-H Plus for me. I noticed that Kodi crashes at almost every different skin which might be a cause of higher graphics in skins. Only default skins works smoothly so far.
  7. Jacek087

    Jacek087 New Member

    Hello! I'm a new member at minix forum.

    I try install new firmware and during the process is appeared that problem

    Create workflow xml file field

    It is appear when I try load image fil.
    Last edited: Jul 22, 2016
  8. HardwareGuru

    HardwareGuru Developer Administrator

    Download again and make sure you use the supplied burning tool
  9. Miro007

    Miro007 New Member

    Hi. I have minix neo x8 h plus. I just update this firmware, it was successful then i unplug it. Now the ethernet and WiFi doesn't works. Please your help needed. What should I do next to get ethernet of WiFi back..?
  10. Villa

    Villa Well-Known Member Super Moderator

    You have an X8-H Plus.
    Which firmware did you flash?
    Was it for the X8-H Plus or one of the other X8 series? They are different!
    Higgs likes this.
  11. Miro007

    Miro007 New Member

    Thanks for reply. I appreciate, I believe it was a wrong firmware that I flush. Then checked out I found minix official firmware for minix, I installed and it's work excellent, I mean super fast with new kodi icon and much more. Thanks
    Villa likes this.
  12. tvjunkie

    tvjunkie New Member

    Guys, is there any new idea on horizon? You can see my problem up there. Successful flashing with every possible way, but wont pass boot screen. Cant boot into system.
    I tried to short-pin two dots, but without success. So by that, it must be software problem, but I dont know what else to try to make it alive again.
    Red light on the back (spdif) is turned on when I turn on box.
    Tried different HDMI, to turn it on without HDMI, different charger .... and so on. Every possible combination you can think on :)
  13. Turan1903

    Turan1903 New Member

    Hello to everyone.
    I hope I'm not annoying anyone but I read most of the stuff in this thread and I dont seem to find another thread resolving my problem.

    I have a minix neo 8XH Plus with Andorid Version 4.4.2
    and firmware KOT49H.20141122

    As I figured out I somehow have FW 001 or so on my device which is almost 8 months old. I dont seem to be able to update it online as it says no update available.

    Now my problem is I do only have a MacBook (wihtout Windows) and do also have an external HDD (NTFS) with all my movies on it etc.

    I read in this thread I have to update through a SD Card but didnt find any manual how to do this? could someone maybe put in the link with the explanations how to update my device without a Windows? could I also update my device with my external HD or does it have to be a sd card?
  14. Higgs

    Higgs Yellow Dude Super Moderator

    http://www.minixforum.com/index.php?posts/66486


    Sent from my MotoG3 using Tapatalk
  15. Turan1903

    Turan1903 New Member

  16. JaseM

    JaseM New Member

    Utter rubbish. Complete waste of time.
  17. Higgs

    Higgs Yellow Dude Super Moderator

    That was a very informative post :rolleyes:
    If you have a problem with the instructions in post 1 then could you explain what the issue is? Otherwise your post is <quote>Utter rubbish. Complete waste of time.</quote>
  18. JaseM

    JaseM New Member

    Agreed. Very frustrated at spending an entire evening trying to get my laptop to recognise the Minix box when in recovery mode. It half recognises it when booting normally, but there is an error in Device Manager saying that there needs to be another action before the device/drivers are working properly. What that action is, is anyone's guess...
  19. Turan1903

    Turan1903 New Member


    Ok I did everything as explained in this thread but when I choose udisk no device cant be found, I even tried each usb slot it just says. E: faled to mount /udisk (No such device) my stick is FAT32 formatted (according my macbook MS DOS (FAT32) but for some reason minix cant unmount it. I have a X8H Plus
  20. zeusau

    zeusau New Member

    hi i have got a Minix second hand which has the X8-Hplus firmware installed but the wifi wont work i think it maybe just a X8-H so it could be the wrong firmware is there a way to tell the model. and if it is the wrong firmware which is the best way to put the right one in it thanks in advance
    dander2 likes this.