1. Registration issues have now been resolved. New accounts are able to be created

How to set location permissions for apps?

Discussion in 'NEO U1' started by rax369, Apr 2, 2017.

  1. rax369

    rax369 New Member

    Hi there,

    I'm having a hard time trying to figure out how to allow an app to use my current location on my MINIX NEO U1 (apparently since its latest version, developers designed the app as "geolocked").

    Also have the same app in both of my android phones (one with android 4.4.2, the other using 6.0.1) but in both of them have been able to set the permission w/out a problems.

    1st. screenshot: Shows the warning the app shows once it has been launched
    2nd. screenshot: Shows how the location was already enabled
    3rd. screenshot: Shows the permissions that app already has

    Is there anything else I can do to allow that app to use my the location or enabling something else to complete the process of granting that kind of permissions? :(

    Thanks for your help!

    PD: Tried to add the proper screenshot to this post, in a sorted way, but because your forum rules it wasn't allowed.

    Attached Files:

  2. Higgs

    Higgs Yellow Dude Super Moderator

    So what exactly is the problem? What happens when you click OK as shown in the first screenshot?
  3. rax369

    rax369 New Member

    Nothing happens it just stays there forever, doesn't matter how many times I press OK.

    It wont allow me to continue, show the app contents, menus, etc. Now that's just happening in my MINIX, when I install the app in my phone it runs w/out problems.

    Hence the doubt if I could do something else to grant or confirm the permissions.
  4. rax369

    rax369 New Member

    Sorry had forgotten to mention what app is that.

    It's FuboTV v3.1.1 (streaming sports channels) app.
  5. Higgs

    Higgs Yellow Dude Super Moderator

    Is it like the ok button press isn't registering? Can you select the cancel button?
    What remote are you using?

    Sent from my MotoG3 using Tapatalk
  6. rax369

    rax369 New Member

    My mistake sorry for the confusion. I performed again the tests, and I can press either the OK or the cancel button, both responds but when I press OK, it just take me to the previous screen where it request "allow location access" (shown @ the 2nd screenshot added to this post, not to the initial post of this thread).

    I'm beginning to think it's an app issue. However it's pretty strange that the same app version is working in both of my phones.

    About the remotes, currently using Rii i8+ but also have the Minix A2 Lite. With both remotes got the same result.

    Attached Files:

    Last edited: Apr 3, 2017
  7. CybeRider

    CybeRider Member

    I wonder if it could be the case your phones have GPS while Minix U1 doesn't...

    you probably need a usb GPS module.


    Last edited: Apr 3, 2017
  8. Villa

    Villa Well-Known Member Super Moderator

    Maybe this...
    How many devices can I stream from at the same time?
    One fuboTV subscription allows you to stream from two devices at a time. The function to stream from more than two devices simultaneously is restricted and prohibited due to licensing restrictions.


    ¿En cuantos dispositivos puedo usar fuboTV simultáneamente?
    Una cuenta activa de fuboTV, puede ser utilizada en dos dispositivos a la vez. La función de transmitir más de dos dispositivos simultáneamente está restringida y prohibida debido a restricciones de licencia.


    If not maybe you should contact fuboTV support!
  9. rax369

    rax369 New Member

    I was also thinking that could be the missing element, any suggestion on what GPS receiver could be compatible with my Minix Neo U1? :(

    @Villa: Thanks for your suggestion, however I'm aware about that restriction. Hence don't stream simultaneously from 2 devices, but just from one. ;)
  10. CybeRider

    CybeRider Member

    It crossed my mind bacause one of your pics mentions it. This is what I found about GPS setup here in the forum:

    http://www.minixforum.com/threads/howto-enable-gps.556/


    I hope someone can help you further as I don't have a clue about which gadjet will do the trick. The solution I would follow for myself would be to open the app in one of the phones and Miracast it to the TV. (I'm too lazy to worry pioneering, as soon as I read "you must have root"...):D

    .
    Last edited: Apr 3, 2017
  11. Villa

    Villa Well-Known Member Super Moderator

    I say contact fuboTV support!
    CybeRider likes this.
  12. rax369

    rax369 New Member

    @CybeRider: Thanks for that suggestion, however as you stated the box should be rooted in order to perform that procedure, and hence lose the warranty. :confused:

    All of that just for running an app? Mmmm... nope! I don't thinks so! o_O

    @Villa: Besides the fact their supports sucks! Already contacted them, and they state that the problem remains in the app permissions, like if I could change them on android 5.X (screenshot added: permission for apps).

    The permissions of a particular app, can be changed from android 6.X (AFAIK), shown @ the other screenshot added.

    Attached Files:

  13. CybeRider

    CybeRider Member

    I was just pointing a direction. The link I told you is for a particular hardware 'usb gps mouse' - whatever that is.

    http://mapsnmaps.blogspot.pt/2014/02/using-external-usb-gps-with-android.html

    The above is another example of another device, they don't mention the need for root access, but all this is too old stuff and not Minix related either.

    Don't give up. If you really want that thing to work you probably will have to struggle a little. I told you I got lazy, but back in the days... I still have a working Win98 machine full of my batch files, friends recall me as the 1st person they saw connecting to the Internet, with a thing called Netscape and a 14.4k modem, when word processing was done with a thing called Wordstar and spreadsheets in Lotus 123, installed over DOS. My first DOS computer didn't have a hard drive, the first divX file I saw running was produced by me, backing up one of my DVD, to a cd recorder as I had bought my first DVD reader, when dvd recorders didn't exist, after following text instructions and experimental software exchanged in News Groups. A 600mb file would easily take a full day to process and very likely not to work afterwards, to download it was just unthinkable. That first cd recorder cost me the equivalent of two monthly salaries, and I assembled it myself in a new computer I was paying in a long term loan, without insurances to cover for accidental damage. Naturally to see someone step back because of voiding the warranty of a 100 dlrs gizmo...

    But I can understand that maybe it is not worth the effort. There will always be Miracast. :sneaky:
    Last edited: Apr 4, 2017
  14. Villa

    Villa Well-Known Member Super Moderator

    Do you actually have Location enabled?

    Screenshot_2017-04-04-09-36-40.png
  15. rax369

    rax369 New Member

    Thanks again to both of you for your help.

    @CybeRider: I'm also an old wolf in this tech world my friend, my 1st steps with PCs dates from when humans used DOS as their OSes (even had a Commodore 64) lol

    @Villa: Indeed, the location was enabled from the 1st moment I knew that app was requiring it. However it has not helped @ all. Even enabling it, it wont pass from the screen shown before. :cry:

    I guess it's a GPS related issues as it was mentioned by @CybeRider. Hopefully the Support Team from FuboTV will address this issue in the next app version, otherwise will be necessary a GPS connection to the MINIX (in case that's what's stopping the app from running normally).
  16. Villa

    Villa Well-Known Member Super Moderator

    An option is to give your login credentials to the MINIX team and let them test the app.
    I tried signing up for the 7 day trial but they want credit card details!

    I can't see it being GPS related!
    The app is available for Roku, Apple TV, amazon fireTV & androidtv which do not have GPS!
  17. Higgs

    Higgs Yellow Dude Super Moderator

    But maybe these are special TV versions of the app, not the phone/tablet version


    Sent from my MotoG3 using Tapatalk
  18. Villa

    Villa Well-Known Member Super Moderator

  19. Higgs

    Higgs Yellow Dude Super Moderator

    But won't the playstore see the U1 as a phone/tablet not as android TV, so will install the phone/tablet version and expect GPS. I'm not saying this is the issue, but that it can't be ruled out just because the android TV versions works.

    Sent from my MotoG3 using Tapatalk
  20. CybeRider

    CybeRider Member

    Well, this is crazy. Trying access in Portugal it reports: "We're Sorry. FuboTv content is currently not available in your location" in the several versions +website, this goes for two smart phones ( a Kitkat 4.4.2 and a Lollipop) and two computers an XP and a Win7, and of course our Minix. Yet @Villa is just here on the side (Spain) and he gets it!

    Life is so unfair!:ROFLMAO:

    @rax369: Now that I saw that I can't have it I'm starting to think about that app as a MUST!:sick:
    Last edited: Apr 4, 2017