1. We are having national holidays from 1/10 to 8/10, please note.

How to: Update to newest firmware for MINIX X7 mini / X7 / X5 Mini / X5

Discussion in 'General Rockchip ( x5mini/x5/x7/x7mini )' started by m6242, Apr 6, 2015.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    Read post 1

    Sent from my XT1032 using Tapatalk
  2. alistair20

    alistair20 New Member

    Hi, I have successfully connected my minix neo x7 mini with my laptop, however only as mass storage. When I insert the clip for a hard reset, it says device is unrecognized, and it does not let me update the drivers as it states that those are the best drivers. (Windows does not ask me to install drivers or whatever it just appears in device manager)

    My OS is windows 10 - 64 bit
  3. Villa

    Villa Well-Known Member Super Moderator

    Your device should be off before entering recovery! Power lead is only connected while holding in the reset.

    You may also have a problem with Windows 10.
  4. m6242

    m6242 Active Member

    It seems that you have to use the left usb Slot. Look here:

    Greetings M6242
  5. jose gonzalez

    jose gonzalez New Member

    My Neo 7 is stuck loading the minix screen, so i want to try and update the system, but i don't see anything about drivers for windows 10. Can someone please direct me to a page on the forum that will help.
  6. 7even

    7even New Member

    Hello,

    I don't have a Windows system, how can I update the firmware for my Minix Neo x5 (mini? have to figure this out...) with Linux?
    The update check within the box tells me there is no newer software available, but the version is from 2013 apparently - so I think it lost the track to newer versions somehow.

    Once I flashed an android device with a cyanogen image via adb - would this work for the minix box as well?

    Thanx,
    Nicolas
  7. m6242

    m6242 Active Member

    Edited first post and added Win10 help.
  8. xinput

    xinput Member

    Hello,
    I lost the original USB male to male cable. I've bought a new one, unfortunately it isn't working.

    My X7 mini is stucking in the minix boot screen and i can't reset it or flash with a new ROM now.
    Is there anything i can do to get it working again?

    Best regards.

    EDIT: i can enter the Android recovery menu, but no option there fixes my problem that it stucks on boot logo.

    EDIT2: finally solved..
    Last edited: Jan 28, 2016
  9. m6242

    m6242 Active Member

    Tell us how you solved your problem so maybe other users can participate.
  10. xinput

    xinput Member

    After i did a factory reset in the recovery menu and tried it many times again to connect it to my notebook it finally worked. Spend several hours to get it working
  11. Nelson Cascalheira

    Nelson Cascalheira New Member

    hi guys
    i have a minix x7 and win10 and my compuyer just doens't "ding" saying that recognizes the minix to install the update.
    can anyone help me?
    thanks
  12. MagicFeather

    MagicFeather New Member

    I have exactly the same problem, after doing that Windows 10 .reg tweak, it doesn't even show up in the Device Manager at all, when it did before. How can I undo the registry tweak? I don't have any backups :(.
  13. Punit Sharda

    Punit Sharda New Member

    I have the same issue with x5 mini. there was no 'special cable' as such, and I've tried regular USB cables, that doesn't work either. Please suggest a way to reflash the device. It has become very slow and boring
  14. Villa

    Villa Well-Known Member Super Moderator

    Your X5 Mini should be supplied with a USB type-A to type-A.

    51ZHmqvLdJL._SL1000_.jpg
  15. Punit Sharda

    Punit Sharda New Member

    Hello, Thanks for prompt reply. No I did not get any cable with the box, Also, I tried the switch at the bottom of the device, but it was not getting detected. Do I need to buy Type A to Type A cable?
  16. Villa

    Villa Well-Known Member Super Moderator

    I've never had an X5 Mini so I'm not familiar with it. I can only comment from what I see on the Forum. I guess you should get a cable! What are you trying to use anyway as you say the device is not getting detected?
  17. Punit Sharda

    Punit Sharda New Member

    I am trying to reflash it with latest ROM provided by minix. but my system only doesn't detect it
  18. Villa

    Villa Well-Known Member Super Moderator

    I know what you are trying to do, but if you don't have the cable then it is impossible!
    My question is, what are you using to connect the device to your PC if you don't have the cable?
  19. Punit Sharda

    Punit Sharda New Member

    I was using USB cables that I had.. not sure whether they were type A to type A
  20. Villa

    Villa Well-Known Member Super Moderator

    The image I posted above! o_O
    Type-A refers to the connector style.