1. Official MINIX forum

How to: Update to newest firmware for MINIX X7 mini / X7 / X5 Mini / X5

Discussion in 'General Rockchip ( x5mini/x5/x7/x7mini )' started by m6242, Apr 6, 2015.

  1. Punit Sharda

    Punit Sharda New Member

    Yes Something like that, but the device is not getting detected

    And this cable had not come with Minix box

    I will want to try again but need some help in terms of options available to me if the firmware update doesn't work

    [Moderator: Posts merged. Please note you can edit your posts rather than keep adding new ones]
    Last edited by a moderator: Apr 5, 2016
  2. Punit Sharda

    Punit Sharda New Member

    Hello everyone. I would like to give a big thank you to all who continue to support this forum and help out others with problems and upgrades. I was successfully able to upgrade my minix x5 mini yesterday and it is working all fine so far.

    Workaround for those who are not able to detect minix on their computer using the reset button.

    Open settings to change the following :

    1. USB should be selected to connect to pc. 2.Root your device to get developer options or press about device 7 times or so to get the developer options.
    3. In the developer options select the option that is something like power to fastboot.
    4. Reboot the minix by pressing the power button for some time and selecting reboot when prompted

    This will allow you to get into recovery mode when the system reboots and that's when the pc recognises the minix box and starts installing it's drivers. The rktool will also flash it green.

    Hope this helps to those who are struggling to get minix detected in their pc.

    Enjoy your minix!!
    Last edited: May 8, 2016
  3. zed_blade

    zed_blade New Member

    Hello everyone..

    I need some help. My Minix x5 Mini is currently stuck in Loader mode and I can't seem to flash the firmware.

    I've tried using the Rockchip Batch Tool from Windows 10, but then I get an error stating "Check Chip Failed". I've followed the necessary steps to get the drivers to work and I'm using the 1.8 version of the tool.

    The same error happens with version 1.7.

    Given this, I decided to try the Linux Tool. It clearly detects the Minix and that it is in Loader mode but nothing seems to happen. Not by runnuing LF nor by running UF.
    What can I do? It seems that even the frontal blue light is not on..

    I have to add that for the linux tool I'm running this with a VM on VirtualBox 5.0.20, but I don't think that makes any difference?

    best regards
  4. zed_blade

    zed_blade New Member

    Ok,

    I don't know what I did but I am now stuck in MaskROM mode. The thing is, I still can't restore the firmware or anything.
    It will always fail with "Download Boot Fail".

    On the BatchTool it shows a blue square on the device. On the LinuxTool it shows the MaskROM string. What ele can I do to solve this? I'm out of ideas

    Really stuck folks, I need a hand. Will someone help please?
  5. HardwareGuru

    HardwareGuru Developer Administrator

    Look under forum: general> guides> downgrade to 4.2
    Use this tool to flash the correct bootloader before flashing your firmware again.
  6. zed_blade

    zed_blade New Member

    Hello HardwareGuru, thank you for your reply.

    But that's the things. Even on DevelopTool I select the X5series_(...)V1 bin, but by clicking download, eraseId, eraseAll Blocks, etc, the output is always the same:
    "Download Boot Fail". (I have a X5 Mini)

    I think I may have a bad nand image or something like that.. What would be the advised course of action now? Shorting pins on the X5 motherboard?
    Use the linux tool and try to split the FW into sections and write individually to the chip?

    Or have I just killed the damn thing?

    Best Regards.
  7. zed_blade

    zed_blade New Member

    Ok, sorry for the double post.

    I just realized I've been pretty dumb. I'm having issues because I could sworn my unit was a X5 Mini, but after staring blank at it it just hit me. This is a X7 Mini intead of the X5. Terribly sorry for this. I feel pretty embarassed.

    Best Regards
    HardwareGuru likes this.
  8. Bencasa

    Bencasa New Member

    Hello,
    I have a problem with my Minix neo 7 , when I have updatet the box, it didn't works no more :-( has someone a tip for me .
    Thanks and best regards
  9. leongsem

    leongsem Member

    do you use the correct cable?
    have you put the pin at factory reset while power on?
    what version of window you using?
    Bencasa likes this.
  10. Arnie_boogs

    Arnie_boogs New Member

    How about for the x5 mini wothout the reset button and the cable port? Mine got stuck on the Minix logo and cant proceed to startup.. please help. Thanks!
  11. Higgs

    Higgs Yellow Dude Super Moderator

    See post 1

    Sent from my MotoG3 using Tapatalk
  12. Zampaï

    Zampaï New Member

    Hello,

    I tried tu update my Neo X7 mini to the last firmware because it was freezed on my TV : only showing the blinking "minix" logo.

    So I folowed the procedure for W10 (fix.reg, etc), but :
    At the end of the restore process I got this message : "Download Firmware Fail"
    (sorry I tried to add a print screen but I do not have rights for now)

    Can you help me ? I do not know what to do now for my minix :-(
    THX !
  13. midnight

    midnight Moderator Moderator

    I had the same issue helping a friend do his X5 mini ....not sure why it failed ? . I just tried it a second time and it was successful. :unsure:
  14. Zampaï

    Zampaï New Member

    I allready tried it 2 times. And I have rebooted my PC after the reg fix to be sure it operates. I got the same Fail message.
    Last edited: Sep 25, 2016
  15. Zampaï

    Zampaï New Member

    up ! and help please ! :) Is there an other way to update my minix neo x7 mini ? How can I fix the "failed download" ?
  16. HardwareGuru

    HardwareGuru Developer Administrator

    Use usb2.. also look in guides section.. there is a downgrade topic.. yiu can find a tool in there to flash the bootloader.. try that before flashing again.
  17. Zampaï

    Zampaï New Member

    Last edited: Oct 1, 2016
  18. Zampaï

    Zampaï New Member

    I tried to restore to an old realease : X7mini Kitkat 240 ( june 4th 2015 )
    http://www.minixforum.com/threads/x7mini-kitkat-240-june-4th-2015.6186/
    At the end I did not got the download failure message but I got a new message : "Format Disk Fail".
    On my TV, the minix showed the glowing Minix logo during a long time and then I have seen some "android formating stuff" messages.

    Now my minix is back working weel. OK. :)

    So I have a last question : why can't I update my minix X7 to the last firmware ?
    Last edited: Oct 1, 2016
  19. Slainte77

    Slainte77 New Member

    Hi, I am also having the same problem and am a newbie. How do I connect my Neo X5 Mini to my laptop? TIA Or is there another way to install firmware? My screen is stuck on the MINIX screen.
  20. taitas

    taitas New Member

    [Quote = "Villa, posta: 47039, membro: 253"] di Windows 8.1
    Sono corretto in quanto non vi è un problema con i driver 8.1 per Windows, ma infatti è il file config.ini RKFlashTool che è in colpa ?!

    Gli utenti possono scaricare il set di strumenti di downgrade che contiene un config.ini già modificato
    http://www.minixforum.com/downloads/download.php?file=Rockchip-Downgrade_tools.rar

    Non ho di Windows 8.1 quindi ho paura che non posso provare niente di tutto questo.


    cavo speciale
    Se si dispone il cavo in dotazione con il dispositivo, usarlo! (Y)

    Il cavo in dotazione con un dispositivo non è in realtà che speciale! (Ha un po 'più lungo del normale connettore micro USB). Ogni altro "cavo dati" può essere utilizzato, Micro USB (connettore lungo o corto) a USB A
    Personalmente, non ho mai avuto un problema con un connettore più corto.
    Si deve capire che un cavo di carico (che molto probabilmente guardare identico a un cavo dati) non funziona!

    L'opzione più semplice, però, se si ha il cavo in dotazione con il dispositivo, usarlo! (Y)[/ Quote]