1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

howto - enable GPS

Discussion in 'NEO X8-H, X8 Plus & X8 Guides and FAQs' started by Wal, Aug 28, 2014.

  1. Wal

    Wal New Member

    Hardware :
    USB GPS Mouse with PL2303 Chip - My Navilock USB GPS Modul NL-302U
    Minix X8-H
    Sygic and Google Maps testet

    1. you must have root:whistle:
    2. add in the build.prop "ro.kernel.android.gps=ttyUSB0" and "ro.kernel.android.gps.speed=4800"
    3. make a directory "/system/lib/modules" and copy "pl2303.ko" in the directory
    4. copy "gps.default.so" in "/system/lib/hw"
    5. copy "install-recovery.sh" and "init.gps.sh" to "/system/etc"
    6. set permission 755
    7. reboot

    that's all(y)

    Attached Files:

    daracerz and troy ross like this.
  2. Dnerve

    Dnerve Active Member

    Neat trick for a car PC! Seems you are almost ready with your screen and all! Perhaps a nice tutorial with pics of the installation on the way? :)
  3. Wal

    Wal New Member

    when I'm done with all:D
    MadSlob likes this.
  4. troy ross

    troy ross New Member

    Any updates on the navigation set up?
    I'm looking to install in Car
  5. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Very interesting application, sticky.
  6. troy ross

    troy ross New Member

    Any suggestions I have a 10.1 hd screen with touch ready I just need a android source with gps capability
  7. daracerz

    daracerz New Member

    Wal, awesome post and thanks for the data, came in real handy!!

    After the posted procedure, the GPS device is found and acquiring satalites, but it seems to be in an endless loop. Using GPS Test, I can see the unit start acquisition, gets about 7 satelites in view, and the moment 1 or 2 satelites turn "green", the unit appears to go through a reset and will either come on with circles or triangles in the gps tracker view. The unit I am using supports both GPS and GLONASS. I believe this is the problem. Does this driver support GLONASS receivers and know how I can modify it to get it to work?

  8. MonsieurKees

    MonsieurKees New Member

    Thanks Wal. I have done this on a NEO X5 with fw 240 and a Globalsat ND-105c USB GPS receiver (Globalsat gpsinfo app from playstore is very unstable).

    Unfortunatily I don't get it workimg. I have the feeling that the pl2303.ko driver isn't loaded at all.
    When I run Lsmod it shows only 8 modules and no pl2302.ko
    It's impossible to mount /system rw, so I cannot load the driver manually for further investigation.
  9. Chaminda

    Chaminda New Member

    I have BU-353S4 USB receiver and can't get it to work using the above method.
    Its says "set permission 775" - Is that for all the files copied?

    I'm not sure if pl2303.ko supports the newer receivers
  10. Muzza

    Muzza New Member

    I want to do this as I've got a G-Star IV BU-353S4 usb gps antenna and I've rooted my X8-H plus, but the rest is not clear to me.

    Can you provide a step by step guide on how to do this.

    Edit: I worked out how to do the above, but I cannot get it to work, any ideas?

    Also I've noticed that it seems to unroot itself, so I have had to do the root over again a few times.

    Last edited: Sep 8, 2017
  11. Muzza

    Muzza New Member

    Update, update!!!!

    Always remember google is your friend! Anyway I found the following site: http://mapsnmaps.blogspot.com.au/2014/02/using-external-usb-gps-with-android.html

    Basically you have to connect your usb gps receiver to the OTG usb port. Enable developer options, and allow mock locations. Then use the app You are here GPS.

    At first it would only receive gps info at 4800 baud but the info was gibberish. I couldn't work out what was going on or why. So I decided to hook the gps receiver to my laptop. I installed the PL2303 windows driver and inserted the usb. I then opened device manager and found the com port it was using. I then ran the GPSInfo windows program and set the com port. But I was getting similar gibberish info.

    I then found a FAQ page about my usb gps receiver at http://usglobalsat.com/store/gpsfacts/bu353s4_gps_facts.html

    It said I could configure my receiver with SirfDemo programming utility, but that "custom settings are temporary until the receiver has exhausted both the internal Super-Cap. Then the receiver will revert back to its original default settings."

    I then ran the sirfdemo program and under the action menu selected "switch to NMEA protocol".

    Connecting the receive back into the Minix and running you are here gps, I then set the baud rate to 9600 and then was able to receive the proper gps info.

    I could then run either/both gpsinfo or gps status apps and they now work. Google maps also found my current location also.

    I disconnected the gps and waited an hour to see if it would revert back to the default settings, but it still worked. I will now wait a whole day and then see if it reverts back or not.


    Update: a day later and its still working.

    Actually on the FAQ page where it says: "switch to NMEA protocol" there is no mention of this setting reverting back.

    So..... if I want to I'm set to be able to use my minix for a car PC/gps system, however it would be tedious to have to do the "you are here gps" app settings every time you wanted to use it.
    Last edited: Sep 12, 2017