1. Welcome to the official forum for MINIX devices!

X7 I thought the rockchip flash software was win 10 compatible now

Discussion in 'NEO X7' started by jamonbread, May 5, 2017.

  1. jamonbread

    jamonbread New Member

    I've installed the drivers but I constantly get USB device not recognised. I tried installing using device manager and navigating to the driver location and see there's only vista, win7, and win 8 drivers available and none of them work. I can basically only run the flash tool in windows 10.
  2. Villa

    Villa Well-Known Member Super Moderator

    Are you referring to this?
    http://www.minixforum.com/threads/h...x7-mini-x7-x5-mini-x5.5230/page-5#post-129198
  3. jamonbread

    jamonbread New Member

    I did download the batch tool from the link provided on the thread you linked, the last post claimed support for win 8/10. I grabbed the very latest version 1.8 from the link below
    https://freeandroidroot.com/download-rockchip-batch-tool/

    Also grabbed the latest rockchip driver assistant v4.4

    I also downloaded X7 Kitkat 240 ( june 4th 2015 )

    I have an X7 which is stuck at the boot-up MiniX logo, I had the same issues with an older X5 which I fixed by flashing with the rockchip batch tool when I was still using Win7. I've also tried booting the box up into recovery both resetting and wiping the catches containing user info.
    Last edited: May 5, 2017
  4. Villa

    Villa Well-Known Member Super Moderator

    Have you tried this?

    Hint: For Win 10 users :

    For the ones using Windows 10, to get the drivers working for the full image load using Rockchip tools , create a file in notepad let's call it "fix.reg" (extension "reg" is important, the name does not matter) and copy these lines in it:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\220700000222]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\220700060222]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\220700100222]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\2207292C0100]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\2207300A0100]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\2207300B0100]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\2207310B0100]
    "SkipBOSDescriptorQuery"=hex:01,00,00,00

    Save it, double click on it, and accept all warnings. Now the Drivers will work. It should work for 8.1 also (did not try it).
  5. jamonbread

    jamonbread New Member

    Thanks for the suggestion

    Does this only effect the installed driver, and will it be undone if I then uninstall the driver at a later date?

    Cheers
  6. Villa

    Villa Well-Known Member Super Moderator

    No idea!
  7. Irish Martin

    Irish Martin New Member

    Can you please advise on where to put this "fix.reg" file?
    Sorry a bit wet behind the ears?
  8. Villa

    Villa Well-Known Member Super Moderator

    I've never tried it and I don't know if it matters where it is put?
    But it says...
    Save it, double click on it, and accept all warnings. Now the Drivers will work.

    The instructions were copied from here...
    http://www.minixforum.com/threads/h...irmware-for-minix-x7-mini-x7-x5-mini-x5.5230/
    ...after the OP removed them when he claimed that the latest Rockchip Batchtool version works with Win8 or Win10.