1. Registration issues have now been resolved. New accounts are able to be created

is my Neo X7 dead? (another "not powering up thread"

Discussion in 'NEO X7' started by yud, May 23, 2017.

  1. yud

    yud New Member

    Hi,

    Received a Neo X7 and it is not powering up. Not sure when was the last time it worked. I really want to get it working...
    (of course I read all the "not powering up" thread here...)

    When I plug the power cord and press the power button I can see a red light flashing for a split of a second on the optical audio port. Then it goes off. And no video out at all.

    Checked power supply (5v, 2500mA), and it appeared OK. Bought another power supply, just in case. Same results. (5v, 3000mA).

    Performed the reset sequence a number of times (paper clip + power button, etc). Same results.

    Installed the USB driver and connected to a PC. Windows Device Manager is showing it as "Unknown USB Device (Device Descriptor Request Failed). Uninstalling the unrecognised device and re-discovering it yields the same results. No luck with a different USB port and different computer.
    Obviously the RK Tool does not see the X7.

    Does it mean my X7 is dead? Is there any way to resurrect it?

    Will appreciate any advice as it seems like a fantastic thing to have.

    Thanks!
  2. yud

    yud New Member

    An update:

    As soon as I posted the above I came across this thread:
    http://www.minixforum.com/threads/i...ash-software-was-win-10-compatible-now.16448/

    Did the registry update, connected the X7 again, and voila! Windows now recognised it! So it's not completely dead after all.

    Now the RK Tool also detected it and I was able to successfully upgrade to the latest firmware.

    BUT...

    Still no video out!

    The blue light is now on (wasn't previously) and I can see a light through the optical port (steady, as opposed to the split second it was before).

    Connected to 2 different monitors using 2 different HDMI cables, but no video out.

    Performed a few reset sequences with no luck (unless I'm doing it wrong). No logo, no display, nothing!

    Any advice?
  3. Higgs

    Higgs Yellow Dude Super Moderator

    Try powering it up without the hdmi cable connected. Then connect the hdmi cable for 5 mins or so.
    What resolution are the monitors? Can you try with a television?
  4. yud

    yud New Member

    Thanks for the quick reply!

    Tried powering up with no HDMI cable connected. Then connected it. Still no video.

    One monitor has resolution of 1920 x 1080.
    The other is an HD TV.
    No video on either.

    I then realised I just upgraded the firmware, instead of using "restore". So I tried the process again but I cannot put it into recovery mode! No matter how many times I tried.

    Any suggestions?
  5. Higgs

    Higgs Yellow Dude Super Moderator

    If the square is pink when connected to the rkflashtool then try using the Switch button and the box should turn green.
  6. yud

    yud New Member

    Nope. All squares are blank.
    Keep reconnecting and doing the reset sequence but no indication from Windows that it's connected and all squares in the RK Tool are blank.

    EDIT:
    Doing it now! Managed to get it connected. Will update shortly.

    EDIT 2:
    Managed to run Restore. Still no video out! :-(
    Last edited: May 23, 2017
  7. Villa

    Villa Well-Known Member Super Moderator

  8. yud

    yud New Member

  9. Villa

    Villa Well-Known Member Super Moderator

    That is correct!
  10. yud

    yud New Member

    An update:

    After many many tries I managed to get the X7 in flash mode AND recognized by the RKDevelop Tool.
    I then managed to change the boot loader.

    Bu since then I cannot get any of my machines to recognize the device when in flash mode. I always get "USB device driver not recognized" with an "unknown device" in Device Manager.

    Tried this on Windows 7 (32 bit), Windows 8 and Windows 10. The Win 10 machine is the one I originally flashed KK, then downgraded the boot loader.
    With the Windows 8 and 10 I had the registry hack.
    I uninstalled the driver and re-installed a number of times on each. No lock.

    So now I have the JB bootloader but cannot downgrade the firmware. :-(

    Any advice how to get the USB driver properly installed so I can downgrade to JB?

    Or perhaps all the troubles I had so far indicate my X7 is a goner?

    Will appreciate any help!
  11. Adambob

    Adambob New Member

    Thanks for this new thread i will try some of the ideas, i got no more replys on my thread
  12. Adambob

    Adambob New Member

    this might help
  13. yud

    yud New Member

    Thanks but it doesn't.

    As explained in my previous post none of the machine recognize the device, regardless of how many times I uninstalled/reinstalled the driver.
  14. yud

    yud New Member

    Gave up on the X7.

    Bought Neo X8-H Plus on eBay.

    Thanks everyone for your help.