1. Welcome to the official forum for MINIX devices!

Is there a way to have the U1 Autostart when plugged in?

Discussion in 'NEO U1' started by Robert D Nicholson, Feb 19, 2016.

  1. RikD

    RikD Member

    I'd like to know this as well. H R S D, did you figure this one out or does anyone else know?

    edit:
    After flashing a new ROM, this settings persists. That means that the menu option calls code that flashes a seperate rom or something.
    I'm still very interested if this can be done from shell or a piece of Java code that enables/disables the autopower feature.
    Last edited: Jan 16, 2017
  2. H R S D

    H R S D New Member

    Hey RikD -- Nope, I never figured it out. I've searched many documents within the IMG/ROM looking for "MCU" but no luck :(
    Let me know if you get lucky.
  3. Dokuos

    Dokuos New Member

    Finally there are diferent boards for U1.

    I have 2 "old" U1 wich auto starts without check nothing in MCU and now I bought 4 "news" that doesn't auto start if not enables th MCU option. Same firm in all, so I suposse that are diferent boards, some pins solder or something like that.

    At first sight, looks identical but something different exists
  4. RikD

    RikD Member

    If you enabled the setting once, then flashed a new firmware version, the auto start setting is still active, but the checkbox in MCU is unchecked.
    If you want to disable autostart, you can check the box, then uncheck the box and it should be disabled.

    It seems it's write only and the actual value is never read.
  5. Dokuos

    Dokuos New Member

    Yes is like that, always check.

    But is more curious that I use FW10, FW11 and FW12, all with the same result.....always autopower on although MCU is uncheck
  6. Dokuos

    Dokuos New Member

    I received answer from Minix (Thanks John), and they said that form factory ALL U1 have to check MCU to enable autostart......

    This is an X-File....my U1 is like diamond, :)
    kingsizept likes this.
  7. RikD

    RikD Member

    What John said is (obviously) correct. New U1's straight out of the factory don't have auto power enabled. You have to manually check the checkbox in MCU settings. If you have done this on FW10 and then flash to FW11 or FW12, the autopower FUNCTION is still active, but the SETTING is not checked in MCU settings.

    I don't know how I can say it more clearly, there is no mystery or x-file o_O
  8. RikD

    RikD Member

    Also it would be greatly appreciated if @MINIX - John could let us know if and how this setting can be enabled/disabled from ADB Shell.
  9. Dokuos

    Dokuos New Member

    Thank you RikD

    This weekend I'll make more test, because now I didn't remember the steps I followed to make two units autopower without MCU (n)

    More info, next monday.

    Thank everybody
    Last edited: Apr 21, 2017
  10. Dokuos

    Dokuos New Member

    Well, good news

    As normal, RikD It's right...(y)(y)(y)(y)

    Is I check the MCU in FW005 (the factory firm), and after upgrade to FW0012....VoilĂ , the autopower works even the MCU is check or uncheck,

    Thank you very much