1. Welcome to the official forum for MINIX devices!

It is possible to install windows creator update

Discussion in 'NEO Z83-4' started by xixou, May 19, 2017.

  1. Yaronk100

    Yaronk100 New Member

    Hi to all the helpers,

    I ran Windows update troubleshooter. It fixed a few things and I ran the Windows Upgrade Assistant again.
    It downloaded the files for the upgrade and began the first restart session. When it got to 11% it suddenly stopped, no message displayed, and restarted again. After restarting it gave the message: "Restoring your previous version of Windows...".
    I have no clue what prevents it from progressing and finalizing the upgrade.
  2. Joe Shuster

    Joe Shuster New Member

    Thanks for the process explanation. I've downloaded and run the partition manager -- just browsing so far. My system's first partition is 64mb, not 100mb. It seems like that isn't a problem for your process.

    I'm more nervous/curious about the 16mb that everyone is discarding. Is there a variation of your procedure that doesn't wipe out the 16mb partition? Can the partition manager move that little partition enough to expand the System partition for the Windows update?

    Also, I presume that after expanding the System partition to about 500 Mb, you need to leave it that way in case future Windows updates need that space again, right?

    Thanks, Joe
  3. Villa

    Villa Well-Known Member Super Moderator

    http://www.minixforum.com/threads/i...ndows-creator-update.16565/page-2#post-133557
  4. Joe Shuster

    Joe Shuster New Member

    Villa, thanks for directing my to that post.

    However, the 16 mb MSR partition doesn't show up in the Disk Manager list: From_Disk_Management.png

    But it does show in the partition tool:
    From_MiniTool_Partition_Wizard.png

    So you won't know whether or not you have the MSR from looking at Disk Manager.

    Also, the reading I've done suggests that the MSR is something that Windows expects and uses as a scratchpad for fixing problems on the fly. That's why I'm hesitant to delete the MSR for the benefit of updating Windows. If the deletion causes a problem it will show up at the time when Windows is trying to fix something. It seems like turning off the airbag in your car -- You might never notice it, but if you do need it's a little too late.

    That's why I asked about a way to preserve the MSR while extending the system partition to the size that allows a Windows update.

    Joe
    Villa likes this.
  5. Villa

    Villa Well-Known Member Super Moderator

    Very true! :)

    This is me...

    MiniTool.PNG
  6. Mike Bazley

    Mike Bazley New Member

    I have updated to Windows Creator using a 30gb usb memory stick however the wifi driver in Device Manager now has a warning triangle. I have tried to update the driver but it says I have the latest version. Bluetooth ok and used to connect keyboard. Any help welcome?
  7. liad

    liad New Member

    Windows won't update

    My windows trys to update but then i get an error message. I added a pic to show the error. Help please?

    Attached Files:

    Last edited by a moderator: Jul 20, 2017
  8. Villa

    Villa Well-Known Member Super Moderator

  9. liad

    liad New Member

    I read the instruction and understood nothing. I think this one is way over my league...how can a simple dude make this work?
  10. Mike Bazley

    Mike Bazley New Member

    Solved by replacing the most recent broadcom wifi driver with 5.93.100.25 from 2014
  11. RudyB

    RudyB New Member

    Joe Shuster likes this.
  12. RudyB

    RudyB New Member

    @Mike Bazley
    Mike, I reckon it was a complete new Windows install that you did? Which would preserve / create the required MSR partition. Would it be too much asked if you could give us a step by step cookbook prescription of how you did this?
    Joe Shuster likes this.
  13. lukasware

    lukasware New Member

    I wanted to confirm that xixou's fix works perfectly...I tried to install the creator's update a few times but it only worked once I followed his directions...thanks xixou!
  14. Wolfman 99

    Wolfman 99 New Member

    Could someone help me with this please?

    I tried to extend my partition as in the 1st post and thought i had done everything correct but now my pc wont boot up. I get the message.

    Recovery
    Your pc needs to be repaired. The digital signiture for this file could not be verified. Error code 0xc0000428. You need to use recovery tools. If you dont have intillation media like usb or disc contact device manufaturer. Press windows key for UEFI firmware setting.

    Only just bought the pc & gutted i messed things up on it already. I only have an air mouse and pressing the windows key on that doesnt seem to bring up any UEFI setting.



    Thanks for any help.
  15. awjester

    awjester New Member

    Wolfmain: If you have another Windows 10 system, create a USB Recovery drive. Insert USB drive, while booting up press F11 until you see the boot menu. Select the USB drive and find the boot recovery option under a sub-menu. Ask if you have questions.
  16. Wolfman 99

    Wolfman 99 New Member

    Thanks for the quick reply awjester. Yes got another PC so will create a USB recovery drive and let you know how it goes.
    Thanks again for your help appreciate it!
  17. lukasware

    lukasware New Member

    Last edited: Jul 26, 2017
  18. awjester

    awjester New Member

    We have update the BIOS (to 1.66) and upgraded to Windows 10 Home Creators on ten of these Z83-4 systems. After updating, about three or four had this non-booting error. Creating a USB Recovery drive from a working system solve the problem without reinstall any drivers.

    As lukasware said, "finding and reinstalling the drivers is not straightforward", so everyone please create a USB Recovery drive using the "include all drivers" option when you have a working system.

    Also about half of the Z83-4 systems came with 500MB boot partition, so the resizing was not necessary for those system.
    Last edited: Jul 26, 2017
  19. Wolfman 99

    Wolfman 99 New Member

    I managed to get it sorted thanks people. I borrowed a keyboard and managed to get into start up repair by pressing f9 and that did the trick without making a recovery drive. Not sure what happened but everything works fine now. Windows creator fully installed after the restart as well without any problems, which left me with only 1.7 GB of storage but followed these disk clean up instructions http://www.thewindowsclub.com/remove-previous-windows-installations Now got 12 GB free. Thanks for helping people appreciated. (y)
  20. Peter Harp

    Peter Harp New Member

    Well this has been a complete disaster for me. On my first 'BOX', yes that's right, I tried this on already, everything seemed to go OK. It updated and went without a hitch........... for about 2 weeks. Then, without any warning I powered on the box, blue light on, login screen came up, windows booted, I selected Kodi, Kodi booted, then, then nothing. The screen froze. I held power button in for 10sec until power off. Then, every time I powered on again all I got was the blue light, nothing else, no picture, nothing.

    I tried 'pinging' but got "timed out" message. This box was NOT going to start. So I contacted Minix. They sent me a new box, problem was it didn't come with the latest Win 10 'Creator' update, so, I decided to update it before loading anything else on. Sure enough I got the "Reserved" message that it could not install update due to reserved space. So, I went through the steps I did first using the 'Mini Partition' tool.

    Again everything went well until it rebooted to save changes and create new partitions. All I got was a Blue Screen saying that my device was 'broken' and needed fixing using recovery tools or recovery media neither of which I have. Error Code - OxC0000428

    Nothing I do now gets past this screen. Result, 2 'broken boxes'.

    Does anybody have any ideas?